14 Replies Latest reply: Mar 11, 2010 5:30 AM by thebookdoc@aol.com
Cory Shubert Level 1 Level 1
Issue: SDHC cards that used to mount when connected via USB card reader now will not mount. DiskUtility will see them but will not mount. Repair tab doesn't do anything. Same card can be put in a PC laptop with built in reader and the files download just fine so it is not the card.

Tried both a SD card and the SDHC, same issue on iMac 24" OSX 10.5.6 with recent updates via Software Update screen.

Anyone else come across this out on the web? Is it an update issue of the OS or something else that is conflicting with SDHC cards?

Thanks,
C

24" Intel iMac, 17" Core 2 iMac, 2 Intel MacBooks, Mac OS X (10.5.6)
  • Király Level 6 Level 6
    Do you have the same problem when logged in to a different user account?
  • Cory Shubert Level 1 Level 1
    Yes, still happens. I logged in with my tester account and still the darn card won't mount.

    I am using the SanDisk Imagemate 12 in 1 that supports SDHC and have been using this for a year or so without any issue, but now it is just not working. Like I said, it can't be the connection cuz the lights are on and DiskUtility sees the card, it just won't mount it, that is what is so strange.

    Thanks,

    c
  • Cory Shubert Level 1 Level 1
    UPDATE. I just tried to mount a CF card and the same thing, I can see the card in the list in DiskUtility but it will not mount. But, a USB external drive will mount, just not SD or CF cards.

    For some reason my firewire 400 drives, 3 of them, are mounted and working, so this seems to be a USB issue as far as I can tell right now and specific to removable media as in cards.

    This one has me stumped...
  • Cory Shubert Level 1 Level 1
    Well, I think I solved it but not sure how... all I did was download and install the 10.5.6 combo updater off the Apple site and the SDHC card popped right up as it always has.

    I guess I won't complain and just assume that in a backup or something, a file or directory got lost or messed up and the combo update fixed it?

    Oh well, crossed fingers and moving on.

    Cheers,

    c
  • Ralph Giorno Level 1 Level 1
    My software update says I am up to date, but my macbook pro, macbook and macbook air will not mount sdhc cards greater than 1 gb in size, either with a usb reader or an expresscard reader. CF cards of any size are no problem.
  • Ralph Giorno Level 1 Level 1
    Actually seems my card readers were too old, I tried a kensington part # fcr-hs219/1 and all the cards were visible
  • malau Level 1 Level 1
    I've been able to mount CF and SD cards of any size using a generic multi format reader on my Powerbook G4 but on my MacBook it does not mount the card/s if it has a capacity of over 1GB using the card reader.
  • KPAMN Level 1 Level 1
    I managed to get my card (Verbatim SDHC Premium 16GB 133Xread 60Xwrite) in the canon G7 picked up only through iPhoto. Nothing else worked.

    Hope this helps
  • ReindeR Rustema Level 1 Level 1
    Kingston 512MB SD cards do not mount on my 1 month old MacBook Pro with the latest software. I tested two of those, one I just bought in a shop.

    I need to use these cards, because cards >1Gb do not work properly in my iLiad eReader according to Mobileread.com.

    Other cards do mount. I have an old 8Mb JVC or a 2Gb.

    System Profiler says:

    Kingston:
    Capacity: 477,9 MB
    Available: 476,8 MB
    Writable: Yes
    File System: MS-DOS FAT16
    BSD Name: disk1s1
    Mount Point: /Volumes/Kingston

    The contents of the card are visible when I use Terminal to go to /Volumes/Kingston

    How to proceed from here?

    TIA!
  • "80 GB" iPod Level 1 Level 1
    Same problem, just happened 8 days ago! Using Mac OS 10.5.8(up to date). From one night reading my SD card and having everything fine to the next morning suddenly not reading it:(

    I tested a few SD cards, it reads some, others do not register and others ask to initialize.

    *Noticed it is the SDHC and HD ones, the low quality simple ones read fine.*

    High quality SD cards and SD reader work fine on PC

    Also, I doubt this is a factor my higher quality SD cards are 4GB and 8GB while my low quality cards are 2GB.

    Reset SMC does not seem to help. May need to re-install operating system but do not know if that will help as it seems to be an update problem. Please let me know if you noticed the same problem, here is to hoping this is fixed SOON :}
  • JollyOlly Level 1 Level 1
    Same problem here after updating to 10.5.8. The SDHC cards have been working perfectly for 5 months with a card reader and this evening they all just stopped working.

    I managed to get some images off using Image Capture and connecting the camera via a USB cable, but the cards (one Sandisk 8GB and one Transcend 4GB SDHC) will no longer mount on the desktop.

    Was a solution ever found to this problem?
  • Jdiddy Level 1 Level 1
    I'm having the same problem mounting a leica m8 using 8GB sdhc class 4 card. I heard this camera did not initially support sdhc, so it might be an issue. I was able to mount my dlux4 just fine using the same card. I'm really confused, not knowing if the problem is with my camera or the OS. iPhoto can detect the camera but i can't access my DNG files.
  • thebookdoc@aol.com Level 1 Level 1
    This still appears to be an issue. I have a card reader that I was using with my laptop and desktop and now it works on neither. What is the fix??
  • thebookdoc@aol.com Level 1 Level 1
    As per an earlier post in this thread, I looked for the OSX 10.5.8 Combo Updater and installed it. Though my 10.5.8 was current, the Combo Updater seems to have repaired the USB connection issue. I would recommend this to attempt to solve the issue, but be sure to get the combo updater for your system, and BACKUP before installing.

    http://support.apple.com/downloads/MacOS_X_10_5_8_ComboUpdate