10 Replies Latest reply: Apr 5, 2009 5:55 PM by lissy79
lissy79 Level 1 Level 1 (0 points)
I initially had a problem getting my itouch connected to my secure wireless internet. Finally figured that out.

After it being connected perfectly fine for about a week, suddenly my itouch won't connect. It had the password and even occasionally has the connected wireless lines. My internet works because I'm using it on my laptop. I have "forgotten the network" several times and reentered the password. I have turned off my router and the itouch for a couple minutes and restarted both to no avail.

Are there settings on my itouch I need to select that aren't selected? Occasionally it shows the IP Address and subnet Mask and sometimes it doesn't. Either way, it doesn't work. When I go to gmail, I get the error: Cannot get mail. The connection to the server "imap.gmail.com" failed.

For the App store it says: Cannot connect to itunes store.

For facebook it only has the newsfeed from the last time I checked it a couple days ago.

Any suggestions since my wireless DOES work?? Thank you!

ipod touch
  • luvlabs Level 4 Level 4 (3,610 points)
    Welcome to Apple Discussions

    Your type of problem is usually fixed by reseting Network Settings on your iPod. Go to Settings > General > Reset > Reset Network Settings and tap that. After your iPod restarts, go to Settings > WiFi and log back on to your network (you will have to reenter your password).

    That should fix it, but if the problem persists, write back.
  • lissy79 Level 1 Level 1 (0 points)
    Just tried that. It's not asking for my password. I also don't have the "forget this network" button.
  • brendennc Level 1 Level 1 (0 points)
    My Ipod Touch has the same problem it says it is connected to the internet and even has the little signal bars but I can't pull up any app that requires wifi. I have tried to restore my Ipod Touch and Reset the Settings but it still doesn't work.
  • luvlabs Level 4 Level 4 (3,610 points)
    Is your network open or are you running encryption?

    Before you do anything, turn off your router, wait a few seconds, and turn it back on.

    If you have an open network then there are two quick, easy things to try. Go to Settings > WiFi and turn off WiFi. Wait a few moments and turn it back on. Is you iPod reconnecting to the network?

    If it does reconnect, tap on the blue > next to your network name. You should get an IP address other than 169.x.x.x (home networks are usually 192.168.x.x). If you do not, tap DHCP, scroll down, and tap Renew Lease. You IP information should refresh.

    Assuming you have normal IP addresses, try going to a website. If that doesn't work, try typing http://74.125.45.100 This address will take you to Google.

    Let us know the results of you work.
  • lissy79 Level 1 Level 1 (0 points)
    It is still not working.

    1. When I go to setting and do the renew lease, my router info never comes back.
    2. I tried going to safari and entering goggle's IP's address in Safari and that didn't work. Error is: Cannot open page. Safari cannot open the page because it is not connected to the internet.

    as a side note, in the wifi settings, it says it's connected to my wireless and my wireless has a full signal. I do not; however, have the wireless symbol at the top of my ipod where it says ipod.

    Additionally, before I tried this round of directions, I tried to go to the internet again just for the heck of it, it did ask for my password when I went into gmail. I entered it, it accepted it and then I got the usual error. I think it was asking for the password from the previous instructions you gave when I said it wasn't asking for a password.

    Message was edited by: lissy79
  • xtriptychx Level 1 Level 1 (0 points)
    I have the same problem. It will connect, and it claims to have a full signal, but no apps will use the internet.

    I've never had this until recently.
  • luvlabs Level 4 Level 4 (3,610 points)
    Lissy,

    If you do not have the WiFi connection symbol at the top left, you need to reset the network settings. You do that by tapping Settings > General > Reset > Reset Network Settings. You iPod will restart and you should be able to log on to your network.
  • luvlabs Level 4 Level 4 (3,610 points)
    Do you have the WiFi symbol in the top left of your screen? If not, reset your network settings as in my response to lissy.

    If you have that symbol, please start a new post and give us more details of your network setup, router, etc.
  • applegenius18 Level 3 Level 3 (890 points)
    have you tried renewing your lease after you tapping on the blue arrow, because you said it worked before. and btw, where is your wifi signal coming from?
  • lissy79 Level 1 Level 1 (0 points)
    I've tried the past two suggestions already, BUT...

    It appears that suddenly (without trying those again) that it has started working again. I was able to use my neighbors unsecured network. Then a couple hours later I tried our secure network and it suddenly worked. Hopefully it will "stick."

    Thanks for your help. I'll be back if it happens again.