6 Replies Latest reply: May 27, 2009 7:57 PM by David in Germantown
Neil2 Level 1 Level 1 (0 points)
I have iTunes 8.02 and an original iPhone with os 2.2. I have iTunes set to sync iCal to the iPhone, and during the sync it says it is syncing calendars, but the events on my phone are different from the ones in iCal on my Mac.

I went into the iPhone>pref>mail, contacts, calendars>my mobile me account, and I checked "sync calendars," but that erased all my events from the iPhone. That was not what I was looking for. I had to restore from backup.

I seem to remember it working in the past, but this might be the first sync since .mac changed to moble me. Thanks.

PowerMac G5/2x2, a MacBook C2D/2.0, iPhone, 1st & 5th gen iPods, Mac OS X (10.5.6)
  • Jason L Community Specialists Community Specialists (10,515 points)
    Hi Neil,

    There is a new version of iTunes and iPhone software available, updating may resolve the issue.
    http://www.apple.com/itunes/download/
    http://www.apple.com/iphone/softwareupdate/

    If updating does not resolve the issue, try the tips in this article: http://support.apple.com/kb/TS2481

    -Jason
  • Neil2 Level 1 Level 1 (0 points)
    OK, now I run iTunes 8.1.1 and iPhone os 2.2.1, but I still have the same problem syncing calendars. The funny thing is that I get sync conflicts announced for some holidays, but I checked the box to sync ALL calendars. I'll now try the Apple support doc you linked. Thanks.
  • Neil2 Level 1 Level 1 (0 points)
    I tried to reset my iSync data according to the instructions in the link, but that option was greyed out in iSync. While I was there, I looked at my iSync log and it was blank. Hmmm..

    Also, I checked my iCal calendars on the web. I saw that all of my events from my iPhone made it to the cloud, along with at least one event I entered on my Mac about a year ago, but I'm missing events added on my Mac for about the past six months. Is that info useful for diagnosing the problem? Thanks.
  • Neil2 Level 1 Level 1 (0 points)
    I finally also tried to reset sync services via Terminal, but it timed out.

    " exception while performing selector _reallyResetSyncData on server: NSPortTimeoutException connection timeout: did not receive reply
    PerlObjCBridge: NSException raised while sending reallyResetSyncData to NSObject object
    name: "ISyncServerUnavailableException"
    reason: "Lost connection to the sync server: NSPortTimeoutException: connection timeout: did not receive reply ((null))"
    userInfo: ""
    location: "/System/Library/Frameworks/SyncServices.framework/Versions/A/Resources/resetsy nc.pl line 16"
    ** PerlObjCBridge: dying due to NSException"
  • Neil2 Level 1 Level 1 (0 points)
    Even though I got that error message in Terminal, that command seemed to do the trick. I couple minutes after I posted that message a new sync started that showed up on the Mobile Me iCal web page.
  • David in Germantown Level 1 Level 1 (45 points)
    Try deleting the Calendar Cache file in users/Calendars/

    This solve the problem for me. iCal wasn't syncing with MobileMe either but this solved both problems.