10 Replies Latest reply: Sep 18, 2009 7:50 PM by Lyle Millander
Lyle Millander Level 1 Level 1 (0 points)
I'm working on someone's PowerBook G4 and stumbled on an issue that may help some folks. The specific unit is a 15" PowerBook G4/867/DVI with 512MB and a Gigabit Ethernet port.

The problem exhibited as poor network connectivity via the Ethernet port. The DHCP assigned address would sporadically toggle between a network assigned one to a self-assigned address. The port itself toggled from online to offline repeatedly.

The user did not report this problem when the unit was at their home (although it looks like the user never had it networked as the unit had OS X 10.3.0). The problem started when the Powerbook was connected to my workbench Netgear gigabit switch.

The workaround was to force the Ethernet port to 100BT vs. allowing it to auto-configure to 1000BT. This is done via System Preferences/Network/Show:Built-in Ethernet/Ethernet Tab/Configure: Manually/Speed: 100baseTX/Apply Now. Conventional trouble-shooting steps had no affect (disk repair, permission fix, cache clear, pram reset, nvram reset).

Hope this helps someone. Responses welcome.

Lyle Millander

( keywords: PowerBook G4 Ethernet port failure dropout intermittent fix network self-assigned )

PowerBook G4 15" 867MHz, Mac OS X (10.3.x), Gigabit Ethernet
  • kmac1036 Level 4 Level 4 (2,360 points)
    does installing the latest updates for 10.3 fix it?

    would it do the same thing if you booted from a 10.4 external drive?
  • Lyle Millander Level 1 Level 1 (0 points)
    Hi kmac1036,

    I upgraded the OS from 10.3.0 to 10.3.9 with the combo updater (copied via flash drive) and the problem remained. After backing down to 100BT, I installed all the remaining updates via the Ethernet connection.
    At that point I didn't bother testing again. All indications pointed to a hardware problem and the laptop's owner would have been happy at 10BT.
    Thanks for the chime in.

    Regards,
    Lyle Millander
  • wusup2u Level 1 Level 1 (5 points)
    It's strange. I have the same problem on my 15" PowerBook G4 1.5Ghz with 1Gb of ram and also a Gigabit ethernet port. It also happens on my Airport connection. It will sometimes connect but try to use a self-assigned IP address and the internet will not work. I tried deleting the connections and then adding them in again. No luck. I tried deleting the Locations and adding them back in. Again, no luck. I tried shutting down my laptop and turning back on with still no luck. I am getting very annoyed by this frequent problem.
  • Leoiki Level 1 Level 1 (0 points)
    Wow. I wish I saw this post two months ago - thank you Lyle for posting your solution. I had the same intermittent ethernet on my PowerBook G4 15" 1.25Gh, on the Gigabit port, running 10.5.6. I tried all of usual troubleshooting techniques Lyle mentioned. I proved my hardware was okay by reinstalling the OS and ethernet was rock solid. The problem came back when I restored from a cloned backup - implicating bad software or settings. The problem cleared up when I trashed the network configuration preference (plist) file, restarted, then recreated the ethernet connection with the original settings (jot them down on paper). Open up network preferences, jot down your ethernet settings on paper, close network preferences, drag the network settings file to the trash, restart, then recreate your ethernet settings. Preference file corruption? Likely. I just didn't think trashing a preference file would work for network stuff, but it did for me. Just another troubleshooting technique to keep in your toolbox.

    root/library/preferences/com.apple.networkConfig.plist

    Just an aside: this same PowerBook two months later is now showing signs of NO ethernet activity on the Gigabit port. Loading a new OS, zapping PRAM, changing cables, switch ports, etc, no activity (e.g. "Cable Disconnected"). The port looks good, no bent pins, was working great last week. Airport works great, new battery, 2 GB RAM, passes the Apple Hardware Test on the original DVD's, <sigh>, I guess it's time to sell ... unless anyone has more ideas about that Gigabit port?
  • Leoiki Level 1 Level 1 (0 points)
    Follow up...I spoke with an Apple tech and he agreed I probably have a dead Gigabit port. Too bad the port is soldered directly to the logic board. Trading in my old logic board and replacing starts around $700 USD. Instead he agreed with my solution of purchasing a gigabit ethernet card to fit the 15" G4's PCMCIA card slot. I got a Netgear GA511 card at $29 USD from Amazon - free shipping! So, goodbye ethernet port and hello to an inexpensive alternative. While I was doing research, I notice there are a lot of things you can put into that old PCMCIA slot. Wow...great engineering future proofed me, thanks Apple! I'm sure glad my new MBP 17 has a "legacy" ExpressCard/34 slot ... just in (future) case. Good luck with your problem and hope this thread helps you.
  • Alan Carwile Level 1 Level 1 (10 points)
    My 15-inch PowerBook G4 867 ethernet and airport are working fine at home (10/100 not 1G for wired, but 802.11n for wifi). However, at a second location, it has very inconsistent behavior. Loading of simple web pages works fine. Loading of complex pages like http://www.linkedin.com (after login) or of http://www.facebook.com experiences problems. Tried a different ethernet wall jack at the second location. Activity Window indicates network connection problems on a couple files that make up the web site.

    Using a friend's newer mac, there was not an issue. Using a dell windows pc, there was no issue.

    Tried going to 100BT full duplex, but no luck. I thought it would work.

    Suggestions appreciated.

    Alan
  • Leoiki Level 1 Level 1 (0 points)
    Hi Alan,
    Sorry, I don't have Tiger (OS 10.4) installed. Your testing with a newer mac and the Dell makes me think the ethernet connection is working okay, but it doesn't answer if your PBG4 network settings need adjustment or your browser (Safari or Firefox?) are causing problems in your second location.

    You could test if there is some data packet loss as seen by your PBG4 at your second location. Go to Spotlight > find and run Network Utility > click on Ping > and type in www.apple.com or your router's ip address if you know it. See if you have any data loss. Sorry if the location of Ping is different in 10.4.

    Maybe your PBG4's network location settings for your "second location" is needs to be deleted and recreated (try to recreate a new "location" with exactly the same settings as your home location). Here's how:
    http://docs.info.apple.com/article.html?path=Mac/10.4/en/mh630.html

    Maybe you need to load the highest version of Safari or Firefox that Tiger supports and try your testing again.

    Even more radical is to borrow someone's retail Leopard install DVD and upgrade yourself to Mac OS 10.5 Leopard, if you have sufficient RAM and hard drive space on your PBG4. The network config screens and tools in Leopard are MUCH improved compared to Tiger. Have fun with Leopard - it's the last OS that Apple says can be installed on our PBG4's.

    Your clue about the consistent network connection problem that occurs on the (same) couple of files that make up the complex website is interesting. Something about those files is highlighting some kind of weakness at your second location. Too many combinations of router/browser/OS/network settings - time for more testing! Those complex webpages have got to be more current than the OS / browser combination you're running. Good luck, write back and maybe you can get Lyle back on the line.
  • Troup Nightingale Level 1 Level 1 (0 points)
    For WUSUP2 concerning the self assigned ip address under DHCP. My son's 1 year old 15inch Macbook Pro just had the same problem. A little history. We have an old G4 Imac with the round base and connected swivel 15" monitor. We took a lightning hit near the house which entered wires and killed a few devices. Among them, it took out the ethernet port in the imac and the hardwired LAN port it was connected to on the Apple Airport Extreme. Also took out the WAN port on the Airport Extreme. Resyt of the computer and the external drives are fine. Just killed the ethernet. The ethernet port en0 reports failure under network diagnostics. Ok, tried to see if my daughter's brand new 13" Apple MacBook could connect. BTW, the Airport is connected to a cable modem using Comcast high speed internet access.

    I found that I could connect the computer hardwire to one of the Airport LAN connections and connect the cable modem to the Airport using another LAN (not WAN) connector. Works great. Can communicate to the internet at high speed with no problems. Guess it thinks the internet is part of the LAN!

    Ok, now to the self assigned ip problem. My son wanted on the internet, so I disconnected my daughter's laptop and connected his. No internet. Went to the network setup and there was the DHCP self assigned ip address problem. At first nothing we did worked. Finally went to manual and typed in all the settings that were in my daughter's DHCP. Seems like we then rebooted the cable modem. His system then still did not connect to the internet, but it got rid of the self assigned ip issue. We then reset the settings to auto using DHCP. After APPLYING, it was missing some settings and could not connect to the internet. We then rebooted the cable modem again and VOILA! It brought down all the DHCP settings and we instantly connected to the internet. This happened a few days ago and he has not had a problem yet. SO, there is a way around this problem. If you do not have another working computer to copy the settings, you may be able to get settings from your ISP.
    Good luck!
  • Troup Nightingale Level 1 Level 1 (0 points)
    For those who wonder, we could have connected directly to the cable modem for a single system connection. We actually did try this while trying to fix the self assigned ip problem. Come to think of it, we may have done all our trouble shooting while directly connected to the cable modem.

    Update: Purchased another apple AirPort Extreme. All ports work on it and the cable modem is back on the WAN port. The Imac ethernet port is still dead no matter what it is plugged in to. Forgot to mention that when the other AirPort Extreme WAN and one LAN port bit the dust, the WIFI portion bit the dust, too. The AirPort could not be seen using WIFI. It was seen by a laptop when hardwired to a LAN port. But then in the middle of the troubleshooting, I received an UPDATE message that there was an update for the AirPort software Utility. Hmmm, so, I did the upgrade. Never saw that older AirPort after the Utility was updated!!!! The AirPort was really messed up by the lightning strike and it was NOT on a surge protector.
  • Lyle Millander Level 1 Level 1 (0 points)
    Hi Leoiki,

    Wow, I have been offline for a while. You're very welcome and I'm glad my suggestion put you on the correct path.

    When it comes to troubleshooting, I tend to go with the divide and conquer approach. The GA511 card you purchased is a good troubleshooting tool - I keep one in my bag. I also keep a bus-powered USB/FW drive handy with multiple partitions that have clean OS installs and a few favorite utilities. Booting from another drive really helps to narrow down the possibilities.

    Everything you suggested for Alan is right on track. A few months have passed and I'd wager his issue is behind him by now. If I had stayed current, I would have suggested putting his friend's "newer Mac" into Firewire target mode and booting from it on the errant PowerBook (if the OS was PPC compatible). Alternatively (and safer), just cloning the "newer Mac" to an external drive and booting from that. Booting from a known working OS install would quickly provide some clues.

    Good choice on the 17" MBP. Shame the 13" and 15" lost their expansion slots. SD was a nice addition, not a replacement.

    All the best,
    Lyle Millander