3 Replies Latest reply: Apr 12, 2009 6:11 AM by phicks1
phicks1 Level 1 Level 1 (0 points)
Good Morning/Evening

I have had my Macbook for about two months now and loved it. About a month ago it went from downloading a film from Itunes in around 30mins to 12hrs!. Also when I try to access any websites with pictures it takes a very long time to load and downloading files again takes an age. I also own an imac that is running fine. I have tried connecting direct to the home hub with my macbook but there is no change in speed, this is while the imac is offline as well. As I use my macbook in my home office I hope there is a way to speed this up.

Hope you can help?

Paul

Macbook 10.5.6, Mac OS X (10.5.6)
  • Klaus1 Level 8 Level 8 (46,785 points)
    The following usually works on both Tiger and Leopard:

    (First, if yours is an Intel Mac, check that Safari is not running in Rosetta, which is enough to slow it to a crawl.)

    Adding DNS codes to your Network Settings, should gives good results in terms of speed-up:

    Open System Preferences/Network. Double click on your connection type, or select it in the drop-down menu. Click on TCP/IP and in the box marked 'DNS Servers' enter the following two numbers:

    208.67.222.222
    208.67.220.220

    (An explanation of why that is both safe and a good idea can be read here: http://www.labnol.org/internet/tools/opendsn-what-is-opendns-why-required-2/2587 / )

    Whilst in System Preferences/Network you should also turn off 'IPv6' in your preference pane, as otherwise you may not get the full speed benefit (the DNS resolver will default to making SRV queries). If you want to know what IPv6 is:

    This is Apple's guidance on iPv6:

    http://docs.info.apple.com/article.html?path=Mac/10.5/en/8708.html

    Click on Apply Now and close the window.

    Restart Safari, and repair permissions.

    If that didn't do it, then try this as well:

    Empty Safari's cache (from the Safari menu), then close Safari.

    Go to Home/Library/Safari and delete the following files:

    form values
    download.plist

    Then go to Home/Library/Preferences and delete

    com.apple.Safari.plist

    Repair permissions (in Disk Utility).

    Start up Safari again, and things should have improved.
  • bediddleby Level 1 Level 1 (35 points)
    Also make sure you aren't suffering from duplex mismatch; #1 cause of individual network performance problems, IMHO. Check your Ethernet adapter's Advanced/Ethernet settings. If it's set to "automatically" configured, then what are the values grayed out below that? You should never see 'half' duplex unless you're running 10mb (which most aren't!)
  • phicks1 Level 1 Level 1 (0 points)
    I use Firefox normally would this make it worse?. It is also when I have software updates it takes an age to download as well.