1 Reply Latest reply: Apr 30, 2009 6:19 AM by Grantman
TigerSSMac Level 2 Level 2
I canot seem to get Flash Video embedded on a webpage to play via my optical output. Tried all the sys prefs setting etc. No joy. I've also googled my fingers off to no use. OK so I've tried all the steps from below even another where people said to try GarageBand and then the webpage (in this case YouTube video). Nothing works.

+From Apple's Support Knowledgebase:+

+No sound from some applications, but system alert sounds play (Mac OS X 10.3, 10.4)+
+Some audio applications may change your computer's audio settings to a sample rate that is too high for other applications to use. In this situation, system alert sounds still work, and does iTunes, but other applications may have no sound (audio output). This document applies to Mac OS X 10.3 or later and applications that use QuickTime 6 for audio, such as Safari and Quicktime Player.+

+This can happen on Macs that support high sample rates (higher than 48000 Hz):+

+iMac G5+
+Mac mini+
+Power Mac G5 models that support sample rates higher than 48000 Hz+
+PowerBook G4 support sample rates higher than 48000 Hz+
+For example, if you play an Internet movie in Safari, it will make no sound; if you open a QuickTime movie on your computer, QuickTime Player reports the following error (and the movie will have no audio):+

+"You may experience problems playing a sound track in (Movie Name).mov because a software component needed by the movie could not be opened."+


+1. Open Audio MIDI Setup (/Applications/Utilities/), then check the Audio Output setting.+
+2. Change the Audio Output setting to 44100.0 Hz.+
+3. Quit Audio MIDI Setup.+

Kind of blows to have a big bad Mac Pro hooked to my 7.1 surround setup and a 46" XBR HDTV and not be able to play sounds through the system when following a YouTube link. Quicktime video, DVD Player, everything else works fine. So does anyone else have any suggestions?

So does anyone else have any suggestions?

MacPro Xeon Q2.8's (retired: SE/30 IIci Q800 8500 9500 G3 G4 G52.7s MPro D2.66s), Mac OS X (10.5.6), 10GB Ram, 3TB, some externals, eyeTV hybrid, AirPort Express etc...
  • Grantman Level 1 Level 1
    I'm experiencing the same issue. I went to my MIDI setup but it said that "output was not supported."

    There's another fix, however, that some people have written in on. Open Garage Band, plunk a few notes. Save it. Close it out and then reboot Safari (or whatever browser you have). It should work fine. It did for me...for a little while and then my Safari went dead again.

    I'm stumped, frankly, but the Garage Band workaround might work for you, so give it a shot.