7 Replies Latest reply: Apr 23, 2009 4:19 PM by MontyG
iphanatic Level 1 Level 1
I have searched and ready the other threads with the same name, as listed below. Those threads are closed and archived, even though they did not create a solution for me. Please help. This is a frustrating problem that I can't seem to fix.
I'm using iPhoto '09. This may or may not be the issue as far as compatibility with the iPhone.

I had the issue before and still could not find a solution. Then once an update came out it fixed the problem. I currently have over 100 photos on my phone and don't want to lose any of them. I have tried deleting some but it doesn't change anything.

I've tried the suggestions in these threads to no avail:

iMac, Mac OS X (10.5.6)
  • Jason L Community Specialists Community Specialists

    Can iPhoto import photos from other cameras?
    Can Image Capture import the photos? The Image Capture application is located in the Applications folder.

    Make sure the iPhone is directly connected to the back of the iMac, using the cable that came with it.


    Message was edited by: Jason L
  • Envision99 Level 4 Level 4
    Why don't you tell us exactly what is happening when you connect your iPhone and open up iPhoto. We need to hear what problems you are facing so we can help you. When you create threads you have to be clear on the issues you are facing so everybody knows whats going on. Referencing other threads is helpful, but if we don't know the exact problem you are facing and the error messages surrounding it we won't know where to start.
  • S1nfullman Level 1 Level 1
    I'm having a similar problem. This is the first time I've tried importing pictures off my iPhone since upgrading to iPhoto '09. What happens is the phone shows up in the left panel and an outline is drawn for every photo on my iPhone but thumbnails of the actual pictures don't appear. I tried selecting them and importing anyway but I get an error that says "Error Downloading Image: iPhoto cannot import your photos because there was a problem downloading an image. I tried the things suggested in the 2 other posts also to no avail.
  • Stewart Lynch Level 1 Level 1
    I am having the same problem with my MacBook Pro 15" iPhoto. I also have a MacBook Pro 17" both running 10.5.6 and iPhoto 09
    I can import fine from my 3G iPhone into my iPhoto on my 17" but get the error on my 15" MacBook.
    "Error Downloading Image: iPhoto cannot import your photos because there was a problem downloading an image"
  • Envision99 Level 4 Level 4
    If that is the case, I would say it is a problem with the iPhoto application and you need to call Apple, or post inside of the software forum. Since you can import the pictures from your iPhone on one computer and can't on another, the iPhone is not the problem, it is the software on the computer.

    It sounds like you are having the same problem S1nfullman, so if I were you I would call Apple as well, or go and post inside of the software forum.

    I bet both of you will have the same problem if you connect any digital camera to your computer and try to import the photos inside of iPhoto.
  • Jason L Community Specialists Community Specialists

    Try launching iPhoto while holding the Option key and creating a test library. This article: http://support.apple.com/kb/HT1229 provides more information about moving and switching between iPhoto libraries.

    If you don't see the issue when using the test iPhoto library, try rebuilding the original iPhoto library as described here: http://support.apple.com/kb/HT2638

    If you do see the same issue with the test library, try importing the photos using the Image Capture application.

  • MontyG Level 1 Level 1
    I had a similar problem with importing impages from my USB SD card reader. I tried importing images using my iMac, Macbook Pro, and a new Macbook Pro unibody and got the same error, "iPhoto cannot import your photos because there was a problem downloading an image." I finally realized that the problem was either the memory card or the card reader itself. I switched to an older usb card reader and had no issues after that.

    I am not sure if this is the same problem that you are facing with your iphone but if you cannot import images using a fresh iphoto db and or os test account, then I would seriously look into the possibility that the iphone itself could be the source of your issues.