0 Replies Latest reply: Apr 13, 2009 12:05 PM by Cheryl Tarbox
Cheryl Tarbox Level 1 Level 1 (30 points)
I posted this earlier today to the Podcast Producer board. But it looks like this may be a more appropriate place for it. Any suggestions are greatly appreciated.

Cheryl

Hello,

I have been working on getting a Podcast Producer server up and running for a few weeks now. I have made a lot of progress in this endeavor, and without this forum would still be struggling with some things.

Here is my setup:

Dual 2.3GHz Power PC G5
2 GB DDR SDRM
Fresh install of 10.5, upgrading immediately to 10.5.6
DNS resolves correctly
Services running:
AFP
Mail
NFS
OpenDirectory (Master/Kerberized)
PodCast Producer
QuickTime Streaming
Web
Xgrid
Shared File System: /Volumes/PCP_SFS

Bound to AD Domain Controller with AD Plugin to allow users to login to blog/wiki website with their Active Directory credentials.

SSL enabled on Web Services to protect AD login credentials: http://support.apple.com/kb/TS1619. Valid certificate from DigiCert for our university domain installed.

All is working well, EXCEPT, when using Safari and logged in to the wiki/blog and clicking on the 'Subscribe to iTunes' link, instead of getting the URL:

itpc://macosxserver02.binghamton.edu/groups/podcasts/blog/index.its which launches iTunes and downloads the Podcasts in the wiki/blog website as advertised. (This works w/o SSL enabled)

I get:

feed:https://macosxserver02.binghamton.edu/groups/podcasts/blog/index.its

which opens an RSS window in Safari with the Podcasts, and asks me to log in again.

If I try the "subscribe to iTunes" link in Firefox, it downloads the index.its file.

I have tried all the suggestions in this thread:

http://podcastproducer.org/forums/setting-up/982792036/view

but have not had any success with either the 'redirect' suggestion or the suggestion to change a line of code in the /usr/share/wikid/lib/python/apple_wlt/WeblogHTMLRenderer.py which must have been written for an earlier version of Leopard, because this line of code does not exist in this file in 10.5.6.

Any suggestions on how to fix this would be most welcome. I have a feeling I just need to change the web protocol in a config file somewhere, but have no idea where.

Thank you for your time,
Cheryl Tarbox
Binghamton University

20" 2.4 GHz Alum iMacs, Mac OS X (10.4.11), 2 Netboot Xserves to manage ~100 clients in public computing labs