Previous 1 2 3 Next 64 Replies Latest reply: Jan 11, 2010 6:37 PM by Yawitz
6h057 Level 1 Level 1 (0 points)
Greetings all, two weeks ago I purchashed a MacBook Pro and iMac and they've worked fine, except for the internet. The wireless randomly goes out, but the airport bars remain. At first I thought it was just pages having trouble loading because of the OS (stupid I know) It's been happening more and more frequently and the only way to solve it is to turn the Airport off and then on which allows the internet to reconnect. My wireless router is connected to an HP an the router is a Dlink 1310 wireless G router. Any help would be greatly appreciated.

iMac and MacBook Pro, Mac OS X (10.5.6)
  • 6h057 Level 1 Level 1 (0 points)
    ::Update:: I plugged in my ethernet cord and disabled the Airport Extreme and so far the connection hasn't dropped. I'm assuming this rules out a Comcast modem problem, but still, I need this ethernet cord for my Xbox and was depending on my wireless for the laptop. It's getting very annoying having to stop every few minutes and turn Airport on and off. Could it be I just need to upgrade to a wireless N router? I read that N is backwards compatible so shouldn't my laptop work with a G router? I'm running out of patience, please help!
  • macaliasmac Level 1 Level 1 (0 points)
    I have the same issue with my brand new MacBook Pro. Don't upgrade to a "N" router as that will not solve your issue. I am using a new Netgear Wireless N router. It connects to all of my other laptops great (I have 2 PC laptops), but the MacBook Pro connection is sporadic at best. It is very frustrating. If anyone has a solution to this please help us!!!
  • David Hard Level 1 Level 1 (95 points)
    I'm in the same boat. I also use Comcast as my ISP. I've read somewhere that Comcast and Airport Extreme Base stations don't always play nicely together because of the way Comcast assigns IP addresses... or something like that. I've been having the same problem where my internet connection will drop at least 3 times a day. I usually reboot the cable modem to get it back up and running. When I do have a connection, it is extremely slow to where I'll often get "the server has timed out" error messages because it takes FORVER for a page to load... any page. This all started happening for me a few weeks ago. before that, everything was working OK. My speed was a little slower than what I expected of broadband. But at least the connection was stable. The only thing I can think of that has changed is that I did the firmware update. But I'm not entirely sure if I was having the connectivity issues even before I did that. I'd be curious to hear if you have done the firmware update recently as well. If so, that could be the problem. I'm not sure how to revert back to the older firmware version. I'll let you know if I learn anything else about my own problem. It sounds like we're having the same issue.
  • Bob Timmons Level 10 Level 10 (93,530 points)
    "I'm not sure how to revert back to the older firmware version"

    Open Airport Utility and click on Manual Setup
    On the next page, move your cursor to the word Version. It will turn gray.
    Click on Version to open another window that will allow you to choose the version that you would like to install.
  • 6h057 Level 1 Level 1 (0 points)
    Well, the problem seemed to go away when I messed with my router settings and changed the router name, but now the problem is back. It seems to only happen when I have more than one computer using the internet as I use my Macbook Pro. My laptop PC doesn't have this problem. It's getting really annoying now. I've tried Apple support and my routers support and still it doesn't seem to be solving the problem.
  • bigsaladnow Level 1 Level 1 (0 points)
    After waking from sleep I get the message "none of you preferred networks are available" although it lists my wireless network in the window with a padlock, and when I click on it I get network timeout. Dismissing the message and then connecting via the Airport menu icon usually works. Apple Support could not fix the problem after one hour on the phone. Problem is worse if the lid has been shut.

    MBPro late-2008
    MacOS 10.5.6 and 10.5.7 same problem
    Netgear router
  • mark strecker Level 1 Level 1 (125 points)
    I am having the same problem on a office network. It is only happening on one iMac. It happened after upgrading to 10.5.7. No problems with all the other computers that have been upgraded. I reset the PRam and did a Hardware Reset.
  • printmediaguy Level 1 Level 1 (0 points)
    You are not alone! This problem of Airports dropping signals seems to have started about a month ago. I, along with many friends have been experiencing the same symptoms. It is not a hardware problem. It is not an Airport problem, since PC's on the wireless network work fine. It is a software problem. Apple seems to be unaware of the problem, or is unable to solve it.
    There are hundreds of posts on this problem. I tried a dozen of the "solutions" but none worked for more than a day or so. The only solution is to plug in to my modem with a wire and wait until someone solves this huge and annoying bug in the software. Very disappointing.
  • bscepter Level 3 Level 3 (635 points)
    add me to the list. upgraded the AE to the latest firmware and upgraded to 10.5.7. now my wife's macbook drops its connection all the time while my macbook pro - in the same room - surfs just fine.
  • bscepter Level 3 Level 3 (635 points)
    i just reverted to the old firmware. let's see if that sorts it.
  • mark strecker Level 1 Level 1 (125 points)
    Alright, I did a clean install of 10.5, and the wireless worked again. Then I installed the combo update of 10.5.7, and the problem is back again. I also repaired permissions, ran Disk Warrior. Something is funky with 10.5.7.
  • scgreen Level 1 Level 1 (0 points)
    Add me to the list as well. I just bought a new 13" Macbook a few days ago and have been in the process of switching files over from my PC. The Mac keeps losing its wifi connection, and two pc's in my house continue to work fine. I've been using the same wifi and ISP configuration for the past year with no problems. I was beginning to think the mac I bought was a dud... sounds like this is a common problem, and definitely a software issue.
  • Vlado Damjanovski Level 1 Level 1 (0 points)
    Hi all,
    It seems I am not alone. There is a very strange problem either with my brand new unibody MacBookPro 17" or the Airport Extreme I am using to connect to the Internet via a cable connected router. The router I am using is Billion 7300 and works fine, and I can even connect to the wireless access via the router and all works fine. I am using Airport Extreme to extend the access area in my house and also use a USB drive for storage attached to the AirportExtreme. The funny thing is that the first couple of weeks I had no problems with the MacBookPro going on the Internet via the Airport. At that time I had the wireless part of the Billion modem disabled so as to avoid possible interference. Suddenly, one day about a week or so ago, the MBP would connect first time to the wireless Airport and to the Internet for only about a few seconds and then no update on any of the web pages. I was suspecting first my ADSL, but that was all along OK. The signal strength to the Airport is strong, but just the connection to the Internet is no longer available. Strange thing is I have in the same room a 24" iMac and this is still connected to the Internet via the Airport with no problems. Same settings on both! I tried everything I could think off on the Airport, tweaked, changed, reset and created new connection - but without any luck. It is as if the Airport decided to just block the MBP for whatever reason. I also have the Little Snitch, which I disabled too.
    I was hoping that the latest Leopard 10.5.7 would have a fix for such a behaviour, but no change.
    I cannot make any conclusion as everything contradicts: if the MBP wireless has a problem, I wouldn't be able to connect to the Billion wireless; if the Airport is at fault I should not be able to connect to it with the iMac. I go to work where other two brands of wireless hot-spots I use (D-Link and Billion 7402) and I have no problems swicthing between the two. It seems only Apple's Airport is a problem for my new MBP.
    It must be something in the software of the Airport or MBP ?!?!?
    I already spent three days trying to solve a problem that should be 'No Brainer" according to the Apple's design books. But I do have a problem that I did not know about before.
    Thank you in advance for any suggestions.
    Vlado Damjanovski, Sydney.
  • mark strecker Level 1 Level 1 (125 points)
    Well I fixed my problem by doing several Clean Installs. I found it that it work for this computer if I only updated it to 10.5.5, if I update to 10.5.6 or 10.5.7 then the problem exists. Every other computer is fine with 10.5.7 (15 macs- various imacs, macbook pros, mac minis, etc).
Previous 1 2 3 Next