13 Replies Latest reply: Feb 26, 2006 3:03 PM by lisabellab
Gerard BERQUEZ Level 1 Level 1 (5 points)
Hi

I can't eject the dvd.
I have open the firmware but in repy to eject cd : the answer was "can't open the eject device".
How to do ?

Thanks
  • S&G Level 1 Level 1 (5 points)
    Restart and hold mouse clicker down until disk ejects.
  • Gerard BERQUEZ Level 1 Level 1 (5 points)
    Thanks for you response but when, i made this, the dvd can't eject.
  • Francis Darstein Level 4 Level 4 (3,320 points)
    Hi Gerard,
    -launch the Terminal (application in your Applications / Utilities folder)
    -type: drutil eject
    -press the Enter key

    hope that helps

    Francis
  • Gerard BERQUEZ Level 1 Level 1 (5 points)
    Thanks for you response Francis,

    After use the terminal and you recommandation
    the mesage was ; " Could not find a valid device."

    Gerard
  • Francis Darstein Level 4 Level 4 (3,320 points)
    Gerard,

    looks like your device is out of services...
    Again in Terminal, type:
    drutil info
    and press Enter

    and see what the Terminal is saying about your internal drive;

    Also, you could use Burnerz to obtain all information about your drive, if it can find it.

    If both , the Terminal application, and Burnerz are not able to see the drive, I'm afraid that this drive is dead, or simply disconnected inside. In this last case it should be easy to check and to fix. Please see this Apple page about iMac G5, and what you can do yourself.

    Hope that can help..

    Good luck

    Francis
  • Francis Darstein Level 4 Level 4 (3,320 points)
    Gerard,
    I Just would add some additional information,
    I just re-read your original first post, and saw that you said, "I have open the firmware" , so the question is: what do you mean by this "I have open the firmware", ?
    Did you do something "special" on your System before this problem ?
    Is your Operating System installed in good conditions, of course you cannot boot from the installer CD, but what you can try at first is to launch a Permission Repair on your booting HD, and try to boot in single user mode in order to repair your HD if necessary.
    ------------------
    To run a Permission Repair follow these procedure below :
    -Launch Disk Utility , located here: Applications / Utilities / Disk Utility
    -select First Aid Tab
    -Choose the Startup HD in the left window part
    -Click on “Permissions Repair” button
    -Quit DU
    ---------------
    Then boot in single user mode and launch the fsck procedure, to repair your booting drive. Do it by the following procedure :
    -reboot while holding down both keys Apple and S
    -You will get a screen full of text, which looks like the old MS-DOS
    -at prompt :
    -type fsck -fy
    -press enter
    -wait for the message resulting after the process
    -if the message don't say that your HD seems to be OK
    -re type again fsck -fy
    -press enter
    -do it until you get a message saying that your HD seems to be OK
    -Then type reboot
    -Press enter

    be carefull when typing fsck -fy to respect space between fsck and -fy

    Francis
  • Gerard BERQUEZ Level 1 Level 1 (5 points)
    Thanks for you response, with diskBurner, the disk doen't appear.
    The drive may be out, also i do change it.

    best regards.

    Gérard
  • keithbrough Level 1 Level 1 (0 points)
    I have the same proble to which you had replied concerning someone with a CD in their drive. Restarting, holding down mouse button doesn't work. Command Option O F to open the Frimware only gets me, after typing Eject Disk, the reponse:
    "can't open EJECT device".

    I don't get ANY response when on terminal application I try typing "drutil eject"... is there anything else I can do?
  • alan ruta Level 4 Level 4 (1,285 points)
    I've used the mouse down/restart many times, but this time the only thing that worked was the "drutil eject"

    thanks

    alan
  • Claude Lyneis Level 1 Level 1 (10 points)
    A cd wouldn't eject. It would try, but not come out. Laid my Mac on its back and out it came. I first tried it face down but that didn't work. May have to do with cd thickness.
    I am relieved to get the #@%^ disk out. Who want Bocelli anyway.
  • KORBA Level 1 Level 1 (0 points)
    im having same problem...the drive works correctly...but wont eject because the computer case is WARPED...when i apply a small amount of pressure on the case (front and back at same time) the cd will eject easily.

    what really ticks me off is that i dropped a small fortune on this device and expecting near perfection i now have a device that apple will not likely replace, but simply refer me to the warranty...I JUST GOT IT FOR CHRISTMAS A FEW WEEKS AGO...didnt open and set up right away...

    APPLE, HAVE MERCY....HELP ME!!!!!!!!!!!!!!!!

    (im newly converted from windows to mac)

    IMAC   Mac OS X (10.4.4)  
  • xanthoula7 Level 1 Level 1 (0 points)
    Well, I had the same problem 3 days after buying my imac G5, and NOTHING worked. Luckily enough, I had a 15 days warranty at the store I bought it (a FNAC), so they replaced it, after spending 3hours on their apple hotline unsuccessfully. But each time I ensert a new CD, I always wonder if it'll come out.

    imac5   Mac OS X (10.4.3)  
  • lisabellab Level 1 Level 1 (0 points)
    Try this, it's worked twice for me now when 'open firmware' and holding down the mouse key did not:

    1. Shut down your machine completely (do not restart)

    2. Disconnect the power cord

    3. Leave the machine to sit for a few minutes

    4. Reconnect the power cord

    5. Press the power button to turn on your machine

    And...

    The CD will appear on the desktop

    I learned this the hard way: I made the trek to an Apple store and the CD automatically appeared on my desktop when the employee started up my machine. I felt really dumb. I had spent hours trying to solve the problem.

    I JUST had the same problem again and tried this trick at home and it worked.

    iMac iSight   Mac OS X (10.4.5)