6 Replies Latest reply: Apr 20, 2009 6:27 PM by amandaw
TND Level 1 Level 1 (0 points)
My computer keeps asking me if I want to download Itunes 8.1.
Every time I push download it says:

"Thank you for downloading iTunes. Now that you’ve downloaded iTunes, you’re just a few steps away from starting a digital entertainment collection and syncing it to your iPod or iPhone."

Only the problem is that it is nowhere to find on my computer... Why is that?

TND

Windows XP
  • Katrina S. Level 7 Level 7 (24,090 points)
    Maybe a pop-up blocker is stopping the download.

    Do you get a pop-up window that asks if you want to RUN, SAVE or CANCEL?
  • TND Level 1 Level 1 (0 points)
    Thank you so much - I thought I had already done that, but when i checked I saw that you were right in your suggestion. I am most greatfull for the help!
    TND
  • Katrina S. Level 7 Level 7 (24,090 points)
    You're welcome, and thanks for the points!
  • Obichukwu Level 1 Level 1 (0 points)
    Every attempt to install iTunes 8.1.1 (from the Apple website)on my desktop PC (with Windows XP Pro O/S) has been unsuccessful. The error prompt I get (during installation process) is that the downloaded .exe file has an invalid signature and as such my system has not been modified. I get the same results after running the Apple Software Update software. Can anyone help me with a possible solution?
  • Katrina S. Level 7 Level 7 (24,090 points)
    Obichukwu, don't use ASU. Just use the itunes download page.
    Choose SAVE instead of RUN.
  • amandaw Level 1 Level 1 (0 points)
    Okay so I have tried downloading several times and it is never successful. My husband and I both have an iphone and his works fine with itunes but when I plug mine in it says I have to download 8.0 or higher. So i get through almost all of the downloading (a half hour later) it says that "IPod service could not be installed. Verify that you have sufficient privileges to install." If I click on ignore, a smiliar error will come up and my only option is to retry or cancel. If I retry the same error comes up, if I cancel the thing gets aborted and I loose the whole download. Please help!