3 Replies Latest reply: May 28, 2009 4:57 PM by David Vinson2
beaugency Level 1 Level 1 (0 points)
I paid for several applications but now when I try to open them they won't open. However the applications that came with the I-Touch open. Help.

PC, Windows XP
  • roaminggnome Level 10 Level 10 (92,725 points)
    You can try a reset or a restore.

    These are covered in the manual:

    http://manuals.info.apple.com/enUS/iPod_touch_2.2_UserGuide.pdf

    You can try removing them from your iphone via the sync process and the adding them back.
  • Rogelio Sevilla Level 1 Level 1 (0 points)
    Hello, i've beem having a similar problem, i bought an app from the store, it worked great, but after i plug my ipod touch 2G to my PC, the apps stopped working, they wont open anymore, then i unistalled it using itunes, then, using ITunes, in the app tab, i tried to reinstall them, but now i get an error, it said something like this "You don't have authorization to install apps in this ipod". Dont know why . So then i tried to restore the OS using ITunes, but the same error keeps showing.

    Any ideas?
  • David Vinson2 Level 1 Level 1 (5 points)
    I had the same problem with a new iPod Touch. I just got it, downloaded some applications and after a few days none of my downloaded applications would work. I did not like the idea of resetting and starting so I did some further checking. I opened the "App Store", selected "Updates" and then ran the needed update. Only one application needed an update but everything worked fine after the one was installed.

    I hope this helps.

    Dave