6 Replies Latest reply: Apr 26, 2009 10:51 AM by Outpost
ianboon Level 1 Level 1 (0 points)
I have recently purchased a 24" intel iMac (latest revision) running Mac OSX 10.5.6. I tried to transfer the user account from an older computer upon initial startup using the built-in migration feature, but it failed and reported that "there are no versions of mac os x available on your old mac," which is obviously not the case, as I am trying to transfer from an old white PowerPC iMac (with the hemisphere swivel base) running Mac OSX 10.4.11. All the correct procedures were followed using a firewire 400 to 800 cable.

I then found somewhere that it is wise to try to create an account on the new computer and then try to use migration assistant to transfer the account. I tried this several times, and every time the new computer did not recognize the older mac, and just left it searching (all the correct procedures, such as holding down the T key during restart on the old computer, were followed. The old computer has the firewire symbol floating around on the screen as it should).

I also tried the network option, where the new computer gives a number to type into the old computer, thereby linking the computers. This also was unsuccessful and just reported that a network error occurred.

On one of my latest firewire attempts I was given a message on the new computer that stated "Your old mac might not be able to connect to this one using Firewire" What???

Does this mean I'm screwed? How do I transfer my old account to my new computer? Please let me know if you need additional information on the situation. All suggestions are appreciated.

24" iMac, Mac OS X (10.5.6), brand new
  • V.K. Level 9 Level 9 (56,110 points)
    I don't know why this is happening but if all else fails you can always do manual migration. it is tedious but possible.
    just boot the old computer in target mode, connect it by firewire and copy what you need by hand in using finder.
    see this link on what to copy
    http://discussions.apple.com/message.jspa?messageID=6185507
    you will have to reinstall your applications from scratch.

    P.S. one thing you can try first is run "verify disk" on the old computer's main drive and if it indicates any errors, run "repair disk".

    Message was edited by: V.K.
  • ianboon Level 1 Level 1 (0 points)
    Thank you for these suggestions. That link is very informative concerning which files should be copied over, and I may have to try that option if no solution with the migration assistant is found. I also ran disk utility and ran the "verify disk" option. It says in green type that "Volume passed verification," so I think things are ok there. Thanks again for your suggestions.
  • ianboon Level 1 Level 1 (0 points)
    So I tried just mounting the hard drive using firewire outside of the migration assistant, got the image on the desktop, and then attempted to use migration assistant. The transfer worked fine this time since the drive was already recognized. So I guess this problem won't occur if you mount the drive before attempting to open migration assistant, because it sure doesn't recognize it in there. Thank you for your help. Problem solved.
  • Outpost Level 1 Level 1 (60 points)
    I have the same problem. Entered the passkey numbers on the g4, both migration asst's open, sits for about 5 minutes with gears a'spinnin', and then an error message comes up on the iMac. Tried with both ethernet and wireless connections (my firewire cable has the wrong connector).

    So I migrated via USB from a SuperDuper copy on my Seagate ext drive. That got some things over, but I still need to know:

    How do I get my email accounts over. Do I have to enter all that stuff again as if it were new?

    I don't see any easy import function for iTunes and iPhoto.

    For iTune, I renamed the iMac's music folder, and copied the one from the g4 clone. That got the music into the iMac, and I can play it by drilling down to the individual songs, but they don't appear in the iMac's iTunes library (except one at a time, as I play them).
  • V.K. Level 9 Level 9 (56,110 points)
    see my post above.
  • Outpost Level 1 Level 1 (60 points)
    Thanks! The things for iPhoto and iTunes worked!

    However the things for Mail put the accounts on the list, but they didn't respond to anything -- wouldn't send or receive mail. So I deleted the mail plist, which made it start from scratch, and I entered my accounts manually, which wasn't so bad, with the new automated entry in Leopard.

    So, I guess everything is fine -- except wondering why the migration asst didn't work.