14 Replies Latest reply: Apr 28, 2009 5:54 AM by Neil Paisnel
Neil Paisnel Level 1 Level 1 (30 points)
Is there a way to set the defaults for all slideshows?

I want to be able to click on an Event, Faces, Places or Photos folder and then click slideshow, and have it play without having to go through the settings window before it start.
I dont want music or fancy effects, just a straight slideshow, set as default for all slideshows

It is such a pain. Until I can sort this I have started using other slide show apps that work direct from finder. Select a folder of photos, click slide show, and it plays a slide show without all the tedious questions about what you want it to do.

Mac Pro 3.0Ghz 10Gb RAM 4 x 1Tb HD's, Mac OS X (10.5.6), FreeNAS servers and Other Windoze and Linux machines
  • Terence Devlin Level 10 Level 10 (134,925 points)
    Select an album - or whatever - and click on the Play Button at bottom toolbar. Select one of the templates and make any other choices you like. Then tick the box at 'Use This Setting as Default'

    Then ever after all you have to do is click the Play button.

    Regards

    TD
  • Neil Paisnel Level 1 Level 1 (30 points)
    No, I am afraid not, that does not work.
    That is what I first thought, when I saw the check box. But after using it changed my mind. I then thought it only kept those settings as default for only that slide show, and you had to do it for each folder.

    Since reading your post, I have tried again.

    I now notice that it does not work at all.
    Whenever the Check box for 'Use Settings As Default' is ticked it does not stick, even for the same Event

    The use as default check box does not work.

    I check it, play a slide show, close the slideshow, and play again and the tick in the check box has gone and all settings are back to original (Ken Burns effect, music etc)

    So looks like I will have to change my question to

    "How do I fix my broken iPhoto default check box?"

    Message was edited by: Neil Paisnel
  • Terence Devlin Level 10 Level 10 (134,925 points)
    Works for me.

    Try trash the com.apple.iPhoto.plist file from the HD/Users/ Your Name / library / preferences folder. (Remember you'll need to reset your User options afterwards. These include minor settings like the window colour and so on. Note: If you've moved your library you'll need to point iPhoto at it again.)


    Regards

    TD
  • Neil Paisnel Level 1 Level 1 (30 points)
    Looks like we cross posted while I was editing my post
  • Neil Paisnel Level 1 Level 1 (30 points)
    But no
    Trashed the plist and tried again.

    Still no luck


    in fact worse.

    Every side show I try now, keeps the title of the first slide show I play.

    Will try again in an hour or so.

    Got to go and pick up the girlfriend from work


    Will trash the file again and do a re boot. Hopefully it will have re started when I get back
  • Old Toad Level 10 Level 10 (130,070 points)
    Neil:

    If you save the slideshow preferences for a specific album it will only be set for that album. You can change the photos in the album and keep the settings. I don't remember if you can duplicate the album and keep the slideshow settings but you could give that a try.


  • Neil Paisnel Level 1 Level 1 (30 points)
    Old Toad

    When you use the word 'albums' are you referring to Albums you have created yourself using File/New Album ? or using it generically to mean any group of photos in the Events, Photos, Faces or Places sections of the library?

    I have not created any Albums as such, I am just trying to get a slideshow to play from the 4 categories in the Library.

    I do not want to have to select the settings each time whenever I highlight an event or Face of Place.

    I was hoping there was a iPhoto wide slide show default setting that covered all slideshows.

    Just a nuisance to have to set the settings each time you want to play a slideshow of a different batch of photos.
  • Old Toad Level 10 Level 10 (130,070 points)
    I'm referring to Album I created in the left hand pane in iPhoto. Those can be assigned saved slideshows preferences. Once you have album setup with photos for a slideshow and save the settings you can replace the photos in that album and keep the settings intact.

    That is the only way to setup and have a default slideshow setting. In the meantime submit a feature request to apple via http://www.apple.com/feedback/iphoto.html.

    There's a 3rd party slideshow application, PhotoPresenter, that works seamlessly with iPhoto that you can set up a default setting for each of it's 25+ animate themes and then select an album or event, hit play and you'll get the slideshow just as you set it up. You can see some examples of it's many themes in this demo page: PhotoPresenter Animated Slideshow Themes.

    OT
  • Terence Devlin Level 10 Level 10 (134,925 points)
    I was hoping there was a iPhoto wide slide show default setting that covered all slideshows.


    There is in the specific case when you use the Play button on the toolbar. The question for you is why the app is not respecting your choice to set as default.

    I note your comments about using Force Quit a bit recently.

    Try a test:

    Create a new Library - Hold down the option (or alt) key key and launch iPhoto. From the resulting menu select 'Create Library' - and import five or ten pics. See if you can set a default Slideshow in that library.

    Regards

    TD
  • Neil Paisnel Level 1 Level 1 (30 points)
    Thanks for the Photo Presenter Link. I will try that, although it may be a bit more complex than I (well the girlfriend) wants. Am having a play with Phoenix Slides and JPEGDeux at the moment. They both play a slideshow on the screen they were opened in without hijacking the other monitors as well.
    +Edit: yes, it offers lots of options...exactly what I am trying to avoid I just want a simple slideshow, all the same. select Event/folder, click and play+

    I have not created any Albums that you are talking about, just trying to play slide shows, by highlighting a group of pics in the library and hitting the Slideshow button on the bottom of the screen.

    Terrence, I created a new iPhoto Library, and dragged two folders of photos into it from a store of photos on the NAS serve. Photos that had never been imported before...so totally fresh data that has not been on the Mac before.
    That import created two new events as expected.
    Highlight one and click Slideshow icon down the bottom of the iPhoto screen. The usual box pops up I select Shatter, No music and two second time change.
    Play the show and it works as expected. Play it again and it remembers the settings, although the Check box saying Use as Default is now empty.

    Select the other Event, and Slideshow, the options box still pops up, but it has kept the settings I set before, so I still need to click the play button a second time to get it to play.

    So every time I hit the Slideshow button on a new event, for the first time, the options box pops up. Subsequent times it does not. So looks like that is the way it is.

    I can do it, no matter how annoying it may be, but the girlfriend is very technophobic, as soon as something like this pops up, she gives up.

    Thanks for giving this a shot, but looks like this is how Mac planned it.

    Neil

    Message was edited by: Neil Paisnel
  • Terence Devlin Level 10 Level 10 (134,925 points)
    So every time I hit the Slideshow button on a new event, for the first time, the options box pops up. Subsequent times it does not. So looks like that is the way it is.


    But it's not that way for me. I set a default this afternoon and everytime I go back to it I press play and we go straight into the slideshow. I've tried it with the Classsic and the Shatter themes.

    Are you running a Managed or a Referenced Library?

    If you're running a Managed library, then it's the default setting, and iPhoto copies files into the iPhoto Library when Importing

    If you're running a Referenced Library, then you made a change at iPhoto -> Preferences -> Advanced and iPhoto is NOT copying the files into the iPhoto Library when importing.

    Regards

    TD
  • Neil Paisnel Level 1 Level 1 (30 points)
    Managed library, all files copied to iPhoto.

    If you pause a slideshow that is running, and click on the settings icon to change something, what do you see? Is the Use settings as Default check box ticked or is it blank?

    What happens if you import a new folder of pictures, and immediately click on the new Event that the import created, then click Slideshow? Does it play the slideshow directly in that case?
  • Terence Devlin Level 10 Level 10 (134,925 points)
    If you pause a slideshow that is running, and click on the settings icon to change something, what do you see? Is the Use settings as Default check box ticked or is it blank?


    The 'Use Settings...' box is unchecked. This is, I guess, a syntax thing. You will call up the dialogue to make changes, and then you must decide to include those changes as default.

    What happens if you import a new folder of pictures, and immediately click on the new Event that the import created, then click Slideshow? Does it play the slideshow directly in that case?


    No, it asks me to make decisions.

    Regards

    TD
  • Neil Paisnel Level 1 Level 1 (30 points)
    Ok, well that is what mine does also, so those default settings are only default settings for the one album/folder of photos.

    Looks like that is the way it is. Would have expected default settings to be system wide. Oh well,