Skip navigation
This discussion is archived

Win7 Not Installing Drivers for 1st Gen Touch

1543 Views 3 Replies Latest reply: Apr 29, 2009 10:24 AM by luvlabs RSS
SpyglassWolf Calculating status...
Currently Being Moderated
Apr 28, 2009 9:27 AM
Hello folks,

I've been trying to get my 1st Gen Touch up and running in the most recent version of iTunes, installed onto a dual-boot machine (32-bit Vista and Win7). In Vista, the Touch works perfectly. Flip over to Win7, and no dice. I can hear the chime sounding that a USB device has been plugged in and removed, but at no point does any drivers actually install, no info pop-up that new hardware detected, and no iPod listed in the USB devices of Device Manager.

I've tried following the directives of http://support.apple.com/kb/HT1852 to no effect; everything looks to be in order. I've uninstalled and reinstalled iTunes. The only, and I mean only, sign of life I've seen out of Win7 is the one time I managed to fluke my way into Recovery Mode on the Touch, at which point it was recognized as a generic iPod in Win7. I just didn't think that a recovery wipe and reinstall would be a necessary step to a normal installation.

Further, I've also tried running the iTunes program in compatibility mode for Vista, and with Admin privileges for Win7 mode, to no effect. Does anyone have any ideas on what I'm overlooking? I know the hardware works; this has to be software...

Thanks!
Dell XPS 700, Windows Vista, Dual-Boot Vista / Win7
  • applegenius18 Level 3 Level 3 (890 points)
    Currently Being Moderated
    Apr 28, 2009 6:02 PM (in response to SpyglassWolf)
    So you have a beta of Windows 7? If so, I don't think iTunes will even work with an OS that isn't even out in the market.
    iMac 20" 2.66GHz (early 2008), Mac OS X (10.5.6), iPod Touch 2nd Gen (Firmware 2.2.1)
  • luvlabs Level 4 Level 4 (3,610 points)
    Currently Being Moderated
    Apr 29, 2009 10:24 AM (in response to SpyglassWolf)
    Had I seen your post earlier, I would have suggested your start with Apple Mobile Device Services. The Vista instructions would have been close enough to get this working for you.

    And applegenius, there a lots of beta OS's floating around out there. For a beta to go public, we need people like SpyglassWolf to test them with various software to make sure that they work and if they don't, what can be done to get things working.
    iMAC, Mac OS X (10.5.6), 2G touch 2.2.1

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.