4 Replies Latest reply: May 17, 2009 9:37 AM by Sulli500
chuang7 Level 1 Level 1 (0 points)
Hi, I having trouble with my mac book pro connecting to my wireless router. I recently bought a wireless D-Link router. I can detect the signal and connect to it, but when it's connected, I still can't go to the internet. My browser say I'm not connected to the internet.

I don't think anythings wrong with my laptop as I'm able to use the signal through other routers.

I have install a windows OS into my laptop and tried to connect to the router. It says it was unable to verify me as user or my connection, can't remember which, and was unable to connect to it.

Anyone know what's wrong?

Mac Book Pro, Mac OS X (10.5.1)
  • chuang7 Level 1 Level 1 (0 points)
    Okay, so now I'm able to use the internet through the router for my windows OS, but still having trouble with my mac OS.

    I was able to connect to it with no problem. However, I was able to open my homepage on safari, but no other websites. I wasn't able to access any website through firefox. The security type is : WPA2 Personal ; not sure if that has anything to do with the problem.
  • iVmichael Level 6 Level 6 (13,725 points)
    Check you have a Primary and Secondary DNS server set in System Preferences/Network/Airport/DNS Tab (your ISP will have provided them) - you should have DNS servers set for each different location you use.

  • jacks123 Level 1 Level 1 (0 points)
    I have a BRAND NEW macbook pro (literally 2 days old) and I am also having trouble connecting to non-apple wireless routers. But get this...my previous and now dead powerbook G4 and my work's ibooks can all connect to my home network (using a westell versalink 327W) just fine. My MBP detects the network but times out. I've tried resetting the router, even opening up the router so it has no password and nothing works! In fact, my MBP will ask for a WEP password even when the router is open (but it only does this when I try to access it through the network utility, when I try to connect through the airport symbol at the top right of the screen it just times out) I tried a netgear wireless router and that doesn't work either. My MBP only seems to connect to apple wireless routers. I am so so so so frustrated! For a machine that cost me over 3K, I should be able to connect to any router I choose! I am pretty sure it's an apple/MBP issue since my other computers I've tried whether mac or PC, all connect fine. I read on some other forums that a lot of people that own MBPs are having the same or similar connection issues. I also read that apple is aware of the issue and it may have stemmed from an airport update, but I don't if and when they're be a patch or even if that's true. I am calling apple tomorrow and having WORDS with them! I'll post whatever I find out that may be helpful. Sorry for such a long massage, but c'mon this is RIDICULOUS!

    Message was edited by: jacks123
  • Sulli500 Level 1 Level 1 (20 points)
    have you updated the router access list? routers need to know the mac address of machines that will connect to the router. add the mbp's mac address to the access list of the router. then when the mcp connects to the router the router's security key needs to be entered at least once from the mbp. the mbp will remember the security key.

    i set up my new mbp to my netgear router in about five minutes and have had no problems. hope this helps.