6 Replies Latest reply: May 12, 2009 6:59 AM by Rikiiiii
Azeem Ahmad Level 1 Level 1 (0 points)
I've just moved to Berlin (I don't speak German yet) and am having problems connecting my iPhone (bought in Australia and is officially unlocked) to my WiFi connection.
My MacBook Pro has been set up (by my flatmate) to the WiFi at home using a PPPoE connection (ISP is Alice).
My iPhone picks up the wireless network but can't connect to the internet. It appears that I need to set up the iPhone in the same way as my laptop but I don't seem to have the options under wireless connections for PPPoE on my iPhone.

Has anybody resolved this issue before?

macBook Pro 15'', Mac OS X (10.5.6), iPhone PPPoE Wireless
  • Lawrence Finch Level 7 Level 7 (30,650 points)
    PPPoE only applies to the connect between your router and the ISP. It should be transparent to any computers or the iPhone connected to the network. Your problem is most likely something other than PPPoE.
  • Azeem Ahmad Level 1 Level 1 (0 points)
    Cool. Thanx for that but I still can't get my iPhone to work on the wireless network.
    I've selected the wireless network and put in the password and have full signal on the iPhone but it still is unable to connect to the internet.
    This is the only time I have used a Wireless network which is PPPoE. All the other networks I have connected to have been DHCP.

    Is there something that I'm missing that will make it work on this wireless network? My laptop is connected perfectly (although that wasn't an easy process).
  • Lawrence Finch Level 7 Level 7 (30,650 points)
    Unfortunately, it sounds like you didn't note what had to be done to the laptop to get it to work. First check that the router is assigning an IP address. Go to Settings -> WiFi and tap the arrow to the right of the network name. Note the IP address. If it begins 169.254... this means that your router did not assign an IP address. This could be for several reasons:

    1. DHCP is not enabled in the router. You will need to log into the router console via its web address to check. In this case you must manually assign an address to the iPhone. In the router console find the range of addresses to use (which will most likely begin with 192 or 10) and choose an address that is not in use (e.g., 192.168.1.17) and manually enter it into the iPhone. You must also enter the router's own address (e.g., 192.168.1.1) into the Gateway and DNS fields.

    2. DHCP is broken in the router. Try power cycling the router.

    3. The router has MAC (Media Access Control) filtering enabled. This is a router feature that restricts use of the router to known computers and other devices. You will need to enter the phone's "WiFi Address" (Settings/General/About) into the MAC "allowed" table in the router console.

    4. The router firmware is out of date. You will have to upgrade the router's firmware from the manufacturer's site.
  • Azeem Ahmad Level 1 Level 1 (0 points)
    Thanx for that. My flatmate was speaking German to the ISP person so I didn't follow the conversation but I did follow the steps he was taking on the laptop. Unfortunately I can't seem to do the same on the iPhone.

    The router doesn't seem to be assigning an IP Address as you suggested (starting with 169.254.....).

    I'll have to wait for my flatmate to get back before I try anything with the router as I don't want to disrupt his internet connection.
  • bkloppie Level 1 Level 1 (0 points)
    The Problem is that maybe you didn't get a real router. It might be a modem-wireless access point bridge (sorry I'm german). This is what Alice usually sells. So there is no chance to enter your access data (u-name+pwd) into the device. This means your mac sets up the connection every time you use the internet. The iphone is not designed to set up a connection by itself (PPPoE).

    Best way would be to try to change the device you have into a real router. In this case Alice should be very accommodative. They have very basic hardware for the ususal customer. You have to ask for "special" things. </irony off>

    Hope I could help you.
  • Rikiiiii Level 1 Level 1 (0 points)
    I live in Italy and have one of those routers: the factory locks them to a modem (requiring manual login.)
    You have to find an unbranded firmware and install it.
    If you can specify the model I may help you changing the firmware.

    You can also call the operator and ask them to enable "Bridged+Routed" mode, but (at least in Italy) finding a good operator requires a lot of luck...

    Message was edited by: Riki