Previous 1 2 Next 18 Replies Latest reply: Sep 22, 2009 9:01 AM by DizzyDown
JBluepoz Level 1 Level 1 (0 points)
Hey,

I've installed Windows 7 RC on my MacBook. I tried to install BootCamp form Leopard DVD, but the installer says, that it can be run on XP or Vista only (any clues?). I've installed all drivers provided on DVD normally, by running each installer separately, but the problem is that keyboard doesn't work properly - I can't use volume, brightness, keyboard light keys. It seems that Keyboard Manager is needed, but as you know, I can't install BootCamp on Windows..

HELP.

MacBook Pro, Other OS, Windows 7 RC
  • Scults Level 1 Level 1 (0 points)
    Have you [had a problem running programs previously loaded, i keep getting a box pop up saying i need to have admin rights even though im logged in under admin ?
  • JBluepoz Level 1 Level 1 (0 points)
    Nope.

    Message was edited by: JBluepoz

    Message was edited by: JBluepoz
  • Blackshuu Level 1 Level 1 (0 points)
    I am having the same issue with my iMac 20". Everything except the keyboard seems to work under Windows 7 RC. I cant use either the volume keys or the eject key. Trying the bootcamp updated drivers for WinVista 32Bit displays an incompatibility screen and the boot camp installer just displays a screen stating that the installer found a problem and installation cannot continue.
  • carldavies1983 Level 1 Level 1 (0 points)
    I'm in the same situation. I just cannot seem to get my bluetooth keyboard and mouse to pair within windows 7 rc.

    I will welcome any support on this!

    thanks
    carl
  • CorkyO Level 1 Level 1 (45 points)
    carldavies1983,

    You might try the following (assuming you have an alternative input device in W7RC):

    1 - Load the 'Add a device' dialog for bluetooth

    2 - Wait until your device is listed and just select it (highlight only)

    3 - Right-click (or press 'Alt+Enter') the highlighted item and select 'Properties'

    4 - Go to the 'Services' tab and wait until it lists a 'Drivers' check box

    5 - Place a check mark in the box and click 'Apply'

    6 - Click on the notification balloon that pops up on the right end of the taskbar to watch the progress of installation (it will probably say something like 'Windows Update..'

    7 - When done, your device should disappear from the list and should now have functionality (although from my experience not exactly perfectly consistent pairing).

    This worked on my Mac Pro (early 2008).

    To the other posters who have been unsuccessful at installing Boot Camp:

    Have you tried right-clicking (Alt+Enter) on the 'BootCamp.exe' file (found by opening the OS X installation disc to explore the BootCamp\Apple folder) - and then selecting 'Run as Administrator'? This will sometimes allow the installers to run even if they have some type of compatibility issue.

    Good luck.

    Message was edited by: CorkyO
  • chanvincent92 Level 1 Level 1 (0 points)
    I have the same issue... I can't get the keyboard working under Windows 7 RC. Really annoying
  • carldavies1983 Level 1 Level 1 (0 points)
    That does work partly, It shows it in the devices section of control panel for 1 to 2 minutes then it disappears. But at no point does the keyboard actually work.

    Any ideas?

    thanks
  • JBluepoz Level 1 Level 1 (0 points)
    I use my built-in keyboard, not wireless. I also use a Bluetooth mouse. I had a problem with pairing it with Windows 7, but now it works fine. I remember that I had to install it a few times.
  • JBluepoz Level 1 Level 1 (0 points)
    Running setup.exe as an Administrator does nothing. Still the same thing.
  • JBluepoz Level 1 Level 1 (0 points)
    Ok, I think I've found the solution for all problems we talked about. It worked for me, maybe it'll work for you.

    I tried to find a patch or update of BootCamp and I did: http://forums.macrumors.com/showpost.php?p=6908029&postcount=216

    All you have to do is:
    1. Copy BootCamp drivers CD from Mac OS X DVD - go to 'Computer', right click the BootCamp DVD an choose 'Copy'. Paste it on your Desktop (name it i.e. 'Boot Camp').
    2. Download 'AppleBoot_Camp_patchLIMO.zip' from http://www.speedyshare.com/404462147.html
    3. Expand it and open newly created folder.
    4. Copy 'BootCamp(.msi)' or 'BootCamp64(.msi)' from 'BootCamp 2.0' or 'BootCamp 2.1' (which one you like, I've chosen 2.0) folder to /Drivers/Apple in 'Boot Camp' folder on your Desktop. Yes, you have to overwrite it.
    5. Run 'setup(.exe)' in Boot Camp folder and proceed with installer instructions.

    Tell me if it worked for you.
  • JBluepoz Level 1 Level 1 (0 points)
    Solution that helped me is in my last post.
  • wacbert Level 1 Level 1 (0 points)
    I'm running bootcamp 2.1 and everything is working except brightness and now it seems the backlit keyboard.

    Does anyone have a fix for these? I have googled for hours with no luck. I can't tell if the fix above is for the bluetooth or the brightness issue?

    Should I give up and wait for next release? Apple?
  • carpoto Level 1 Level 1 (0 points)
    I installed Windows 7 RC 1 on my 2008 (April) iMac. I successfully got my bluetooth keyboard and mighty mouse setup using the drivers from my leopard install disk (not sure if they're boot camp 2.0 or 2.1).

    Mouse: I did it by going to Add a device and by right clicking on my mighty mouse and selecting properties. Then I selected the checkbox (something about HID device) in the services tab. It then started working without me doing anything else.

    Keyboard: I right clicked on the keyboard (in Add a device like above) and selected "Add device...". I tried this over and over, but finally it worked after trying about 10 times. Sometimes I got an unexpected error, sometimes it just went away, but finally it asked me what kind of passcode I wanted to use, and I asked for it to give me a passcode. I actually had to do the passcode part twice (no idea why), and it started working the second time even before I made it through the whole passcode. Anyway, just be persistent with the keyboard I guess.
  • cdmcali Level 1 Level 1 (0 points)
    This worked for me. Opened add bluetooth device and also opened bluetooth devices. In add device, right click the keyboard and select properties. Check the check box as mentioned in previous post and wait for it to install. Once it says installed it should appear in the bluetooth devices area. May have to do it a few times. Mine worked after the 3rd try.
Previous 1 2 Next