8 Replies Latest reply: Jul 7, 2009 8:49 PM by seachange
jacks123 Level 1 (0 points)
I have a brand new MBP and it won't connect to any non-apple wireless routers

- my computer is 2 days old (it's awesome and I love it accept that I can't get wireless connection at home)
- wireless router: westell versalink model 327 W
- PROBLEM: my mbp will detect the network just fine, but won't connect to it...just times out, it will connect to a neighbors linksys, but cannot load any internet pages, so still not helpful. When I try to connect to the wirelesss router using the network utility it asks for a WEP password, which it never did before because it's an open wireless router. (I know you should always password protect, but it's not my router...I'm just in the same house)
- I had a powerbook G4 and ibooks that have all connected fine to the same wireless network. My dad has an HP laptop that also connects fine
- it only connects to the apple brand airport wireless routers
- it will connect to the wireless router if I plug in the ethernet cord
- I have tried checking the connections, allowing all connections, repairing my disk permissions (even though my computer is only 2 days out of the box), resetting the router, opening the router so no password is needed...NOTHING WORKS!
- I also tried another wireless router (netgear): doesn't work

I've been reading around in some forums and this seems to be an apple and maybe more specifically a macbook pro issue (just by process of elimination). One forum said that it was because of an airport update that basically "breaks" mbp's airport and makes it not accept any non airport wireless connections, apple supposedly is working on a fix but who knows

I'm feeling disappointed and very upset that this is even a problem, especially with how many people I read are dealing with the same issue wit still no solution. My mbp was far from cheap and this just shouldn't be an issue. I'm planning on contacting apple and getting to bottom of this or at least some kind of answer.

MacBookPro, Mac OS X (10.5.6)