6 Replies Latest reply: May 10, 2009 11:29 PM by motiv8_me
motiv8_me Level 1 Level 1 (0 points)
I was using an iPhone, first generation 8gb, with a registered developer copy of 3.0 beta 3. I powered the device off for an hour or so, turned it back on, and got a pink screen showing the iPhone must be connected to iTunes. I connected this to iTunes, iTunes told me that the software had expired and must be updated. I got another message saying that the iPhone was passcode locked (it was), and that the passcode must be entered for iTunes to be able to access it. I was unable to input the passcode because the ONLY option on the iPhone was to make an emergency call.

I put the iPhone into recovery mode (my only option), and iTunes was able to access the device. Tried to restore to 3.0 beta 5, 3.0 beta 3, and 2.2.1, in that order. The 3.0 versions will complete the restore, and when the iPhone attempts to restart, it just restarts back into recovery mode again. iPhone does not do anything else.

I really need help, this phone is a paperweight now. The Geniuses at the bar told me that it was unsupported, I don't know what else to do.

MacBook 13", Mac OS X (10.5.6)