9 Replies Latest reply: Jun 28, 2009 7:56 PM by -OH
OmerNisar Level 1 Level 1 (0 points)
I have an iPhone 3g and wifi seemed to be working fine till a week ago and now it no longer keeps a connection to my wifi.
My wifi is a time capsule with WPA password protection. The iPhone will see it, make a connection for one second then drop the connection.
Any one have the same problem? Any solutions

Macbook Air, Mac OS X (10.5.6)
  • Jason L Community Specialists Community Specialists (10,520 points)
    Hi Omer,

    Make sure you have the latest software updates for your iPhone and Time Capsule.
    This article: http://support.apple.com/kb/HT1414 provides more information about updating and restoring the iPhone.
    This article: http://support.apple.com/kb/HT1218 provides more information about updating the Time Capsule.

    If the issue persists after updating, it may be caused by interference. Try changing the channel or removing potential sources of interference as described here: http://support.apple.com/kb/HT1365

    -Jason
  • Allan Sampson Level 10 Level 10 (123,365 points)
    Try removing the network from your iPhone, followed by re-connecting to the network.

    Go to Settings > Wi-Fi.

    Select the right facing arrow in a blue circle icon to the right of the network. At the next screen, select Forget this Network.

    Follow this by reconnecting to the network.

    If you are unable to select Forget this Network for the network without being connected to the network, go to Settings > General > Reset.

    Select Reset Network Settings.

    This will erase all wi-fi networks and settings from your iPhone for all wireless networks you have connected to with your iPhone.

    Follow this by reconnecting to the network.
  • OmerNisar Level 1 Level 1 (0 points)
    I've tried reseting and restoring the phone as well as the network options.
    I have the latest firmware on the time capsule, and have changed the channel a few times.
    Still no avail.
  • SIR_Casper Level 1 Level 1 (0 points)
    My wifi stop working. I try everything to recover it with restore, reset and downgrade but nothing. Then go to reseller, who sold me. He refused to recover it, because operating system it 3.0 beta. Now I don't know what to do.
  • jonathan37773 Level 1 Level 1 (0 points)
    I'm having the same issues. Tried all of the suggestions people offered, but still having no luck. It started happening when I upgraded to 3.0
  • shazzr Level 1 Level 1 (0 points)
    Also had the same issue. My old iPhone (with no backlight on the screen) can use the WIFI normally...it runs 2.2.1. Got to be something with 3.0. Anyway...I ended up sending in my iPhone for repair...pain! I didn't even get a replacement iPhone while I were waiting!
  • TrevorThreeThousand Level 1 Level 1 (0 points)
    Yes, same here. Wifi dies completely after just a while. Cannot be fixed by rebooting the iPhone, but rebooting the wireless router gives a temporary solution, for maybe a few minutes. Very unfortunate. I was kind of expecting something like this, I have to say.
  • Larry Eckerling Level 1 Level 1 (0 points)
    I had the same problem. it turns out that it must be the upgrade to 3.0, but only on the Iphone 3G. The Wifi on the 3GS seems to work fine. I've gotten an exchange from an Applestore, and got a new phone again which is using 2.1. Does anyone know when Apple will fix this problem, or more importantly, are they aware of the problem? We're going to need to upgrade, but we can upgrade until this HUGE bug is fixed.
  • -OH Level 1 Level 1 (0 points)
    I had the same problem with my 3G.
    Took it to the apple store today. Replaced.

    I got the new one restored from backup it was working for a few hours, now it refuses to take the unlock code... ARRGGGHHH! that's a whole new post.