5 Replies Latest reply: May 13, 2009 12:59 PM by Leaping Ahead
Leaping Ahead Level 1 Level 1 (0 points)
Hello,

For some unknown reason the 'Other...' option appeared in my login screen window and I can't seem to get rid of it. I've done a bit of Googling and it was suggested that 'Other...' shows up when the root user is enabled (in Directory Utility).

I checked to see if root was enabled and it was disabled, as is by default. I tried enabling and then disabling root to see if it would correct the issue and it didn't.

I tried all the usual procedures for Mac problems (repairing permissions, running maintenance scripts etc.) but none of that helped.

In Account Preferences the option to allow network users to login is disabled, so is the guest account, so it's neither of those.

Does anyone have any other ideas?

Thanks in advance.

P.S. I'm downloading the 10.5.7 update as I type this, though I doubt it'll fix anything.

MacBook Pro 15" 3,1, Mac OS X (10.5.6), 2.4GHz Santa Rosa, 4GB RAM, 160GB HDD 5400RPM
  • biovizier Level 5 Level 5 (7,925 points)
    It was noted way back in 10.5.0 that using "Directory Utility" to disable "root" doesn't reverse all of the changes made when it used to enable "root" -- including whatever triggers the appearance of "Other" at the login window. Apparently, this still hasn't been resolved.

    Instead, try logging in to an "admin" account, launching "/Applications" > "Utilities" > "Terminal.app" and entering this command:<pre>
    dsenableroot -d</pre>
  • nerowolfe Level 6 Level 6 (13,070 points)
    Did you disable the root account using the Directory Utility.app?
    Run the utility and under the menu item Edit, check that the root account is disabled.
    If it is disabled, then the "Other" is related to something else. Does it appear in the Accounts preference pane?
  • Leaping Ahead Level 1 Level 1 (0 points)
    Hi,

    Thanks for the suggestion but unfortunately the Other... option is still present in the login window.

    It's not a serious problem but it's quite annoying having to select my username every time to enter my password.

    Apparently the 10.5.7 update didn’t do anything to help either...
  • Antonio Rocco Level 6 Level 6 (10,330 points)
    Hi

    Apart from enabling Root Directory Utility also allows for Active Directory 'binding' and Open Directory 'joining'. Either LDAP Server will present 'Other' as an option on the login screen assuming the credentials presented for Active Directory were correct. For Open Directory you would not necessarily need authenticated binding.

    On the login window clicking on the gray letters beneath where it says OSX should cycle certain information. Things like Build and OSX Version, Serial Number etc. If it says Network Accounts Available then odds are that's where the 'Other' Account is coming from.

    To remove quit out of all applications launch Terminal and issue:

    sudo rm -R /Library/Preferences/DirectoryService

    followed by a restart. Hopefully you should be back to normal?

    Tony
  • Leaping Ahead Level 1 Level 1 (0 points)
    Hi Tony,

    Thanks a lot for your answer. It worked perfectly.

    As you said, 'Network Accounts Available' showed up with a green blob next to it, so I entered the Terminal command and rebooted to find 'Other...' gone from the login window!

    Thanks again,

    Marc