6 Replies Latest reply: May 18, 2009 9:06 PM by Craigular.B
relume Level 1 Level 1 (0 points)
3 Airport Express 6.3
2 MacBook Pro with MacOSX 10.5.7
3 PowerBook with MacOSX 10.4.11
1 XServe with MacOSX 10.4.11

Hello,

At our location we have above infrastructure and we are normally working with our MacBooks and PowerBooks attached to the LAN. On this LAN we have also attached 3 Airport Express (Firmware 6.3) setup as bridges between LAN and Wifi (MAC-address control is disabled).

Our problem is simple but also strange. We can access the LAN and Internet over Wifi over all 3 AirPort Express devices from all our MacBooks and PowerBooks, but we can access for configuration or other purposes like streaming audio to the audio ports of the AirPort Express devices over Wifi only from our MacOSX 10.4.11 based PowerBooks. Also the AirPort Utility shows the devices over Wifi only on our 10.4.11 base PowerBooks. On our 10.5.7 (the same was true with 10.5.6) based MacBooks the AirPort Utility can not find the AirPort Express devices, although we have access to the LAN and Internet. We can only access over Wifi from our 10.5.7 MacBooks the AirPort Express devices if we connect them by their IP-Adresse (Menu Option configure other devices). If we have attached our 10.5.7 MacBooks on the LAN, we can access the AirPort Express by the AirPort Utility with out any problem and also attached Audio Ports or Printers are selectable. So we guess their must be a problem in MacOSX 10.5.X (Leopard) and the Bonjour service.

Also if we are connected by Wifi with our 10.4.11 based PowerBooks we can located servers on the LAN easly in the finder window sidebar (Networks or Servers). The same is not possible on our 10.5 based MacBooks Pro if they are connected to the network by Wifi. In this case on the 10.5 base MacBooks we can access our servers on the LAN only if we "call" them by their IP-address or full domain name by the finder tool/menu option "connect to server".

Does anybody have same problems? Is there any problem solving?

Many thanks in advance and with best regards,

André

Mac OS X (10.5.7), Mac OS X 10.4.11
  • Craigular.B Level 1 Level 1 (0 points)
    I'm having a similar problem, relume.

    I just upgraded my MBP to 10.5.7 this morning and can no longer play music through iTunes over the AirPort Express base station. My firmware is also 6.3 (I have the pre-802.11n version).

    I can play music from our Windows desktop just fine, but as soon as I try to connect from my laptop not only does it not connect, but it also takes my wireless out, so I have to turn the AirPort card off and then back on.

    I can see the base station in the AirPort Utility and configure it though. I can do everything except play music from my laptop.

    -Craig
  • relume Level 1 Level 1 (0 points)
    Hello

    After some more testing we found the the problem arise only, if logged in a 10.5.X based computer network connectivity is switched from ethernet to airport or vice versa (ethernet and airport have the same fixed ip-address). On 10.4.X based computers switching network connectivity for ethernet to airport or vice versa has no effect, meaning airport and bonjour devices are showed as before the switching.

    If the 10.5.X based computers are rebooted after network switching as descriped above, the problems are not present.

    So we assume it is not really an AirPort but rather an Leopard (10.5.X) and Bonjour issue.
  • vega103 Level 1 Level 1 (0 points)
    I had exactly the same issue, ie after upgrading to 10.5.7 I could no longer use AirTunes on either of my Airport Expresses. (I have a old b/g and a new b/g/n one, neither worked.)

    The fix that worked for me after checking the Console logs, was to switch off IPv6 on my network connections. you need to go to settings, network, select TCP/IP, then click on the Advanced button, then set Configure IPv6 to Off. You will need to make sure you apply these changes. After this I was able to use AirTunes as before.

    Hope this helps.
  • Stephen Spark Level 4 Level 4 (2,415 points)
    Thanks relume, I think you are right about Bonjour, your work around worked for me as well. Changing the IPv6 setting however did nothing for me, I tried it first since it was a little easier to try.

    I figured I would hold off on the update to 10.5.7 to see if there was any issues, but I got bit. Since I found no one having any real issues I ran the update this morning only to lose access to my 2 Apple TVs, iPod touch's Remote App, Airport Express AirTunes as well as not seeing the Express or Time Capsule in Airport Utility with my MacBook Pro. I still had an internet connection on all devices however I could not see any devices related to my media network built around the Apple devices on my MacBook Pro.
  • Stephen Spark Level 4 Level 4 (2,415 points)
    I spoke too soon, it worked for awhile, now AirTunes is cutting in and out, only one AppleTV is showing in iTunes and nothing is showing in Airport Utility again. Now as I type this everything is up again however iTunes needs to be closed a re-opened before both ATVs come up again. I guess I'll have to track down the combo update and try re-installing update to see if it helps.


    I rely on this setup for getting video to my TV's, now it's useless. I switched to Apple because of it's stability and now it seems like no matter what device they update the software on they break it.
  • Craigular.B Level 1 Level 1 (0 points)
    Vega-

    I have IPv6 disabled on my adapter(s) and it still fails to connect. I see this error in my Console:
    Console wrote:
    May 18 23:44:02 comp_name mDNSResponder[23]: mDNSPlatformSendUDP sendto >failed to send packet on InterfaceID 00818C00 en1/4 to 224.0.0.251:5353 skt 7 >error -1 errno 50 (Network is down) 1638847533
    May 18 23:44:03 comp_name mDNSResponder[23]: mDNSPlatformSendUDP sendto >failed to send packet on InterfaceID 00818C00 en1/4 to 224.0.0.251:5353 skt 7 >error -1 errno 50 (Network is down) 1638847867
    May 18 23:44:03 comp_name mDNSResponder[23]: mDNSPlatformSendUDP sendto >failed to send packet on InterfaceID 00818C00 en1/4 to 224.0.0.251:5353 skt 7 >error -1 errno 50 (Network is down) 1638848117


    The last number changes each time.

    It's strange actually, each time before I get those messages, apparently my AirPort is going down (console says AirPort: Link Down on en1). Maybe I have a problem with my wifi card?

    -Craig