Previous 1 7 8 9 10 11 Next 233 Replies Latest reply: Sep 7, 2009 12:36 AM by pgpenc Go to original post
  • patlohman Level 1 Level 1 (0 points)
    Hey everyone,
    i just reactivated the Ethernet (through the gear symbol) in network preferences as previously mentioned.
    Cheers for everyones contributions, it seems to be working fine now (just went through 6 successful sleep modes, compared to usually 2, then a crash).
    Hopefully this is a solution...

    pat

    Message was edited by: patlohman
  • Astroboy from Mindblaze Level 1 Level 1 (5 points)
    Hello there,

    I appied Kai's suggestion (reactivating ethernet port), and it DOES work.
    Seems like this is the culprit.

    if you think about it, trashing the preferences for the other guys must have reset the network configuration, explaining why it worked
  • Jason Stone Level 1 Level 1 (65 points)
    Kai's fix worked for me - just went in and used the network setup assistant and setup wifi - but it leaves the ethernet and firewire active

    working ok now (fingers crossed)

    haven't noticed the issue on my PBook G4 17" 1.5Ghz
  • Greg Earle Level 1 Level 1 (145 points)
    Just to chime in, with a difference.

    As a second machine I have an 17" Aluminum PowerBook G4 1 GHz that I just upgraded to 10.5.7 two days ago.

    I have never had a single problem with an OS release upgrade before now.

    I have fallen victim to the sleep problem as well.

    Tonight I opened the cover and found the machine dead. I thought it was stuck in sleep so I pressed the power button but did not hold it down to shut the machine off.

    I was surprised to hear the startup chime as soon as I pressed the button. Clearly the machine had shut itself off on its own, whereas I clearly remember just shutting the lid the night before.

    After it came up, I found out by a popup error on the screen that the system clock had gotten wiped out - reset to UNIX® time zero (Dec. 31st 1969, 4 PM PST). I have never seen that happen before. A few moments later, NTP kicked in and reset the clock to the correct time, but still - this is Not Good.

    My network configuration was custom - I only have a QuickerTech nQuicky 802.11n card (original AirPort internal card died), and the Ethernet port is not connected, so it wasn't in my configuration.

    So I tried the suggestion here, i.e. I added the wired Ethernet port to my existing custom Network setup. But because the Ethernet is not plugged in, obviously the port in the Network setup shows up with a red button instead of green.

    I'm not sure whether folks here consider a port "active" merely when it is listed in the port configuration, or if they have to be in the port configuration as well as being actively in use and connected?

    At any rate, unlike others of you this seems to have had no effect - the apparent-shutdown and the system clock failure both happened after I had added the wired Ethernet port to the Network port configuration.

    Color me baffled. This never happened with 10.5.6 or previous OSes.
  • William Kucharski Level 6 Level 6 (14,890 points)
    "Active" simply means the port appears in the list in the Network preference pane.

    Your date is kept by the battery - when the battery gets low enough to shut your system down, some charge remains.

    What does System Profiler have to say about the health of your PowerBook's battery?
  • smitty195 Level 1 Level 1 (5 points)
    I'm willing to bet that the health of his battery is just fine. Before I was aware of any problem with the 10.5.7 upgrade, I did the exact same thing that he did. I shut the lid on my MacBook Pro and walked out of the room. About 90 minutes later, I came back in the room and heard a loud noise coming from my computer that I had never heard before (it was the fan in high gear screaming away). When I opened the lid, that's when I realized that it never went to sleep and the computer was hotter than it had ever been before. The power was down to 5%, so I caught it just before it would have shut itself down. My battery is fine, so it had nothing to do with that----it was simply because there was such a power drain with the fan running and the computer not sleeping.
  • William Kucharski Level 6 Level 6 (14,890 points)
    I don't recall if the 1 GHz G4 PowerBook has a PRAM battery or not.

    If it does, when the PRAM battery fails the real time clock will reset when the system battery gets low enough.

    If not it just means the system battery was drained low enough there was not enough charge to keep the clock chip running.
  • smitty195 Level 1 Level 1 (5 points)
    Oh okay--thanks. I'm not familiar with how the battery stuff works on my computer.

    Also, has anyone heard if Apple has responded to this huge issue yet? Does Apple Care know about it, and are they offering a fix? Is a software update coming with a fix? I'm surprised that with something this huge, they continue to allow people to download the update with the bug.

    Message was edited by: smitty195
  • duke0 Level 1 Level 1 (0 points)
    I deleted and re-added an Ethernet option to my Network configuration, and rebooted. Seems to sleep/unsleep reliably now.

    I didn't change anything else.

    Thanks Kai!
  • Network 23 Level 6 Level 6 (11,870 points)
    Greg Earle wrote:
    I'm not sure whether folks here consider a port "active" merely when it is listed in the port configuration, or if they have to be in the port configuration as well as being actively in use and connected?


    William Kucharski wrote:
    "Active" simply means the port appears in the list in the Network preference pane.


    No, that's not true. I answered this earlier in this (long) thread. Active means it's available for a connection. Inactive means you clicked the gear icon at the bottom of the list and chose "Make Service Inactive," which makes the icon go dim; if you plug in a cable nothing will happen. Active means the icon is normal and if you plug in a cable it will be Connected. If you click the minus sign then it's removed from the list, which means you can't make it Active. So you have four possible states in there:
    1. Connected
    2. Active
    3. Inactive
    4. Service deleted

    These distinctions are important because if you think active means Ethernet's in the list, but it's really inactive, and you try to sleep the Mac, then say goodbye to your system. It needs to be Active.

    Greg Earle wrote:
    Color me baffled. This never happened with 10.5.6 or previous OSes.

    I've never had a problem with a system update before either. The sleep problem in this thread is an unusual one, it can't be fixed with the usual Mac voodoo.
  • rbfraven Level 1 Level 1 (0 points)
    Thanks to Kai for posting the ethernet solution to the 10.5.7 Sleep problem as described here and other places. Great detective work! I also had the "sleep" problem after installing 10.5.7 on my MBP (2.5Ghz) with 10.5.6. After activating the ethernet port, Sleep started working normally.

    Bob from PA
  • boatjames Level 1 Level 1 (10 points)
    I have similar problem with MBP 3,1 with osx 10.5.7. On trying to come out of sleep, the screen is totally blank necessitating a power down. However when the MBP is connected to an external data projector, I noticed that on re-awakening, the MBP screen was blank, but the data projector displayed everything correctly, and I was able to use the mouse etc. So I went into display preferences, and did a "detect displays" which brought the MBP screen to life.

    Haven't had chance to replicate this finding yet, but I agree with other posts that this is a 10.5.7 problem . I hope someone has a fix or Apple are working on this, because it is not acceptable.
  • joolsca50 Level 1 Level 1 (0 points)
    Thank you so much to Kai and others for solving this problem!! It was driving me crazy, I thought my Macbook Pro 2008 was fubarred!!
  • Greg Earle Level 1 Level 1 (145 points)
    William,

    The health of the old PowerBook G4's battery is fine. I guess I should've mentioned that I keep it plugged into wall power 99% of the time, only removing it when I take it out of the living room and into the bedroom. This sleep phenomenon is with power connected, and post-10.5.7 only.
  • Greg Earle Level 1 Level 1 (145 points)
    Network 23,

    I'll double-check when I get home, but I'm pretty sure that my custom Network port configuration is now 802.11n card at top, Active, and my unconnected Ethernet underneath it, with red icon - but I don't believe the red icon has "gone dim" in the configuration listing.

    So I believe that it should be in "Active" state according to your definition; yet it hasn't worked around the issue. Again, I'll double-check tonight. (And probably apply the Combo Updater while I'm at it.)
Previous 1 7 8 9 10 11 Next