Previous 1 8 9 10 11 12 Next 233 Replies Latest reply: Sep 7, 2009 12:36 AM by pgpenc Go to original post
  • azputerman Level 1 Level 1 (0 points)
    I am trying your solution now, will update if it worked for me on my MacBook Pro.
  • azputerman Level 1 Level 1 (0 points)
    I deleted the preferences files as suggested. Initial tests are that it seems to have worked. I agree that it is probably a problem with the "powermanagement" file, but I went ahead and relocated (copied) the ones that had been modified since April 1 as suggested.

    Thanks for the solution.

    Message was edited by: azputerman
  • weisbach Level 1 Level 1 (0 points)
    Thank you for discovering this. I was running into the same problem and this workaround stops the freezing.
  • fjsdofnsjgv Level 1 Level 1 (10 points)
    Thank you Kai, and Norby for describing the process (I'm a Mac noob). This solution worked perfectly for me. I didn't even have to do a restart.
  • John H Trimble Level 1 Level 1 (15 points)
    Add my name to the list.

    I haven't counted how many times, but it seems to be happening often. Either when I close the lid of my MacBook, or choose sleep from the menu.

    Today, after sleeping my computer (via menu) before going to work, I came home to find the sceeen lit, the fan going like crazy, and no response from clicks, spaces, returns, or force-quits ... had to hard power down. Variations of this (black screen, fan going, no response) have happened several times.

    Jon
  • the family cat Level 2 Level 2 (165 points)
    Yes, another one here who suffered the same bug - only noticed it when my MBP became roasting hot instead of sleeping...!

    The "add ethernet port to network config" fix did the trick for me - thanks to this thread.

    Hope Apple make an official fix soon...
  • John H Trimble Level 1 Level 1 (15 points)
    Kai's solution worked for me as well ... I had been using a wifi location with no ethernet.

    Added ethernet and no more problems. Slept the Macbook 4 times via Apple menu, woke up with no problems. Slept it 4 times by closing lid, again, it woke up without a hitch. Plugged in my external FW drive and repeated ... no problemo!

    Thanks Kai, and thanks Apple Discussion Forums!
  • MMcMinn Level 1 Level 1 (0 points)
    Dear friends

    I updated my Mac Book Pro to 10.5.7 and started to observe problems with the sleep mode. First sleep ok, but the second sleep was a real night mare.

    A year ago, I configured two locations: Office with Aiport and Home with a Wireless Novtel HSUPA Modem. I removed all the other options, including Ethernet ¿a mistake?. Just to mention that I did these modifications before the 10.5.6. update.

    I noticed the first problems using the Novatel Modem (Airport off). I think most of the problems are with Airport activated. At home I only use the Novatel Modem and I was having problems with sleep mode.

    Adding an activated Ethernet connection to my local network options (Home and Office) solved all sleep problems.

    Thanks for the help and kind feedback.

    The best thing about Apple is the great support of the community of users.

    All the best

    Miguel McMinn

    Balearic Islands Spain
  • p7k Level 1 Level 1 (0 points)
    this has been a day of nightmarish cacophony of swears and cries.
    for the first time, i hated being on a mac.

    i suspected a hardware problem and reset all non-volatile flash : no help.
    i suspected adium and filed an erroneous bug report (d o u c h e).
    i suspected hardware to the point of taking it to a 'genius'.

    NO! a freaking inactive Ethernet port which I've done as part of my configurations for more than a year.

    was this god dam?

    active ethernet interface in the location profile solves the problem - is what i'm trying to say...


    if this isn't fixed in the next week, i will have no words.

    Message was edited by: p7k
  • arjello Level 1 Level 1 (10 points)
    He Kai

    That worked also on my machine. Great, I think even the network is now faster. Before, I had switched off ethernet and only used airport. I had the same symptoms as described here. After I activated ethernet everything is fine again. Thanks.

    cu
    arjello

    Message was edited by: arjello
  • dennischristopher Level 1 Level 1 (0 points)
    Hey man,

    I have the same exact problem, it is driving me mad. I also run 10.5.6 and I have been experiencing the same problems. They all started happening after I had my harddisk replaced... (and all my files were transferred...)

    I have lost 20 original compositions this way!

    Any luck yet finding an answer?!
  • zo934 Level 1 Level 1 (0 points)
    Is there a fix at all to this issue, I updated to 10.5.7, noticed now that macbook freezes when its suppose to go to sleep. When I shut it down holding down the power button, and when I boot it back up, it restarts twice, then during sleep mode it freeezes. I did an archive and install, and reverted back to 10.5.6
    but when I installed 10.5.6,when I restart it , it seems to restart twice
    Help please
  • Greg Earle Level 1 Level 1 (145 points)
    Update:

    Installed the Combo Updater. No change in behavior.

    Closed the lid last night before bed. Noted the light didn't start pulsing. Noticed the lights on my CardBus 802.11 card didn't go out.

    Woke up this morning, lights still on, fan(s) going like crazy, PowerBook G4 really hot. Just like some others have experienced.

    Fixed Permissions.

    Changed the Network setup to "Automatic", changed the ordering around, made my CardBus card first, Ethernet (disconnected) 2nd, and made Inactive the other 3 (modem, FireWire, BlueTooth).

    Decided to also try removing the prefs files. * Note: I only had 2 of the 5: *

    preferences.plist
    com.apple.network.identification.plist

    Deleted those, immediately re-booted.

    Problem solved!

    I should never have changed 3 things at once (bad debugger, bad!), but I'm glad it's fixed in some way. Given that I had the Ethernet port in Active state already (when it was still not working), my money is on the 2 Preferences files.
  • Harry R. Level 1 Level 1 (5 points)
    Thank you Kai -

    Enabling the Ethernet port fixed the sleep issue.

    Kinda nuts, isn't it?

    HarryR
  • doug.c Level 1 Level 1 (0 points)
    Why is this discussion still active? Kigh provided a work-around above, posted on May 14, 2009:

    +*Enable your ethernet port in your network settings.*+

    This has fixed the problem for me and AFAIK for countless others in this discussion.

    So to sum it up... 10.5.7 introduced a bug related to sleeping, when wireless is active and ethernet is not. Enable the ethernet port and get on with your lives. Apple will fix this when they get to it. Until then, the work-around works. This problem doesn't need any more discussion unless your bored and have nothing better to do.

    Thanks again Kigh.
Previous 1 8 9 10 11 12 Next