Previous 1 9 10 11 12 13 Next 233 Replies Latest reply: Sep 7, 2009 12:36 AM by pgpenc Go to original post
  • philcolbourn Level 1 Level 1 (0 points)
    The work-around does not always work.

    The ethernet fix did not work for me. In fact, soon afterwards I had a complete lock-up - a rare thing indeed. Possibly not related but note worthy.
  • philcolbourn Level 1 Level 1 (0 points)
    The odd thing is that after I enabled the Ethernet port it did fail to sleep on the second attempt. Then it locked-up. And now, for the first time since the 10.5.7 upgrade, it did wake from sleep after the second time.

    Is it because I am now home and the wireless link is up?
  • RickDean Level 1 Level 1 (0 points)
    Hi -

    Just wanted to add to this. The fix noted above - concerning the ethernet ports does not work 100% of the time for all users. I myself encountered this issue on day 1 with 2 macbooks. The newer one (aluminum) purchased six weeks ago still had the issue after the attempted fix. I had to revert back to 10.5.6.

    I simply don't want other frustrated users to see this post and think that is the final solution. Especially if they are still having a problem and begin to think it is their machine.
  • scolfaro Level 1 Level 1 (5 points)
    after browsing endlessly for some days, not knowing what was wrong, thinking it was freezing because of streaming websites etc, cleaning the whole thing up, fixing leftovers from uninstall and preference files yadda yadda, i realized that it always froze on the second attempt

    and i only found this thread when i googled 2nd attempt freeze etc... so, what the freakin' heck is this?? the ethernet workaround seems to have done it for me, still, what kind of stupid approach is this?

    we all pay a premium to have shiny aluminum alloys super cool computers only to see them degrade all the way down to windows' release-before-you-try guinea-pig-user style policies? and i am not even going to mention my dead pixel (gone through 3 macbooks and 2 pros, it's 3 for 5 in the dead pixel department...)....

    wise up apple, it's unjustifiable to ask for a premium and not provide the top quality expected...
  • deadbolt67 Level 1 Level 1 (0 points)
    Another user experiencing the same issue. Unfortunately, none of the suggestions made in this thread seem to help.

    I remember when updating NT was a crap shoot...in the late mid to late 90s. As a new Apple user, I expected much better vetting of software updates prior to release. This is ridiculous.
  • Hookshot Level 1 Level 1 (0 points)
    I don't know if this has been posted yet (and I'm not going to read all the posts to find out), but creating an ethernet connection under System Preferences > Network solved the sleep/crash problem for me.
  • crenz Level 1 Level 1 (0 points)
    I'm having a similar problem (see http://www.renzwertig.com/2009/05/sleepless-nights-with-1057.html ). I can confirm the computer did not crash (I can reactivate the scren using Cmd+F2), it just keeps on waking up. In my network preferences, I have an Airport, Bluetooth, Ethernet, Firewire and Bluetoot-PAN connection, so the bugfix mentioned does not apply to me.
  • RamiSmidi Level 1 Level 1 (0 points)
    I tried Turning off my ethernet port and the freezing still happens!!!

    how can we get Apple to Jump on this?

    Rami
  • RamiSmidi Level 1 Level 1 (0 points)
    OK, so I found this post....

    http://www.macfixit.com/article.php?story=20090518095106449

    It worked!!!!!

    Make sure you read it exactly has stated:

    To re-enable the Ethernet port settings:
    1. Open System Preferences > Network
    2-1. If you see your Ethernet port in your list of network ports (on the left-side of the window) and it says "Inactive," activate the port by clicking the gear wheel icon and selecting "Make Service Active." Click "Apply."
    2-2. If you do not see your Ethernet port in your list of network ports (on the left-side of the window), click the "+" button in the bottom-left corner.
    3. In the "Interface" drop-down menu, select "Ethernet."
    4. Enter a name and select "Create." You should see your new Ethernet connection appear.
    5. Click "Apply."
    Note: If you are having this issue and your Ethernet port is already enabled, try disabling it (using the gear wheel icon menu > "Make Service Inactive"). Log out or restart your Mac, +_*then enable it.*_+ Be sure to "Apply" your changes.
    Test your MacBook or MacBook Pro by closing the clamshell. Be sure to try this twice as most reports point to the second attempt at sleep as being the culprit for the freeze. If it does not work, try resetting your Mac and test again.

    Let me know if you have any questions i'd love to help anyone out there that has a problem.
  • scolfaro Level 1 Level 1 (5 points)
    i am ****** with this update... it's like the worst update ever, maybe they ordered it from microsoft... it has a typical windows feature now (besides the crashing) - look to the side and the pointless background processing (that i didnt notice in 10.5.6) will have your macbook jumping above 70 degrees and fans at almost 4k rpm...

    seriously, i have it on a stand and watch dvd's before sleeping, and i cannot listen to the dialogues anymore... do i lose the program installation and preferences stuff if i restore and go back to 10.5.6?
  • aduritz Level 1 Level 1 (0 points)
    hi all,

    after installing yesterday's "MacBook Pro SMC Firmware Update 1.3" (http://support.apple.com/downloads/MacBookPro_SMC_Firmware_Update_13) the problem still persists...

    i removed the ethernet port from the configuration and the machine crashed on the second sleep attempt.

    apple apple...
  • Jubal Level 1 Level 1 (0 points)
    My wife's AL MacBook Pro suffered this exact problem. I confirmed that the 10.5.7 update that did it by going back to the 10.5 DVD and doing an 'archive and install' (no problems), I applied the 10.5.6 combo update and again onfirmed no problems. I stopped at that point and did a complete CarbonCopy clone. Then applied the 10.5.7 combo update - bang, problem was back. Digging around on MacFixit produced lots of references to enabling the Ethernet port. Her Ethernet port has always been in the list of available ports although not used, and no matter how hard I fiddled in the Network Settings, I couldn't actually enable it if there wasn't a live Ethernet cable plugged in. On a hunch, I dropped into Terminal and tried the ifconfig command to set the Ethernet port (en0) to up. This produced no change in any visible setting in the Network Prefs Pane, but DID fix the sleep problem. However, it only fixed it until the next reboot. So, my final fix/kludge (until Apple comes up with a patch) was a one-line Apple script, compiled and saved as an application bundle in the AppleScript folder and then added to her startup items. It in turn invokes a four-line UNIX script that issues that ifconfig command.

    The AppleScript line is (this is all entered as one line, it may wrap in email):

    do shell script "/Applications/AppleScript/reset_en0" user name "xxx" password "xxxxxx" with administrative privileges

    the xxx is her short user name and xxxxxx is her administrative password. Compile this and save it as an application bundle with an obvious name (I called it FixSleep); I left it in the AppleScript folder and added it to her list of startup applications in the Accounts preference pane.

    Then, I used a text editor (NOT a word processor, BBEdit, or its free cousin TextRangler would work; if you are comfortable with vi or PICO use one of them) to create the following UNIX script:

    #/bin/sh
    pw=xxxxxx
    echo $pw | sudo -S ifconfig en0 up >/dev/null
    exit

    I saved this script as reset_en0 in the AppleScript folder (the name and location have to match what were called out in the AppleScript above). Again, xxxxxx is the administrative password (and note that en0 is en-zero, not en-oh). Finally, this UNIX script has to be made executable. I know of no way to do this from the Finder. Rainer Brockerhoff's old utility XRay will do so and there are probably others. Again, if you don't mind the Terminal, cd to /Applications/AppleScript and use the chmod command:

    chmod +x reset_en0

    Now (and I agree, this is REALLY a kludge) every time she reboots and then logs in, the AppleScript app is executed. It invokes the UNIX script which resets the Ethernet port to UP. Ugly - but it HAS FIXED THE D**N PROBLEM!!!
  • Braumeister2 Level 1 Level 1 (0 points)
    Yep, same thing here--the ethernet enable/disable "fix" doesn't do it for me, nor does the Permissions Repair voodoo and I'm papering Apple with a bug report every time my machine won't wake from sleep. Even accepting the premise that an update could be so untested as to cause so many problems (up to 11 pages on this thread now--hello, Apple!), it's totally unacceptable that Apple has yet to provide a real fix to this problem. What a PITA.
  • Scrax Level 1 Level 1 (0 points)
    After the update I've the same problem on the sleep mode. The ethernet was active in preference menu but inactive when i check it with ifconfig. Also after a sudo -S ifconfig en0 up >/dev/null it is still inactive.

    I've solved from Network Settings. I switched my Ethernet configuration on Off, before it was on Using DHCP.

    Hope this help.
  • arjello Level 1 Level 1 (10 points)
    If you can not read, than micross.... can't help you either solving problems.

    It says "ethernet ON" NOT OFF !!

    If you are not ACCURATE you can not expect that an Mac should be. Come down, read slowly, try to understand, try again to understand, and than try to fix it. If this is not working, go to a person who understand.
Previous 1 9 10 11 12 13 Next