Previous 1 12 13 14 15 16 Next 233 Replies Latest reply: Sep 7, 2009 12:36 AM by pgpenc Go to original post
  • Daniel Holt2 Level 1 Level 1 (0 points)
    I began to experience the freeze-on-sleep problem on my MacBook4,1 yesterday, after arriving at my parents' house and changing my Location (on the Apple menu) to the one I'd previously set up for working here. Searching, I found that others had fixed this problem by turning on ethernet. Since I never use ethernet here at my parents' house, I'd disabled it when I created the Location profile for this house. I turned it back on and it fixed the problem. I'm telling you this because it occurred to me that if you've tried turning on ethernet and it hasn't fixed the problem for you, you might try creating a new Location profile that has ethernet turned on and switching to that profile. Conceivably, that could get it to work. Just a thought.
  • slobizman Level 1 Level 1 (0 points)
    Can you tell me specifically how you do this:

    "Re-enabled ethernet(en0) in my Network profile"
  • AdamH Level 1 Level 1 (60 points)
    Go to the Apple menu and click on "System Preferences...". When that window opens, click on the "Network" pane under the "Internet and Network" tab. Near the lower-left corner there should be a plus sign ("+") - click it. For interface, select "Ethernet" and name it whatever you want. Click "Create" and you're done!
  • fugasetta Level 1 Level 1 (0 points)
    Same problem!

    First time sleeps second time freezes...

    Hope that Apple listen to us and fix it...soon...
  • Bruce Etnyre Level 4 Level 4 (1,440 points)
    Lindsay B wrote:
    Ok, thanks for the info. Now, if I remove the files and they regenerate, does the problem come back?

    The files will be replaced with fresh ones and if it helps, the problem should not return.
  • Swtv21 Level 1 Level 1 (0 points)
    HI, you might want to make sure all your ports are active.
    Specifically try making sure that the Ethernet port is active.
    Do this,
    Open system Preferences
    -go to network
    -On the left side notice that the ethernet port is not active
    -below, there is -+ and a little gear
    -Click on the gear and make the ethernet port service active.

    I know this is an odd fix for the 10.5.7 sleep crashing issue but trust me on this. After making the service active put the computer to sleep a couple times to verify. Do not do an archive and Install. This is way easier.
    Good Luck!
  • Swtv21 Level 1 Level 1 (0 points)
    HI, you might want to make sure all your ports are active.
    Specifically try making sure that the Ethernet port is active.
    Do this,
    Open system Preferences
    -go to network
    -On the left side notice that the ethernet port is not active
    -below, there is -+ and a little gear
    -Click on the gear and make the ethernet port service active.

    I know this is an odd fix for the 10.5.7 sleep crashing issue but trust me on this. After making the service active restart the mac a couple times to verify. Do not do an archive and Install. This is way easier.
    Good Luck!
  • Caster!! Level 1 Level 1 (0 points)
    So I talked to a Specialist at Apple. Seem that by resetting the System Manager might fix the problem. Hold Control + Option + Shift and power your Macbook Up, Older systems use Command + Option + Shift. The screen should not turn on, hold for 10 seconds. It seems to be working for me right now but time will tell, I hope this works. Best of luck!
  • Caster!! Level 1 Level 1 (0 points)
    Yup Spoke too soon, it ended up freezing after being asleep for an hour.
  • awigg Level 1 Level 1 (0 points)
    After finding my macbook pro with a black screen this morning, I researched (on my old PC that is still around) and found the threads about the NVIDIA cards. On further searching though, I found this thread and others regarding the sleep problem and that seemed to fit my symptoms better - upgraded to 10.5.7 last week, and when I picked up my computer, it was hot on bottom, even though it was supposed to be sleeping. I did a reset that I found recommended (taking out the battery, unplugging cords, and holding down power button for 10 seconds before reinserting battery, attaching power cord, and booting) and was able to get a screen for a few minutes. I checked my Ethernet connection and it said "not connected". I didn't see a gear icon anywhere. I got another black screen on the second sleep, and now I cannot get any video. Can someone advise on how I can get back up and running, and what I should do to help this problem? I have no access to another Mac and the nearest Mac store is 2 hours away.
  • Roy Hooper Level 1 Level 1 (5 points)
    It is not just an inactive ethernet port doing this - mine's active. I thought I'd solved this problem - one time by removing an unused location, and another time by purging the plists mentioned here. Recently, I used iPhone tethering and it created two new network devices (Bluetooth and Bluetooth PAN). Now that these are present, the crash after sleep with 10.5.7 is back. I'm tempted to reinstall from CD and go only to 10.5.6.
  • mcgwd Level 1 Level 1 (25 points)
    alecond wrote:
    Unfortunately since upgrading to 10.5.7 I have the same issue with my MacbookPro3,1 (2.2 GHz Core 2 Duo) with Boot-ROM-version MBP31.0070.B07 and SMC version 1.16f8: when I shut the lid, the screen goes dark but the backlight stays on, the fans spin up due to thermal issues within a minute and when opening the lid again the computer does not wake up anymore but needs a hard reset.


    Same here, with a 2.4(3.1) MBP and losing authorizations with my IK multimedia Sampletank software as well as other mac users using 10.5.7.*** is up with Apple as of late.I feel like my laptop is cursed with all the problems with no acknowledgment at all.I really love this laptop, but I feel like it is doomed to failing soon w/ excessive heat, vid card issues, wireless drop outs and typing issues.No warranty left, after all the money spent had hoped for at least 3-4 years not this pathetic 2 year mess.
  • awigg Level 1 Level 1 (0 points)
    Update on my situation - After spending hours and hours yesterday researching about the problem online and trying various things before the computer just wouldn't boot (I tried 10 or 15 times in 2 hours), I just let it sit alone, without a battery or power cable for the rest of the day. At 10pm last night, my hubby plugged everything in, and IT BOOTED. I immediately deactivated my Ethernet, applied the change, reactivated my Ethernet, and applied the change and rebooted. I also moved the preferences files and System Configuration directory to my desktop before rebooting. When I rebooted, I no longer had the sleep problem, but my Airport connection was broken. So, I moved the files and dir back and rebooted again. Seems to be working fine today. Hopefully, it will last.
  • zo934 Level 1 Level 1 (0 points)
    Im sorry but im totally lost here Im upgraded to 10.5.7
    Im having same problem is there a fix for this yet?
  • Bruce Etnyre Level 4 Level 4 (1,440 points)
    The suggestions described in this thread that fixed the problem were:

    in System Preferences/Network prefpane, activate Etherenet. If it is active, deactivate it and rep-activate it;

    or, move these files (if they exist) to the Trash from the folder
    Macintosh HD/Library/Preferences/SystemConfiguration:

    preferences.plist
    com.apple.smb.server.plist
    com.apple.network.identification.plist
    com.apple.nat.plist
    com.apple.airport.preferences.plist

    and restart.