Previous 1 2 3 4 5 6 Next 233 Replies Latest reply: Sep 7, 2009 12:36 AM by pgpenc Go to original post
  • brambila Level 1 Level 1 (0 points)
    Hello;

    I have the same issue and unfortunately i am not technical at all and wont be able to fix it myself, unless Apple comes up with a patch or a 10.5.8.

    Is Apple listening?

    Will there be an easy solution to this?



    Message was edited by: brambila
  • glhh Level 1 Level 1 (0 points)
    This worked for me too -- tried it just before reverting back to 10.5.6. I think the prefs that need to be removed are in the main library, not the user library. You can use terminal with sudo to remove the sleepimage file. Seems to work perfectly now, so far.

    "OK, my exact line of events:

    1. Resetting the SMC (didn't work by itself, but could be part of the solution).
    2. Removing the sleepimage from /var/vm
    3. Removing all com.apple related preferences (including the folders SystemConfiguration and DirectoryService) that changed since April 1 to a folder on the desktop.
    4. Reboot"

    Both MBP's sleep and wake as intended now.

    Thanks, Esquared).
  • Network 23 Level 6 Level 6 (11,880 points)
    Esquared wrote:
    I had the exact same issue on two MacBook Pro's. Removing a bunch of preference files from HD>Library>Preferences (so NOT the regular pref folder in your Home directory!) seems to have solved this issue on both.


    Your solution did work for me, initially, but after I re-created all my former Network Locations the sleep crash came back. I'm going to try again in a more minimal way since last time I was copying some info back into the Prefs folder.

    As for why I don't roll back to 10.5.6, I might end up doing that, but first I have to remember and separately copy off the documents which are new and changed between the time I upgraded to 10.5.7 and now, because they're going to disappear if I roll back to my last clone that does not contain those files.
  • Network 23 Level 6 Level 6 (11,880 points)
    So I started over and it passed the sleep tests fine, but after I customized one new Network Location (specifically the AirPort settings), the sleep crash came back, except this time it got as far as turning off the backlight. But it never actually went to sleep. It kind of hung with a dark screen, with the sleep light dimmed, not bright, and not pulsing.

    Note to those that try this, in addition to losing your network locations, throwing out those prefs files will also delete your machine name (the one at the top of the Sharing preference).
  • rhentsch Level 1 Level 1 (0 points)
    Same problem on (since 10.5.7) on my MacBookPro4,1
    Greetings from Germany and @Apple: Please help!
  • bruegge Level 1 Level 1 (10 points)
    Similar problem with 10.5.7 and my early 2007 iMac.
    It went to sleep and returned with the spinning wheel.
  • qkoziol Level 1 Level 1 (0 points)
    I experimented with this a little and think I narrowed down the solution to this problem to removing the com.apple preferences in the /Library/Preferences/SystemConfiguration that were newer than April 1. That was these files, in my case:

    preferences.plist
    com.apple.smb.server.plist
    com.apple.network.identification.plist
    com.apple.nat.plist
    com.apple.airport.preferences.plist

    Perhaps someone else can eliminate only half of those preference files and we can narrow it down further?
  • Lear Pilot Level 1 Level 1 (15 points)
    Same problem.
  • Kigh Level 1 Level 1 (5 points)
    Hi,

    I've found a solution or a work around that helps in my case.
    Problem: deactivated ethernet port in my active network environment while using airport alone!
    Mith my MBP I usually connect to the internet by WLAN and I use an environment setting with ethernet deactivated (maybe you too?).
    I've activated the ethernet port, saved the environment - apply - voila.

    Sleep mode works as usual.

    Greetings from Germany,
    Kai
  • Network 23 Level 6 Level 6 (11,880 points)
    Kigh wrote:
    I've found a solution or a work around that helps in my case.
    Problem: deactivated ethernet port in my active network environment while using airport alone!
    Mith my MBP I usually connect to the internet by WLAN and I use an environment setting with ethernet deactivated (maybe you too?).
    I've activated the ethernet port, saved the environment - apply - voila.

    Sleep mode works as usual.


    That could be an important clue. It could apply in my case because after throwing out the preferences, the sleep crash only came back after I edited Network Locations, where I had deactivated the Ethernet port when a wireless Location is active!

    Unfortunately, I may not know if this would have solved my problem because I am already in the middle of restoring from my 10.5.6 clone backup. Hope you solved it for others, though...
  • Irfus Level 1 Level 1 (0 points)
    This works for me too. Finally, I can give InsomniaX some rest,

    This probably also explains why removing that network settings plist had helped. The overhead of keeping the ethernet service active is way more preferable to not being able to put the laptop to sleep. Still, hopefully Apple notices this and comes up with a more permanent fix.
  • Kigh Level 1 Level 1 (5 points)
    Yeah, I hope so!
    My system still works absolutely normal after that. I've had the idea with the ethernet port by reading the last post of user "qkoziol" (...deleting some .plist settings like network settings.)
    From there I've checked my network settings. Thanks to qkoziol and others who had the idea to delete these settings.

    Kai
  • soren2 Level 1 Level 1 (0 points)
    Very interesting observation! My MacBookPro3,1 with 10.5.7 (now back to 10.5.6) had the problem; I have it set up with separate locations for wired and airport. My MacBookPro4,1 with 10.5.7 does not have the sleep problem, and it is set up with an "Automatic" location where both wired and airport are active at all times. I just change my MacBookPro4,1 to have a location that is airport only and now it has the sleep problem as well. Surely sounds network related!
  • fromagique Level 1 Level 1 (0 points)
    If this link to the Ethernet port is true, it makes me wonder. Oddly enough, as I mentioned in one of my other posts, I've had a problem very similar to this in the past: the machine freezes in the same way as we've been seeing here, when the AirPort card is powered down. Any chance these are related? The reason I had done this (removed the wireless connection when on wired) is because the MacBook would keep using the slower wireless connection when both were on. (The wired network is gigabit speed; that's why I want to use it sometimes...) Does anyone know how to force a connection to be used over another one (besides turning off the one that's not desired?) Thx!
  • Herbert Schulz Level 1 Level 1 (10 points)
    Howdy,

    Thanks for this solution. So far it seems to work. It will take a day or two before I have confidence though.

    By the way, I originally thought that just rewriting/updating the network setting (i.e., the plist file) was the solution so I de-activated the Ethernet Port and the problem returned. It appears that the Ethernet Port really must be active.

    Good Luck,
    Herb Schulz
Previous 1 2 3 4 5 6 Next