Skip navigation
This discussion is archived

10.5.7 upgrade problem

1919 Views 6 Replies Latest reply: May 14, 2009 3:11 PM by Lyssa RSS
vjejjala Level 1 Level 1 (0 points)
Currently Being Moderated
May 14, 2009 2:38 PM
I tried upgrading the OS to 10.5.7 today on a two and a half year old MacBook Pro. On restart and install, the upgrade failed. Subsequent attempts at restart lead to an error message that begins:
panic(cpu 0 caller 0x001AC125): ~Version mis-match between Kernel and CPU PM~@/SourceCache/xnu/xnu-1228.12.14/osfmk/i386/pmCPU.c:638
Of course, I have no idea what this or the subsequent lines mean.

I have the Leopard OS X install DVD and a Time Machine backup on an external drive. Overlaid on the above error message, I get the "You need to restart your computer...." prompt irrespective of whether the install DVD is in the drive.

I would be grateful for suggestions on what I should do.

Can I reinstall Leopard from the DVD and try upgrading to the latest version of 10.5 afterwards? How would I do this?

Copious thanks and best wishes,

Vishnu
MacBook Pro, Mac OS X (10.5.7)
  • Allan Eckert Level 8 Level 8 (39,395 points)
    Currently Being Moderated
    May 14, 2009 2:43 PM (in response to vjejjala)
    Hi vjeijala;

    You have had a kernel panic. Generally these are caused by hardware most frequently bad RAM. I would suggest that you run AHT to test out your hardware first.

    Allan
    tiger
    MacBook Pro, PowerMac G5 Quad. iPhone, Mac OS X (10.5.7), 7800 GT, 6.5 GB RAM, 440 GB, Nikon N80, D70 and D300 Nikon Coolscan 5000ED
  • Richard Prescott Level 1 Level 1 (90 points)
    Currently Being Moderated
    May 14, 2009 2:53 PM (in response to vjejjala)
    I think the larger question is whether or not you can still boot to the installer DVD.
    - Leave the DVD in the drive, restart the machine and hold the D key down to start to the AHT part.
    - Select the extended test and before you run it click on the Hardware tab to see if it sees all the RAM you have installed. Any RAM flagged as bad will be written in red text.
    - If you see no red flagged RAM then go back to the Test tab and run the test.
    Just remember, you said you have a Time Machine backup. I found it easier to restore from backup (took about 1.5 to 1.75 hours on my Mac Pro restoring about 175 GB).
    That is why we have Time Machine.
    Select the last backup before the update to 10.5.7.
    MacPro/PowerBooks G4/G4 tower, Mac OS X (10.5.7), Mac user since 1984
  • owl5126 Calculating status...
    Currently Being Moderated
    May 14, 2009 3:27 PM (in response to vjejjala)
    /deleted

    Message was edited by: owl5126
    Power Mac G5 Quad, Mac OS X (10.5.7)
  • Lyssa Level 6 Level 6 (14,780 points)
    Currently Being Moderated
    May 14, 2009 3:11 PM (in response to vjejjala)
    Restoring from a TM backup requires booting from the install disc.

    Try removing & reseating the RAM in the machine, as well as running on first one module, then the other and see if that solves things.

    See this article for how to remove and reseat RAM:
    http://support.apple.com/kb/HT1270

    ~Lyssa
    13" White Macbook; 160 GB black iPod Classic ^_^, Mac OS X (10.5.6), iBook G4 1.07 GHz (10.4.11); 3G iPod 15 GB (4.5 years running smooth!)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.