Skip navigation
This discussion is archived

Wifi WEP passphrase vs. key - how to connect?

5368 Views 7 Replies Latest reply: Jul 2, 2009 8:57 AM by Beelsebob RSS
sduraybito Calculating status...
Currently Being Moderated
May 21, 2009 2:38 PM
My iTouch only connects to my secure Wifi by using the 26 character WEP key when challenged for the Network password. How can I get my iTouch to connect using the passphrase, instead, which is much easier to remember?

The network password gets blown out everytime I reset my iTouch (which is a sucky "feature", IMO).

TIA
  • luvlabs Level 4 Level 4 (3,610 points)
    Currently Being Moderated
    May 21, 2009 4:24 PM (in response to sduraybito)
    Change your encryption to WPA or WPA2. Check your router settings and, if you don't have the option, try downloading the latest firmware for your router - or buy a new one.

    And yes, if you reset you have to re-enter your pass key or password. It's kind of like rebooting your computer, don't you have to enter a password to log back in?
    iMAC, Mac OS X (10.5.7), 2G touch 2.2.1
  • Peter Miller Level 4 Level 4 (1,955 points)
    Currently Being Moderated
    May 21, 2009 4:38 PM (in response to sduraybito)
    you need to configure your router to use a passphrase instead of a WEP key. then you should be able to connect to that network using the passphrase instead of the WEP key.

    Basically its an network issue, not an ipod touch issue. so you have to set the network security protocol to a passkey instead of a WEP key.

    Hope that helps.

    Regards,

    Peter.
    Mac Pro 2x2.8Ghz Quad-Core Intel Xeon CTO; iPod Touch 2nd Gen (Personalized), Mac OS X (10.5.6), iWork & iLife '09, Adobe CS3, Final Cut Studio
  • luvlabs Level 4 Level 4 (3,610 points)
    Currently Being Moderated
    May 22, 2009 1:16 PM (in response to sduraybito)
    sduraybito wrote:
    No one has to re-enter their WEP passphrase or key when they reboot their computer. What planet are you on?


    Earth, same as you. But you do have to log back into your computer which will log you into the corporate network.

    No corporate network that I know of would be so sloppy as to use WEP encryption. The touch doesn't remember things after a reset for simple security reasons. But then again, any company that uses WEP for their wireless network isn't all that security conscious.

    Message was edited by: luvlabs
    iMAC, Mac OS X (10.5.7), 2G touch 2.2.1
  • Jason L Community Hosts Community Hosts (9,250 points)
    Currently Being Moderated
    May 22, 2009 1:51 PM (in response to sduraybito)
    Hi,

    The issue may be the length of the password phrase. If you are using WEP, you'll want to use a 5 or 13 character password phrase as described here: http://support.apple.com/kb/HT1344

    If you are already using a 5 or 13 character password phrase, you may be able to resolve the issue by Resetting Network Settings on the iPhone. To Reset Network Settings tap Settings> General> Reset> Reset Network Settings.

    +"When you reset network settings, your list of previously used networks and your VPN+
    +settings are removed. Wi-Fi is turned off and then back on, disconnecting you from any+
    +network you’re on. The Wi-Fi and “Ask to Join Networks” settings are left turned on."+
    From the iPod touch User Guide http://manuals.info.apple.com/enUS/iPod_touch_2.2_UserGuide.pdf

    -Jason
    MBP 2.4 with 4GB ram, Mac OS X (10.5.7), Original iPhone, iPhone 3G, Apple TV, Airport, iMac, iPod Video, Nano, Hi-Fi..
  • codeH4cker Calculating status...
    Currently Being Moderated
    May 22, 2009 1:57 PM (in response to sduraybito)
    Would this app help?
    It gives you common keys based on the WEP passphrase:
    http://www.iphonedownloadblog.com/2009/02/05/wepgen/
    Many, Other OS
  • Beelsebob Calculating status...
    Currently Being Moderated
    Jul 2, 2009 8:57 AM (in response to sduraybito)
    Fraid not, on the too grown up front, your administrator is incompetent I'm afraid. The most secure form of WEP (128 bit) can be broken into in about 3 seconds. Your administrator needs to change over to using WPA2 Enterprise.
    MacBook, Mac OS X (10.5.7)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.