2 Replies Latest reply: Jul 16, 2009 12:01 AM by darkhell26
hoyer801 Level 1 Level 1 (0 points)
I have a first gen iphone that has the headphone settings reversed. When there are no headphones plugged in, no sound comes out of the speaker at all. The volume indicator says "Ringer (headphones)" when there is no headphone plugged in. When there IS a set of headphones plugged in, it says "ringer" and all sounds come through the speaker. I keep a jack that I cut off of a nonworking microphone plugged in so I can use the phone, but this means that the ipod portion of my iphone is unusable.

I've done a great deal of searching on this issue and found it to be very common. All of the usual remedies have not worked. I have tried the following:

plugging and unplugging (over 100 times in rapid succession)
cleaning the jack with a modified q-tip and alcohol
allowing the phone to lock while playing, removing the headphones, unlocking, and resuming play
soft reset
hard reset
factory restore

I purchased this phone used on ebay as is, no warranty. I called apple and learned the phone is three weeks out of warranty. I'm a very adept DIYer, so I don't mind opening this thing up to replace a part or two since it's already out of warranty.

Any suggestions?
  • Michael Seymour Level 1 Level 1 (5 points)
    i have a similar problem with the iphone getting confused about the input(or lack of)of headphones. for me i found this to be a problem with the ipod app of the phone. for example, i'm listening to music with headphones, i see someone on the street, i pause the music, pull out the headphones to say hi. later i try to call someone (no headphones) and i can;t hear anything. i found that as soon as i put the headphones in that music starts playing etc. what i HAVE TO do is click on the ipod app to see the music, pause it, click the home button to close the app...then pull out the headphones. and if it doesnt work i do it over..and..over until i hear that lovely "click" sound when i lock the iphone. hope this helps.
  • darkhell26 Level 1 Level 1 (0 points)
    Hi,

    Not sure if your problem is solved.

    It happened to me last night. What I did was to ON my Bluetooth and turn it back OFF, then restart the phone. It worked for me.