1 2 Previous Next 16 Replies Latest reply: Oct 23, 2009 11:50 PM by ASCHAUMAN
Zstas Level 1 Level 1 (0 points)
Hi there,

when trying to sync my ATV, iTunes says "the Apple TV is not responding. Check that any firewall software running on this computer has been set to allow communication on port 3689"

It happened for the first time, I didn't change any settings neither in the computer not in the ATV.

I followed the steps described in the articles

http://support.apple.com/kb/TS1447
and
http://support.apple.com/kb/HT1810.

The firewall setting allow all incoming connections, but the same alert box appears, when I try to sync.

Does anybody know what am I doing wrong?

MacBook Pro, Mac OS X (10.5.5)
  • 1. Re: Syncing Problem  - firewall - port 3689
    jmstefanac Level 1 Level 1 (0 points)
    Had the same problem when I installed my new Linksys Wireless N Router today. If you have a router, check the security settings on it and either allow Apple TV or as I did, disable the firewall on the router. Worked after that
  • 2. Re: Syncing Problem  - firewall - port 3689
    pheare Level 1 Level 1 (30 points)
    Disabling your router's firewall is probably not the best idea...
  • 3. Re: Syncing Problem  - firewall - port 3689
    pheare Level 1 Level 1 (30 points)
    I have never had to setup my firewall to get the atv to sync.

    Usually I have no problems syncing with my atv. However, I have gotten this error a couple of times. If I recall, unplugging and re-plugging in the atv solved the problem.
  • 4. Re: Syncing Problem  - firewall - port 3689
    jmstefanac Level 1 Level 1 (0 points)
    Right now I am trying to eliminate as many if the variables as possible, hence turning off the router firewall. My ATV and iTunes simply will not sync. And if they start to sync, it just sits there idle for hours. Now I can't get the ATV to recognise the wireless router. I have an ATV in my other place and have not had a single problem. This new one I got has not given me a moment of peace. I will not update the software on my other ATV or iTunes until I am sure that there is a fix to these problems I'm having now.
  • 5. Re: Syncing Problem  - firewall - port 3689
    pheare Level 1 Level 1 (30 points)
    Do you have the same router in your other place where the atv is working?

    Do you have the option of taking the newer, 'non-syncing' atv and try it on the network that syncs fine? May help you determine if it is truly an atv issue or something funny with the way your one router is working.
  • 6. Re: Syncing Problem  - firewall - port 3689
    jmstefanac Level 1 Level 1 (0 points)
    The routers are different. And unfortunately it is not so simple to just try things in the two places. One is in Singapore and the other in Hong Kong.

    I have a Apple Airport Router with 1Tb of HD in Singapore. All works fine. In my HK place I have a Linksys Wireless N modem. I just installed that as previously I had a ZTE Wireless B/G modem and I thought that was the issue causing slow syncing. I've tried wireless and direct ethernet connection to no avail. Tearing what little hair I have left out.
  • 7. Re: Syncing Problem  - firewall - port 3689
    davelively Level 1 Level 1 (0 points)
    I'm having this same issue. Looking at this kb article: http://support.apple.com/kb/TS1447 it says:

    Note: If you use "fast user switching" on a Mac with firewall enabled you'll need to enable additional ports to allow streaming to Apple TV. If you don't, only the first user will be able to stream to Apple TV. For one additional user enable TCP port 49152. For each additional user, open the next incremental port (49153 for three users, 49154 for four users, 49155 for five users, etc.).

    I am using fast user switching. However, with the application fw in 10.5, I can't open up additional ports. I have my firewall set to allow incoming connections for iTunes. However, this is what I see in my log:

    May 28 19:15:35 Lively-iMac Firewall[53]: Deny iTunes connecting from 192.168.20.52:58232 uid = 0 proto=6
    May 28 19:15:35 Lively-iMac Firewall[53]: Deny iTunes connecting from 192.168.20.52:58233 uid = 0 proto=6

    Anyone know how to make this work with fast user switching in 10.5?
  • 8. Re: Syncing Problem  - firewall - port 3689
    jmstefanac Level 1 Level 1 (0 points)
    I have had enough of all of the issues with Apple TV and did what I should have done in the first place, bought an Apple Time Machine and use that as my router. Now no more problems and no more tearing my hair out. All works as it should do.
  • 9. Re: Syncing Problem  - firewall - port 3689
    JEinFL Level 1 Level 1 (0 points)
    I was experiencing similar issues after installing Airport Express Firmware update to 7.4.1. I re-installed Airport Express Firmware version 7.3.2 and voila! ATV is syncing just as it did before. Check http://support.apple.com/kb/HT1218 for instructions, or here's what I did... after opening the Airport Utility program, I clicked on Base Station/Upload Firmware then in the dialog box, I used the pull-down menu to "Change the Upload Version" back to 7.3.2 and followed the instructions on the screen. After the firmware installed and Airport Express restarted, my iTunes (ver 8.2) started syncing again.
  • 10. Re: Syncing Problem  - firewall - port 3689
    doctor chemist Level 1 Level 1 (0 points)
    I am glad that you were able to solve the problem. I had the same deadly message about a week ago. I had to do a similar setup. Updated my firmware the the Linksys router, disabled the filter multicast setting in the firewall (but I do not disable the whole firewall). I also allowed the firewall to accept the port 3689 (which is specific to itunes). Haven't had a problem since!!!! For instructions on how to open up the port 3689 function on your router, goto portforward.com.
  • 11. Re: Syncing Problem  - firewall - port 3689
    davelively Level 1 Level 1 (0 points)
    So is the general consensus that this is a router firewall issue and not an Apple OS X firewall issue?

    I had thought that the router firewall settings only blocked traffic between the external WAN port and the internal LAN ports. This is all traffic on the internal LAN ports - none of it should be even going through the firewall on the router.

    I have port 3689 opened up to every potential IP address my Mac or ATV could appear on after a reboot. And I've turned off fast user switching (temporarily) to see if that resolved it, but no luck.

    My router is a Linksys WRT300N.
  • 12. Re: Syncing Problem  - firewall - port 3689
    Helpisontheway Level 1 Level 1 (0 points)
    After 2 hours of trouble shooting, I solved this issue on my PC/Network. Earlier in the week, I was concerned about my pc hosting itunes. After scanning for viruses, I decide to restore to factory default all firewall settings in McAfee security. A couple days later I noticed my appleTv was no longer syncing. After much trouble shooting, I determined that I could synce my appleTv when I disabled the McAfee firewall but not when it was enabled. I tried all of the suggestions I could find online including adding port 3689 to the list of approved ports but nothing seemed to work.....until...I noticed the "Manage Network" link on the home page of my McAfee Security Center. I clicked and there was a link that said something along the lines of "trust my home network". I clicked on the link and the McAfee software began building a map of all the devices on my network. The AppleTv is syncing again with no problem and both the McAfee and Windows firewalls are on!
  • 13. Re: Syncing Problem  - firewall - port 3689
    Ljenks Level 1 Level 1 (0 points)
    I have had this Port 3689 issue for a month, after upgrading to aTV 2.4 and iTunes 8.2.1.6. I run Win XP Pro, use a D-Link wireless router to connect to home wireless network, and also connect via ethernet to a LAN. I have 62Gb of music, 3536B of movies, and 1Gb of photos that I choose from to sync to my aTV. It has worked beautifully for 18 months . . . until a month ago.

    I had tried everything . . . rebooting the computer, rebooting the aTV, reseting our router, restoring factory settings, turning off my firewall, everything listed in these forums.

    Then I read a post about a guy that simply unplugged his ethernet and it started working. So, I *disabled my LAN connection and disabled my network bridge*. Mysteriously, aTV has started syncing content again. I am not technical, so I cannot explain how or why. It just works.

    I hope this helps someone because I've wasted so much time on this it makes me ill.
  • 14. Re: Syncing Problem  - firewall - port 3689
    Numanoid5 Level 1 Level 1 (0 points)
    My solution is below - some preamble first for those despairing as I was!

    I had exactly the same issue - purchased ATV yesterday to add to my iMac with Time Capsule WiFi network setup. ATV connected perfectly to the Web but I could not get it to sync with my iMac's iTunes library. I wanted to stream rather than sync but couldn't do either. Tried all previous suggestions - PRAM resets, Firewall to "Allow all incoming connections", router changes - all to no avail.

    Console utility was reporting in its logs that my iMac was denying the ATV access.

    I'm lucky enough to be friends and neighbours with an excellent network admin who deals with Macs as well as PCs but we still couldn't figure it (I'm an SQL DBA so know a little about networks too). He also has ATV and streams with no problem and had no installation or configuration issues.

    We wirelessly connected my ATV to his iTunes library and it worked first time, streaming like a dream. This ruled out ATV as the issue and put my iMac completely in the frame; we still couldn't coax mine into accepting comms from ATV.

    Finally tried the NoobProof freeware utility. I used it to specifically set port 3689 to "Allow" i.e. wipe out any existing settings and set the **** thing to "Allow". Bingo. Everything now works.

    It could be something I've done over the past 18 months since I switched to block that port so I cannot point blame at the iMac or ATV.

    Now it's working I have to say I think ATV is just superb, another quality product from Apple (I didn't think that way about 24 hours ago though!).

    Take-away: if you're still getting the 3689 error then please try the NoobProof util (or something similar like WaterRoof) to at least rule out a genuine firewall rule is blocking the communication.

    I hope this helps someone - when I was tearing my hair out I found plenty of reports of this problem but not too many suggestions. Please write how you get on and any success you have with this really frustrating problem. Best of luck.
1 2 Previous Next