9 Replies Latest reply: Sep 11, 2009 12:08 PM by C-BUS
coreykoch Level 1 Level 1 (0 points)
my iTunes looks for al the world to be normal but when I press the play button, nothing happens. no movement no sound. what's up
thanks for a solution

iMacG4 1.25, Mac OS X (10.4.11)
  • Shmuel Bowles Level 1 Level 1 (5 points)
    I'm having the same issue. I am not aware of any changes I have made to my library, there are no exclamation marks or obvious signs of library corruption. When I double click on a song it appears to begin playing (the title of the song, album, and artist appear above the progress bar) but the progress bar simply remains static, not moving from 0:00. I can change songs by double clicking another in the list but this results in the same thing: no audio, no movement.

    I've tried restarting iTunes and logging in and out with no result.

    Another thing which might help in diagnosing this: I don't get audio anywhere (internet, quicktime files, anywhere). Is your audio working in other programs Corey?
  • Aaron Feibus Level 2 Level 2 (385 points)
    Having exactly the same issue as you've posted, Shmuel. To the letter. I can get sound if I reboot sometimes, but something is causing it to fall back into this pattern. Have you found any solution? I'm about to reinstall iTunes. My software is currently all up to date.
  • dembow Level 1 Level 1 (90 points)
    I can't play some of my music as well. If I double click on a song or click the play button, nothing happens. It's weird that it can play some music, but not other. All files play perfectly in QuickTime and VLC. How can this even happen when it's the same music I've been listening months ago and now all of a sudden I can't play some songs?! I discovered this problem completely random when I turned on shuffle and right after the second song to my surprise the music stopped playing. I tried about everything to make iTunes play the effected songs, but to no success.

    What is going on? Is there a magical solution to this ridiculous problem?
  • Heather75 Level 1 Level 1 (0 points)
    I kmow it's been awhile...did you ever get this fixed and if so, how?? I'm having the same problem...stressfull!!
  • dembow Level 1 Level 1 (90 points)
    Unfortunately I haven't. I completely removed iTunes, rebuild my whole iTunes library from scratch. The effected songs now won't even import to the new library. It's so weird that such a small number of people have this problem and yet nobody knows the cause or the solution for this problem.

    I'm waiting for my Snow Leopard to arrive and I'll see what happens then after clean install.
  • dembow Level 1 Level 1 (90 points)
    This issue persist in Snow Leopard. I have no doubt it's the iTunes related problem, but who knows when Apple plans to update it. Very sad.
  • livc366 Level 1 Level 1 (0 points)
    I've been having the same problem.. PLEASE let me know if you get it working.. it's so annoying not being able to play anything!
  • Haider Level 1 Level 1 (15 points)
    I had this too after installing either snow leopard or iTunes 9 so, I did the following and now it all works as it did before. Before, even when I was clicking on the mp3 files, they weren't playing - really puzzling.

    So, I went to Library>Preferences and deleted the iTunes preference lists (anything that started 'com.apple.itunes...)

    Then I ran disk utility to repair permissions.

    Next time I started iTunes, it went through a set up assistant (is this only v9?) which I answered the questions to, although I can't remember exactly what I answered to each one, apologies.

    It then started to rebuild my library which took an age! After that, all's well - back to how it was before.

    Hope there's something in there that helps.

    Haider
  • C-BUS Level 1 Level 1 (0 points)
    Has anyone tried disabling Home Sharing? I just disabled it and now iTunes is playing my music again!