5 Replies Latest reply: Jun 7, 2009 9:42 PM by Kappy
Scott Rullmann Level 1 Level 1 (0 points)
I recently purchased an external hard drive (Voyager Q by Newer Tech from OWC). I put it on my new iMac and used it to backup my system. So far so good. At some point after the system went to sleep and woke up the drive (connected via FW800) was no longer mounted. When I try and power the drive down and back on I get a dialog that says:

**************
Device Removal

The device you removed was not properly put away. Data might have been lost or damaged. Before you unplug your device, you must first select its icon in the Finder and choose Eject from the File menu.
***************

Does anyone no what I can do to mount this drive again? I don't mind reformatting it if needed but right now I cannot get the drive to mount or drive utility to even see the drive on the FW800 port. I have tried to restart the mac but this doesn't fix it. I have seen some threads with others having this same problem however I have not seen a solution.

Any ideas?

24" iMac 3.06; Mac Mini; PowerMac G4; & Powerbook G4, Mac OS X (10.5.7)
  • Kappy Level 10 Level 10 (247,600 points)
    With the drive connected and powered open Disk Utility. If the drive is listed in the left side list then select the volume even if it's grayed out, then click on the Mount icon in the DU toolbar. If the drive mounts I would suggest you do the following:

    Repairing the Hard Drive

    Open Disk Utility in your Utilities folder. After DU loads select your hard drive from the the left side list. Click on the First Aid tab, then click on the Repair Disk button. If DU reports any errors that have been fixed, then re-run Repair Disk until no errors are reported. If no errors are reported click on the Repair Permissions button. Wait until the operation completes, then quit DU and return.

    If DU reports errors it cannot fix, then you will need Disk Warrior (4.0 for Tiger, and 4.1 for Leopard) and/or TechTool Pro (4.6.1 for Leopard) to repair the drive. If you don't have either of them or if neither of them can fix the drive, then you will need to reformat the drive and reinstall OS X.

    If this does not help or the volume will not mount, then do the following:

    Extended Hard Drive Preparation

    1. Open Disk Utility in your Utilities folder.

    2. After DU loads select your hard drive (this is the entry with the mfgr.'s ID and size) from the left side list. Click on the Partition tab in the DU main window.

    3. Set the number of partitions from the drop down menu to one. Set the format type to Mac OS Extended (Journaled.) Click on the Options button, set the partition scheme to GUID (only required for Intel Macs) then click on the OK button. Click on the Partition button and wait until the process has completed.
  • Scott Rullmann Level 1 Level 1 (0 points)
    When I open Disk Utility the drive is not display at all. There are only two "controllers" listed. One is the internal HD and the other is the DVD drive. The FW port is not shown at all. If I open Disk Utility I will see the drive appear for about 5 seconds and then disappear. Right after it disappears the dialog box appears. I have tried to select the drive when it appears but it still goes away.

    Any other ideas?
  • Kappy Level 10 Level 10 (247,600 points)
    Either the drive, the enclosure, or the FW port is bad.
  • pomme-homme Level 2 Level 2 (415 points)
    I have been dealing with a similar situation on my late 2004 G5 and have isolated the problem to my LaCie d2 external HD. How can I differentiate whether the problem is the FW bus, the port or the d2 drive itself?
  • Kappy Level 10 Level 10 (247,600 points)
    Try other drives in different enclosures and try your drive on a different computer or call LaCie tech support.