10 Replies Latest reply: Jun 14, 2009 7:53 AM by TokyoGaiJin
mintchocicecream Level 1 (15 points)
Hiya

I upgraded my iTunes from 8.1.1 to 8.2 yesterday, and immediately iTunes removed all my photos that I synced from iPhoto.

I cannot get it to sync again. To troubleshoot the problem, I have tried:
• unchecking "Sync photos from:", sync it, checking it again, and syncing again
• syncing a folder of nine photos

Neither worked. There is simply no way I can get my iPhone to sync photos anymore. I haven't tried a full iPhone reset because I'm not sure what that might do to the data.

I am using iTunes 8.2 on Mac OS X 10.5.7 with all patches installed. My MacBook Pro is a first-generation MacBook Pro and my iPhone is the second generation (3G) iPhone with 8GB of storage.

By the way, iTunes appears to successfully create iPod Photo Cache folders – it is just not syncing, and it isn't a disk space issue either.

MacBook Pro 1,1; iPhone 3G, Mac OS X (10.5.7), 15.4-inch, 1.83Ghz, 2GB RAM
  • J. Steel Level 1 (10 points)
    Seeing the same thing here. After rebooting the Mac, however, it sync's up with iPhoto just fine.
  • duhkirk1 Level 1 (95 points)
    You might need to try this.

    http://support.apple.com/kb/HT1224

    Shouldn't affect any itunes folders on your hard drive. You're just removing the outer software.
  • mintchocicecream Level 1 (15 points)
    hmmm still aint working for me... i suspect its with the iphone now, i tried syncing just three photos from a spare windows computer and it wont work either
  • duhkirk1 Level 1 (95 points)
    You can always call Applecare at 1800myiphon for more help.
  • mintchocicecream Level 1 (15 points)
    Solved my own problem by doing a full restore of the iPhone. Fortunately all the settings were restored phewww!!!
  • mintchocicecream Level 1 (15 points)
    Ahh that was a bit too early, I synced my phone again and guess what? iTunes 8.2 removed all photos again.

    Looks like I'm not the only one with the trouble though - see http://macsolvers.wordpress.com/2009/06/04/itunes82/comment-page-1/#comment-696


    I've commented tehre and will repeat here - these are my troubleshooting steps that I've tried:

    - syncing just ONE photo from a folder (Rather than iPhoto) -- didnt work
    - syncing from a Windows PC with iTunes 8.2 (didn't work either)
    - complete restore of iPhone (worked the first time, then iTunes synced and removed all my photos again)
    - using eCamm iPhone Drive to VIEW the photos folder (there are no photos in there and the Photo Database is 638 bytes in size; and also tried removing anything mentioning iPhoto (didn't work)
    - using eCamm iPhone Drive to manually copy the contents of the iPod Photo Cache over (worked!!!)

    Basically I agree the problem seems to be with iTunes 8.2 -- the Photo cache is created correctly, BUT it does not sync to the iPhone... Seems sporadic though because apart from your post, I haven't found anywhere else that had the problem.

    I wish I could downgrade to iTunes 8.1.1 again =/ this is annoying not being able to sync photos!
  • mintchocicecream Level 1 (15 points)
    not solved
  • kasmankk Level 1 (0 points)
    i have same problem on winxp.
    any suggestions?
  • mintchocicecream Level 1 (15 points)
    pictures illustrating the problem:

    "iPhone" is an album containing 111 photos. No photos actually appear even after syncing - as shown by the capacity bar at the bottom:
    http://i42.tinypic.com/30mo2ev.jpg

    Note: I've tried syncing just ONE photo (inside AND outside iPhoto) and it doesnt work.
    Also tried under Windows XP and syncing ONE photo. Didn't work either. (also running iTunes 8.2 as I don't have an old version to try...)

    iPod Photo Cache is created correctly. Tried deleting and recreating it. Definitely works.
    http://i41.tinypic.com/1217og4.jpg

    If I use something like the demo of Ecamm Phone View ( http://www.ecamm.com/mac/phoneview/ ) to view the contents of the iPhone, it is clear that NONE of the iPod Photo Cache thumbnails got transferred to the iPhone. (If i manually transfer it into the Photos folder the photos work – of course, until iTunes syncs again as it then deletes all the photos once again.)

    Tried restoring iPhone - no help.

    Clearly the problem is sporadic (as not many ppl have reported it) but yet, for those that are affected, it stops something that has worked before.
  • TokyoGaiJin Level 1 (20 points)
    After doing a synch with iTunes, I deleted my entire DCIM folder with PhoneView.

    I then snapped a picture or two before re-synching to iTunes. This solved the problem.

    Deleting the DCIM folder and forcing it and its contents to be re-created causes all the corrupted files to be re-created all clean, nice, and uncorrupted.