8 Replies Latest reply: Jun 5, 2009 10:01 AM by Tod Kuykendall
Matthew Hegge Level 1 (105 points)
Suddenly, the 75GB Boot Volume on my Xserve says it only has 1.6GB of space left. This is not accurate and I am not sure what is going on. This seemed to happen after the 10.5.7 server update. I ran disk permissions several times, rebooted, zapped the PRAM. I want to re-install the downloaded 10.5.7 server update but the drive is not recognized to have enough space.

Xserve Intel dual 2.55Ghz, Mac OS X (10.5.7)
  • Matthew Hegge Level 1 (105 points)
    I did a Omnisweeper to the disc in question:

    16.6 GB usr
    6.0 GB Library
    5.0 GB private
    3.8 GB System
    1.8 GB Applications
    1.0 GB Users
    and about 27 MBs for the rest

    It is a 75GB capacity (80GB) drive...it just is not adding up

    Message was edited by: Matthew Hegge
  • Antonio Rocco Level 6 (10,517 points)
    Hi

    On the server launch Terminal and issue:

    sudo du -chxd 1 /

    Be patient as it will take a while. It might probably end up being some runaway log in /var/log? Or - if you're using the Print Service - print jobs that have not been flushed; /var/spool/cups. Or you've possibly - inadvertently - saved a disk image (or two) in /Volumes.

    Tony
  • Matthew Hegge Level 1 (105 points)
    I will give that a shot. Thanks

    I do not use print services. I am running the newest version of Retrospect (v8) to a Tandberg StorageLibrary and am hoping that has nothing to do with it.
  • Matthew Hegge Level 1 (105 points)
    No change in disc space after running the sudo du -chxd 1 /, unless that changes at next restart?
  • Witold Oleksiak Level 1 (135 points)
    That command will not change anything on your drive, but will display detailed information about disk usage. Finder or Omnisweeper might not check all the drive contents.
  • Matthew Hegge Level 1 (105 points)
    All I got was a runaway log. I have run other commands that do a Omniscan-type check. It does not solve my issue though, just gives a report that does not add up.
  • Witold Oleksiak Level 1 (135 points)
    That command displays total file sizes count in the last line. Could you please check if it really does not add up ?

    If so, try running disk verify from Disk Utility and see if it reports any errors.
  • Tod Kuykendall Level 4 (2,270 points)
    I haven't tried it on 10.5 Server yet but under 10.3/4 I've always gotten good results from *Disk Inventory X* especially when launched using Pseudo to make sure you have root permissions for the disk check. One nice thing is it gives a graphical feedback which makes it easy to spot the culprit if something is taking a bunch of space.

    HTH,
    =Tod

    PS I just wanted to add this reminds me of the first time I really used DIX to good effect. I had a user who had inadvertently ended up with his drive becoming the target of his Retrospect back-up process so it was backing itself up to itself. He couldn't see the hidden Retrospect volume but he knew his drive space was magically disappearing. Hmmm...

    http://www.derlien.com/
    http://personalpages.tds.net/~brian_hill/pseudo.html

    Message was edited by: Tod Kuykendall