6 Replies Latest reply: Oct 30, 2009 7:02 PM by goodfela
BoltUprite Level 1 (0 points)
Two Windows XP machines - one running iTunes 8.1 the second running iTunes 8.2 - both fail to connect to AirPort Express with firmware 6.3. Both return the message "Unknown error (-15006) occured" when trying to connect to remote speakers.

A third machine, also running XP and iTunes v8.2 is able to connect just fine.

Does anyone know what error -15006 indicates or how to solve the problem?

Forced to used Windows, Windows XP
  • Calum Shaw Level 1 (0 points)
    From another discussion on this I found that resetting my router and then the airport solved the problem. The resets have to be performed in that order.
  • drumspace Level 1 (0 points)
    I have a similar problem. i get green lights, it is recognized, both by creating a wireless network, or joining a wireless network. everything is AOK. then i go to choose to stream music to AE in itunes, i get this stupid 15006 unknown error. i assume that it is a fault in the itunes software!!!! i used to have ZERO problems using the older itunes, but unfortunately i cannot get the older itunes because i have 64 bit vista. software and firmware all are up to date, i have tried to reset my routers in the order of home router 1st then AE. i have tried with firewall's off and on, none of these things work. there is not much info on google or on this apple site in regards to this error. this is really starting to upset me. apple please figure this out, and make the new version of windows itunes work with AE.
  • deviltrick Level 1 (0 points)
    I have a laptop running windpws vista, which I usually connect with two wireless networks, one from my office, the other one at home. I've noticed that when I came from work, I usually brought my laptop in sleep mode. After waking up, my laptop connects to my network, but the identifier was like networkname (2), and iTunes wouldn't work with my airport express, one with firmware 6.3, another one with firmware 7.1.4.

    If I connect my laptop via the ethernet cable, then my airport express would work ok, because the airport express is in the "same" network, while connecting via wireless would give the mentioned error.

    Windows has an option within network configuration which allows to combine two wireless connections, to be taken as only one.

    I deleted my actual connection and made it again, so my wireless network would be detected correctly, and I am enjoying iTunes via airport express again.

    Hope this tip works for you.
    Oh, the problem came with the last version of iTunes for windows vista.
  • hardbomboo Level 1 (0 points)
    I had such problem these couple months since I bought an Airport Express.
    As I remember, there were several versions of iTune, AirPort firmware, AirPort Utility update during these days. All of those didn't fix the problem, maybe, even worse.
    This is only happened on my Windows PC, my old PowerMac G4 with old iTune version always work, although, sometimes, music stops even iTune is still working...
    Fortunately, I found a work around to solve PC problem.

    Here's the steps,
    Launch Airport utility,
    stop WiFi,
    update the setting on Airport,
    wait until it's done.
    Turn on WiFi,
    press the last setting button on this tab,
    adjust anything, such as 50 minutes to timeout
    update the setting on Airport.
    wait until it's done.
    try to access this Airtune device under iTune.

    Hope these procedures worked on your system.

    Let me repeat again,
    This problem only happened on my Windows PC, I believe THERE MUST BE SOMETHING IN FIRMWARE ARE WRONG!!!!!

    My configuration:
    Windows PC, PowerMac G4 and Airport Express are all connected via Ethernet.
    In other words, I'm using AirTune over Ethernet.
  • tom75ch Level 1 (0 points)

    I got the same issue. Thanks for the hint about Network Connections.
    As the iTune on my PowerBook worked still fine after updating I thought its on the iTune installation on my Win XP.
    The case was that i switched to configure a Accesspoint to static IP-Address.
    After switching back to the privious dynamic one it workes again.
    Did not track down how to get ride of the error with a changed network connection.
    Good luck Thomas
  • goodfela Level 1 (0 points)
    I've fixed my issue by making sure all the airports and computers were on the same subnet. And my main computer wasn't...