4 Replies Latest reply: Sep 16, 2009 7:19 PM by Nightborne
aclc Level 1 Level 1 (0 points)
I am unable to complete the full 8.2 install on my machine - the AMDS component fails to install, although the rest of the packages go in successfully. Unfortunately, without AMDS, I can't sync' my iPhone 3G, nor my iPod.
Having broken out the AMDS package from the 8.2 installer .exe, and tried to run it separately from the command line with logging enabled, the error appears to occur while trying to install the USB drivers themselves - the relevant lines are inserted here:

DIFXAPP: INFO: ENTER: DriverPackageInstallW
DIFXAPP: INFO: Installing INF file 'C:\Program Files\Common Files\Apple\Mobile Device Support\Drivers\usbaapl64.inf' (Plug and Play).
DIFXAPP: INFO: Could not open file C:\Windows\System32\DriverStore\FileRepository\usbaapl64.infamd64_neutralb6bcda7a7950fa43\usbaapl64.inf. (Error code 0xE0000003: The syntax of the INF is invalid.)
DIFXAPP: ERROR: PnP Install failed. (Error code 0x3EE: The volume for a file has been externally altered so that the opened file is no longer valid.)
DIFXAPP: INFO: Attempting to rollback ...
DIFXAPP: INFO: No devices to rollback
DIFXAPP: INFO: RETURN: DriverPackageInstallW (0x3EE)
DIFXAPP: ERROR: encountered while installing driver package 'C:\Program Files\Common Files\Apple\Mobile Device Support\Drivers\usbaapl64.inf'
DIFXAPP: ERROR: InstallDriverPackages failed with error 0x3EE
DIFXAPP: RETURN: InstallDriverPackages() 1006 (0x3EE)
CustomAction MsiInstallDrivers returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 21:16:25: InstallFinalize. Return value 3.
Action 21:16:25: Rollback. Rolling back action:
Rollback: MsiInstallDrivers
Rollback: MsiRollbackInstall

I'm unable to break open the .msi fully because it is apparently 'corrupt', although that doesn't seem to stop Windows having a go. That said, the little that I can peer into it, the relevant .INF file mentioned in the log appears to be zero length.

Backing out the full install and downgrading to 8.1.1 seems to work fine, except that now MobileMe won't work because it's keyed to iTunes 8.2!!

Has anyone else seen this problem? Has anyone else got a valid AMDS .msi file I can try?!

Thanks,

ANdy

Dell Dimension 9150 4GB RAM, Other OS, Windows 7 RC 64-bit
  • aclc Level 1 Level 1 (0 points)
    I managed to work out how to successfully install iTunes 8.2 64-bit on Windows 7 RC. The issue with Apple Mobile Device Support, in particular, appears to be that it needs to write a couple of USB drivers into the c:\windows\system32\drivers sub-tree, and access to that is pretty locked down. Even being an Administrator isn't sufficient to grant rights to it. But I disabled User Account Control, and that coupled with being logged in as a user in the administrators group was sufficient to get it to install.
    So now it all works fine.
  • aires69uk Level 1 Level 1 (0 points)
    Well I unpacked the iTunes 8.2 package and then installed both iTunes and Apple Mobile Device Support separately using the /passive command. They've both installed and both show up in Windows Task Manager - BUT..... Windows only sees my iPhone 3G as a camera in My Computer & Device Managar - iTunes either doesn't see the phone, (ii) sees the phone but can't really identify it, or (iii) comes up with an error code of 0xE8000065. Now I just don't think the 'Apple Mobile Device Support' is identifying the iPhone at all.
  • Erik713 Level 1 Level 1 (0 points)
    I didn't have the exact same issue, but perhaps this might help...

    http://discussions.apple.com/thread.jspa?threadID=2048489&tstart=0
  • Nightborne Level 1 Level 1 (0 points)
    Maybe a little bit of forum necromancy going on here, but I thought it was worth posting for W7 RC users. aclc's post got me thinking about this tonight when I had issues updating my iTunes, and after some hard work investigating the issue, I figured out what has to happen. Basically aclc is exactly right with the root of the issue - I'm simply expanding the idea to involve instructions for those who can't afford to or won't be bothered with finding out the details of the solution.

    Please note that these instructions were written assuming you are using an administrator-level account on a 64-bit Windows 7 Release Client installation, but should help 32-bit users if they have the same experience - I have not tried this solution on a 32-bit box. This fix has been administered using iTunes 9, so I have personally verified this will work with that version of iTunes.

    iTunes 9 issue: iTunes requesting that you uninstall and reinstall for Apple Mobile Support after trying to install iTunes 9 on Windows 7 RC x64

    Resolution:
    By now you've already gone through the failed install on Apple Software Update, and may or may not have manually downloaded iTunes...I'm going to start from the beginning for the benefit of anyone who doesn't want to waste the hour and a half that I did to figure this one out (actually i detoured to read up on a few things for most of that time to feed my inner nerd, but I digress). Plus, this should help with retail Windows 7 users (provided Apple and MS haven't worked this out amongst themselves).

    1 - TURN OFF UAC
    a) Hit Windows Key + R to open the Run command box, type "msconfig", and hit enter or click OK.

    b) Go to the Tools tab, highlight Change UAC Settings and click the Launch button.

    c) Move the slider all the way down to the bottom to turn off UAC.

    d) Reboot your PC for the changes to UAC to take effect.

    2 - INSTALL iTUNES AND APPLE MOBILE SUPPORT THE RIGHT WAY (A.K.A. NOT LIKE THE INSTALLER TRIES TO)
    a) In Apple Software Update, go to Tools | Open Downloaded Updates Folder... (if already downloaded and the installation has failed)
    -or-
    Use the Download and Install Manually feature of the Tools menu (if you have not already tried to install via Apple Software Update)

    b) Locate the iTunes installer and the Apple Mobile Software Update installer. For me they were called:
    iTunes64.msi
    AppleMobileDeviceSupport64.msi

    c) Right-click one of the files identified in 2a. Select Properties, and go to the Compatibility tab. Check the "Run this program in compatibility mode for:" box and select "Previous Versions of Windows". Click Apply. Repeat for the other file in Step 2a.

    d) Run the Apple Mobile Device Support installer identified in 2a. With UAC and compatibility mode both turned off, you should have a clean install.

    e) IF YOU HAVE ALREADY INSTALLED iTUNES AND GOTTEN THE MESSAGE THAT YOUR MOBILE DEVICE SUPPORT IS NOT COMPATIBLE, DON'T PANIC - HERE'S THE FIX: Right-click the iTunes installer identified in 2a and select Repair. You should see a progress bar but will not have to go through a full install. Voila! Open iTunes, plug in your iPhone, and you should be good to go.
    IF YOU HAVE NOT YET ATTEMPTED TO INSTALL iTUNES, simply run the installer for iTunes identified in 2a.


    There you have it - this should do it for you and save someone the aggravation of figuring this out on their own.

    Don't forget to turn UAC back on if you need/want it on.

    Hope this helps!!


    ~NB
    PnT forever.

    Message was edited by: Nightborne