1 2 Previous Next 17 Replies Latest reply: Jun 11, 2009 10:46 PM by zmix
zmix Level 1 Level 1 (115 points)
I just updated to Quicktime 7.6.2 and now when I launch Logic 7.2.3 I get the following error messages:

Could not load Module "Ecore"

Could not load Module "Xlogic"

Could not load Module "XsoundDiver"

Are these relevant or important parts of Logic?

G5 Quad, Mac OS X (10.4.11)
  • 1. Re: Could not load Module "Ecore",  "Xlogic", "XsoundDiver"
    Caramby Level 4 Level 4 (1,515 points)
    Do they belong to 3rd-party plug-ins which you might have installed previously?
  • 2. Re: Could not load Module "Ecore",  "Xlogic", "XsoundDiver"
    zmix Level 1 Level 1 (115 points)
    Thanks for the reply,

    That's an interesting theory. These error messages occur when Logic is displaying the Autoload and before the "rebuilding tree" message. My Autoload has no plugins or instruments so I wonder if there is a link...

    I have trashed the AU preferences and rescanned, rebuilt permissions, etc, but no difference.
  • 3. Re: Could not load Module "Ecore",  "Xlogic", "XsoundDiver"
    Caramby Level 4 Level 4 (1,515 points)
    Sound Diver is a cross-platform MIDI device editor and librarian.

    Xlogic appears to be a compressor.

    Ecore is "the core event abstraction layer and X abstraction layer that makes doing selections, Xdnd, general X stuff, and event loops, timeouts and idle handlers fast, optimized, and convenient."
  • 4. Re: Could not load Module "Ecore",  "Xlogic", "XsoundDiver"
    zmix Level 1 Level 1 (115 points)
    Well, if you google "XLogic" you will find that it's the trade name of Solid State Logic (SSL)'s rack mounted outboard EQ, mic preamps and compressors. This is certainly not what Logic 7.2.3 is unable to load.

    Are these three files a part of OSX?

    Any suggestions about how to restore them?
  • 5. Re: Could not load Module "Ecore",  "Xlogic", "XsoundDiver"
    Caramby Level 4 Level 4 (1,515 points)
    Is it possible that you have at some time installed some plug-ins, & then later on removed them? My guess is that these are legacy files from a poorly-uninstalled plug-in or two.

    If you can remember doing anything like this, find the original installers for the plug-ins & run them; but instead of installing the plug-ins again, choose "uninstall".
  • 6. Re: Could not load Module "Ecore",  "Xlogic", "XsoundDiver"
    zmix Level 1 Level 1 (115 points)
    All I did was update Safari and Quicktime... nothing else changed, all installed plugins are working fine...It's quite odd....isn't it?
  • 7. Re: Could not load Module "Ecore",  "Xlogic", "XsoundDiver"
    Caramby Level 4 Level 4 (1,515 points)
    Yes. So, does Logic launch even so? Have you tried disabling Core Audio?
  • 8. Re: Could not load Module "Ecore",  "Xlogic", "XsoundDiver"
    zmix Level 1 Level 1 (115 points)
    Sorry, I should have been more thorough in my description.

    I only see these messages when I initially launch logic. Loading subsequent projects does not generate these errors. At each error screen there is a 'progress bar' window which is waiting at 0% until I click the "cancel" button and the same thing repeats for the next one.
  • 9. Re: Could not load Module "Ecore",  "Xlogic", "XsoundDiver"
    Caramby Level 4 Level 4 (1,515 points)
    Go to your Drivers pane & disable Core Audio. Restart Logic & see if you get the same messages. I want to know if they are part of Core Audio.

    You will need to turn Core Audio back on again after this experiment, of course…
  • 10. Re: Could not load Module "Ecore",  "Xlogic", "XsoundDiver"
    zmix Level 1 Level 1 (115 points)
    Caramby,

    That was a great suggestion. I disabled the core audio driver and relaunched. No difference.

    At least we now know what it isn't....

    What is the file that Logic 7 uses as it's "autoload"? It used to be named "autoload" in previous versions...

    EDIT:

    Since I only get these errors upon startup, and I do not get them while loading any subsequent songs, I changed the startup preference to "automatically load most recent song on startup" and then relaunched.

    Ugh.. no difference.

    It seems that those files are a part of the Logic 7 structure rather than song related.
  • 11. Re: Could not load Module "Ecore",  "Xlogic", "XsoundDiver"
    Caramby Level 4 Level 4 (1,515 points)
    I'm more & more convinced you have some legacy components. Have a look in here:

    +Library > Application Support > Logic > Plug-In Settings+ &
    +Users > (username) > Library > Application Support > Logic > Plug-In Settings+

    LMK if you see anything suspicious in either of those folders.

    Actually, I'm on 8 now, & I don't remember where 3rd-party plug-ins should live for 7 (would someone else like to chime in now?), but wherever it is — that's where you should look.
  • 12. Re: Could not load Module "Ecore",  "Xlogic", "XsoundDiver"
    zmix Level 1 Level 1 (115 points)
    Hi Again,
    I am well versed in the plugin management of logic 7 and 8.. I do quite a bit of consulting / testing / development for several 3rd party plugin companies, as well as writing my own plugins.

    Nothing changed in my system -except- updating quicktime and safari...

    I doubt it is plugin related, since the problem exists even with the core audio driver disabled.
    In addition I tried this tip from the manual:

    "If you press Shift-Control while launching Logic, the AU Safe Mode will be used:
    Only plug-ins that passed the validation test will be used; manually activated plug-ins
    that failed the validation test will not be available."

    ...no difference.


    I am going to investigate the other key combination - launch options to see if there is a driver issue elsewhere...
  • 13. Re: Could not load Module "Ecore",  "Xlogic", "XsoundDiver"
    zmix Level 1 Level 1 (115 points)
    I looked inside the Logic 7.2.3 package and there is an "Ecore" file as a part of the "Framework"
    Replacing this in the app did not change the problem at all...
  • 14. Re: Could not load Module "Ecore",  "Xlogic", "XsoundDiver"
    Caramby Level 4 Level 4 (1,515 points)
    It could be that you have permissions problems on some of your files. Open +Applications > Utilities > Disk Utilities+ & verify permissions on the drive in question. If there is a problem, choose 'Repair Permissions'.
1 2 Previous Next