Skip navigation
This discussion is archived

Full-duplex fails on new Mac Pro

8890 Views 14 Replies Latest reply: Apr 15, 2010 6:38 AM by screenwright RSS
G. Gollinger Calculating status...
Currently Being Moderated
Jun 10, 2009 8:43 AM
Hello all,

Background: the network port referred to below is 100/full-duplex/no autonegotiation. This is not changeable, sadly.

On a new (purchased May '09) Mac Pro, it refuses to accept the manual/100/full setting. It shows it as disconnected. Setting it back to "Automatic" brings up the connection, but only at 100/half with Ethernet collisions all over the place. It can also be set to manual/100/half and connect, but with the same Ethernet collision problems.

I can verify the port and cable are good; I can attach a white MacBook set to manual/100/full on that same port with the same cable without issue.

Has anyone else seen this behavior, and is there a resolution? Thanks.
Mac Pro early 2009, Mac OS X (10.5.7)
  • Ramses Moya Level 1 Level 1 (135 points)
    Currently Being Moderated
    Jun 10, 2009 10:46 AM (in response to G. Gollinger)
    I tried it on mine and it seemed to work just fine...

    Weird... have you tried both ports on your mac? or a different network drop somewhere else? (just to eliminate things as you go... )
    Octo 2.66 Nehalem 16 Gb RAM, MacBook Pro 4Gb, PowerMac G5 8GbRAM, iPhone, Mac OS X (10.5.7), 8Tb Storage, 24" and 20" LCDs
  • Ramses Moya Level 1 Level 1 (135 points)
    Currently Being Moderated
    Jun 12, 2009 7:47 AM (in response to G. Gollinger)
    Don't know what to say... what you want to make sure is that there are no problems with the negotiation between them..

    I seem to remember long ago, that depending on the configuration of certain Cisco switches and the mac's Appletalk network number, would interfere with the negotiation of the speed. I think it had to do with the spanning-tree protocol and it would always bring you to 1/2 duplex. Its a fix at the Cisco switch... Seem to remember that by setting the same Appletalk Network number manually in the Appletalk control panel, the problem went away. That is why certain machines had the problems and others did not...

    But I don't know what is your network setup like... Are you in an office env or at home?

    Have you tried setting the duplex manually?

    ifconfig en0 media 1000baseTX mediaopt full-duplex
    Octo 2.66 Nehalem 16 Gb RAM, MacBook Pro 4Gb, PowerMac G5 8GbRAM, iPhone, Mac OS X (10.5.7), 8Tb Storage, 24" and 20" LCDs
  • direwolf8 Level 4 Level 4 (1,280 points)
    Currently Being Moderated
    Jul 20, 2009 11:26 AM (in response to G. Gollinger)
    There is no standard for auto speed/duplex detection, and some network interfaces don't work well with some switches. If you can't lock the speed and duplex on your switch port, then you're probably using a cheap unmanageable switch and it just may not work well with your Mac network interface.

    We're very discouraged here by vendors who supply mission critical network hardware and suggest we leave the port set to autodetect. That has never been a reliable feature, even using components from the same manufacturer. We have seen 3com network adapters fail to connect properly to 3com switches, cisco to cisco, netgear to netgear, etc. If manufacturers can't make their own devices do it properly don't expect devices from different manufacturers to do it reliably.
    G5, Mac OS X (10.5)
  • Sultan of Stream Level 1 Level 1 (20 points)
    Currently Being Moderated
    Sep 14, 2009 10:22 AM (in response to G. Gollinger)
    I've had the same issues with '08 Mac Pros & '09 Mac Pros - they never automatically select 100Mbit full-duplex, it must always be done manually - and half the time selecting 100 Mbit, full-duplex doesn't work. The Macs in my office are all connected to an XSAN, so both Ethernet ports are used on different subnets - both are 100 Mbit, full-duplex. I've even seen instances where one Ethernet port works properly (allows you to manually set 100 Mbit, full-duplex) & the other port ON THE SAME MAC PRO does not... Very frustrating! Fortunately, we have HP switches (the same models for both subnets) that I manage, so when it happens, I just set the switch port to auto, the Mac port to auto & wait for the next OS X point release - & try to set them manually again. This results in half-duplex communication for a while, but at least there are no collisions.

    And guess what? This morning I just updated a '09 Mac Pro from Leopard to Snow Leopard - everything worked fine before the OS update, after the reboot, I find that I can't manually select 100 Mbit full-duplex. I had hoped that Snow Leopard wouldn't have this issue...
    PCs and Macs (Intel and PPC)
  • nicklyaine Calculating status...
    Currently Being Moderated
    Oct 1, 2009 12:25 PM (in response to G. Gollinger)
    We are having the exact same issue at our organization. This is a network card driver issue that started when the 10.5.7 update was applied to 2009 Mac Pros. After this update, 100/Full Duplex no longer works. We've opened a ticket with Apple on this; for now we found a workaround. The file that's causing the problem is IONetworkingFamily.kext located in /System/Library/Extensions/ folder. The version that came with 10.5.7 causes the NIC to stop working on 100/Full. Copy the IONetworkingFamily.kext from a 10.5.6 system. On the affected system, boot from another drive. Paste the 10.5.6 IONetworkingFamily.kext file into the affected OS's /System/Library/Extensions/ folder, replacing the original. Last step (very important), run a repair permissions on the affected OS which should set the proper permissions on the file you just copied (System account should Read & Write access). Reboot to the affected OS; NIC should now work on 100/Full. Be aware, this is only a workaround; if 10.5.8 is run on this patched OS, the issue will reoccur.
    Mac Pro, Mac OS X (10.5.8)
  • toddpiket Calculating status...
    Currently Being Moderated
    Nov 13, 2009 6:42 AM (in response to nicklyaine)
    Did your ticket ever get answered? I am having the same problem and it is EXTREMELY frustrating. I'm watching all these Windows machines around me work just fine and I'm beginning to wonder if I should have made the switch to Mac at all.
    MacBook Pro, Mac OS X (10.5.8)
  • Avelsis Calculating status...
    Currently Being Moderated
    Jan 21, 2010 8:59 AM (in response to toddpiket)
    Under 10.6.2 the same problem.
    Apple disgrace themselves.
    I hope someone finds a quick and clean solution.
    Thanks nicklyaine for this workaround. I will try out and report, if its working also under 10.6.

    Greetings from Germany
    Avelsis
    nearly every mac since 10.3.9
  • buzzyboy1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 1, 2010 6:39 AM (in response to G. Gollinger)
    Is there any movement in resolving this issue? My network connection used to FLY with 10.5. Now it is ultra-slow and I can't set it to full-duplex 100Mbit like before. VERY frustrating. Am I an isolated case? Is there something I can ask my network administrator to do to the switches/routers? Is a fix in the works? Come on Apple, please speak up.
    Mac Pro 2 X 2.8 Quad Core Intel Xeon, Mac OS X (10.6.2)
  • buzzyboy1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 3, 2010 9:39 AM (in response to buzzyboy1)
    Solved! You have to use Terminal to enter this ifconfig command:

    sudo ifconfig en0 media 100baseTX mediaopt hw-loopback

    Now Full-Duplex is working! Come on Apple, this hw-loopback option should be in the Network System Preference if this is what it takes.
    Mac Pro 2 X 2.8 Quad Core Intel Xeon, Mac OS X (10.6.2)
  • screenwright Calculating status...
    Currently Being Moderated
    Apr 15, 2010 6:38 AM (in response to buzzyboy1)
    This DOES work, but on all of my Snow Leopard machines, it is reset back to half-duplex after a system restart.

    Curious to see if everyone else has the same problem.
    Mac Pro, Mac OS X (10.4.11)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.