Previous 1 2 Next 25 Replies Latest reply: Aug 26, 2009 3:21 AM by akayib
Mike Poirier Level 1 Level 1 (10 points)
Hey Folks - could use some help here... I can't seem to find anyone with the same problem.

I've created a restricted account for my son and understand I must login as him to create bookmarks in his safari browser to websites that I will allow him to visit.

The problem is when I open the browser & try to add a site by entering my admin username & password - nothing happens. Also, when I try to open his bookmarks & type in my admin name & password - it doens't do a thing... but if I hit cancel instead of trying to login - it opens the bookmarks window but I still can't add sites.

Any ideas out there?

Thanks so much in advance.

Mike

P.S. I've tried creating a new account & also got rid of all safari preferences & settings.

MDD G4 Dual 867mhz, Mac OS X (10.4.11)
  • BDAqua Level 10 Level 10 (120,375 points)
    Hi Mike, not on Tiger at the momemt, but I think you set those in the Admin account, Accounts Pref Pane...

    http://www.ehow.com/how2056443set-parental-controls-mac-os.html
  • Mike Poirier Level 1 Level 1 (10 points)
    yeah - that's what I'm doing. You activate it in the admin account but you control the bookmarks from the restricted account with your admin user name & password. That's what it will not allow me to do.

    Thanks,

    Mike
  • BDAqua Level 10 Level 10 (120,375 points)
    Ah, back on Tiger, Right you are, mulling it now...
  • KevanGordon Level 1 Level 1 (10 points)
    Mike,

    This is, in my opinion, quite a significant problem with Safari 4 on Mac OS X 10.4.

    I handle IT for a school over here in Scotland. The problem with Safari Parental Controls appeared yesterday (Friday). I spent the whole day working on it with no result at all. However, i have some facts about it that i have passed on to Apple for further investigation.

    The issue affects both PPC and Intel versions of 10.4.11. it does NOT affect 10.5.7.

    I confirmed my results on 10 different Macs. Test the following for me and post results...

    1. Create a new user on your Mac. Make that user a Managed one.
    2. Enable the Safari Parental Controls.
    3. Log in to the account you have just created.
    4. Try to visit a site that is not in the bookmarks.
    5. Instead of typing in Admin credentials, when prompted, simply click Cancel.

    What happens?

    6. Now, try it again with proper admin credentials entered and click on OK

    What happens?

    Thanks for your help.
  • Mike Poirier Level 1 Level 1 (10 points)
    Hey Kevan,

    I got everything to work by downgrading. - I'm just going to leave it at that until they fix Safari 4 w/ 10.4.11

    That's what I noticed too... it wouldn't acknowledge my admin user name & password but when I clicked cancel it would open up my bookmarks window.
    It still wouldn't allow me to do anything in there though.

    Very frustrating to say the least. - I got fed up & that's when I decided to re-install & not run software update.

    Thanks!

    Mike
  • KevanGordon Level 1 Level 1 (10 points)
    Hi,

    Thanks for taking the time to reply. I am beginning to wonder if this only happens in isolated cases. Maybe there is simply too small a number of Managed 10.4.11 users with Safari 4 for this to be important.

    However, such a glaring error should really catch the attention of enough people for it to be more commonly discussed. My initial post on Macrumors drew almost no interest.

    I even contacted one of the site admins on iChat and was met with silence!

    Downgrading.... here we come!!!
  • Mike Poirier Level 1 Level 1 (10 points)
    No prob - thank you for also getting involved.

    It does seem like an isolated case. - I did quite a bit of google searchin' prior to posting on here & found nothing.

    I wondering if it's confliting with something else we have installed? I'm curious if a clean install of 10.4.11 w/ Safari 4 would yeild the same result?
    I've been upgrading my OS - not a clean installation.

    hmmm?

    Mike
  • dan-the-red Level 1 Level 1 (5 points)
    All, I'd be interested in a resolution to this, as well.

    Like others listed, I've enabled Parental Controls for my son (yes, he's a genius, but I digress!).

    When I add a new site to Safari, it prompts for the admin login; mixed results. Sometimes it adds, other times not. When he clicks on the bookmark icon, and is prompted for a password, he merely hits cancel, and is in the bookmark view (ie, the password is only there for show, apparently!), and he proceeds to have a field day.

    Also, he's managed to "reset" the bookmarks, and I don't know how.

    I don't mind the concept of my son being smarter than me, but he's only 6...I should have the upper hand in computers for at least another couple of years...

    Final add-on: before I realized HOW he was doing this, I upgraded to the latest Safari, to see if that would fix the issue. Apparently, it's in the last two (or so) versions. It's iBook G4 1GHz w/10.4 and (now) Safari 4
  • MDmacuser Level 2 Level 2 (360 points)
    Hello all,

    I am experiencing the same problem while attempting to restrict items for my niece and nephew. I can simply hit cancel under their account and can add any site. I figure it's only a matter of time before they figure this out. I am hoping that Apple comes up with a solution soon.

    thanks
  • KevanGordon Level 1 Level 1 (10 points)
    Hi,

    This is NOT and isolated problem. I have now confirmed the problem on every qualifying Mac at the school i handle IT for. 48 out of 48 systems have the problem.

    I have contacted Mike at XLR8 today to see if he will ask readers to test and confirm.

    It worries me that so many parents may be oblivious to this flaw!!!
  • dan-the-red Level 1 Level 1 (5 points)
    I've also had a 100% "success" rate (2 out of 2) in reproducing this problem. My macs that have Leopard don't seem to have this problem (but, I don't let my kids play on those-at least not willingly).

    I'll be upgrading to 10.5 on my iBooks, and will report back; methinks this is 10.4 + Safari 3 or 4. Upgrading Safari didn't help.

    I'll report back, once I do the upgrade, and share my experiences.

    ~DtR
  • jvarn Level 1 Level 1 (0 points)
    I can confirm that this happens on a fresh installation of Tiger 10.4 updated to 10.4.11 with Safari 4. I did not enable the Parental Controls until I had finished running Software Update, so I cannot say whether this also affects Safari 3.

    Has anyone had any success working around this?
  • Mike Poirier Level 1 Level 1 (10 points)
    It does not affect Safari 3.

    I'm currently running 10.4.11 & Safari 3 & have no problems at all.

    Can't wait for a fix!

    Thanks everyone for your involvment.
  • M.A.G. Level 1 Level 1 (0 points)
    Great to know that I'm not the only one with this problem. My 6 year old found out the trick!! Guess we will be going back to Safari 3 until they fix this problem.
Previous 1 2 Next