Previous 1 2 Next 16 Replies Latest reply: Aug 13, 2009 7:19 AM by SharedThought
arnarb Level 1 Level 1 (0 points)
Hi.
I just installed Safari 4 on my work PC. When launching the application it crashes immediatelly. In the Application Event viewer the following is collected:

Faulting application safari.exe, version 4.530.17.0, faulting module msvcr80.dll, version 8.0.50727.1433, fault address 0x000172d7.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

I'm running Windows XP PRO SP3. Dell Latitude, Intel Core2 Duo, 2GB RAM. I have latest iTunes (v8.2.0.23) and Quicktime (7.6.2 build 515) installed on the same PC, both working fine.

I've tried to uninstall and re-install -> same result.

Any ideas?

Dell, Windows XP Pro
  • sray-95006 Level 1 Level 1 (0 points)
    I'm having a similar problem on Vista Home Premium (64bit). Safari 3 was working fine but after running the Apple Updater and installing Safari 4 it will not display on desktop. Checking processes running Safari is resident and running, consuming about 13mb of mem, zero cpu cycles, and 3 threads. I have a 4 cpu system (x9650) with 4gb mem. Tried completely removing (using the apple uninstaller and windows uninstaller)and re-installing with a fresh download of Safari 4. Still will not display the browser.
    Tried searching the web for others having this problem but not seeing much out there. Either these are corner cases or people are just giving up. Any thoughts on next steps?
  • arnarb Level 1 Level 1 (0 points)
    I renamed the Plugins folder in C:\Program Files\Safari. When Safari launched in re-generates the folder and installs the plugins (JavaPlugin.jar and npJavaPlugin.dll). Safari then crashes.

    I had wondered if the plugins were the reason for the crash, but since the installer automatically installs the missing files/folder, it has no effect deleting it.

    I haven't tried booting in safe mode and remove the folder, that may work if it stops the installer (and the plugins are indeed the problem).

    Safari is still not working and it's very frustrating to install software and it doesn't work at ALL. Apple, are you listening?
  • miki69 Level 1 Level 1 (10 points)
    Did you try to install latest Adobe Flash player and Shockwave player from Adobe website? To see if this will clear out your problem.

    Cheers,
    Miki
  • arnarb Level 1 Level 1 (0 points)
    One thing worth to mention. I did install Safari 3 on my PC way back but I removed it after short usage as it was not really working for me. It crashed frequently and after a short while I un-installed it.

    I tried again to un-install Safari 4. This time I also searched Regedit for Safari keyword and removed (almost) all occurrences. I left out those that did not apply to the software itself. Note however that I did remove the link from MobileMe and all references by the windows installer. Seems like Apple is not cleaning properly as the Registry is full of Safari references after the un-install.

    I also removed all folder and files that related to Safari install. This includes Program Files, Common Files and Document and Settings\All Users\Application Data\Apple.

    Once I had removed all occurrences from Regedit I re-installed Safari 4.

    This does not resolve the issue. Safari still fails to start.
  • arnarb Level 1 Level 1 (0 points)
    I installed the latest versions from Adobe. No change, Safari still fails to start.

  • miki69 Level 1 Level 1 (10 points)
    Tough one, huh? Ok, you can try this: uninstall Safari 4 with Revo Uninstaller (free) or with Your Uninstaller to completely remove Safari and all its traces from your system. Restart PC and try installing Safari again.

    You should also check if you have latest direct x installed, and also latest drivers for video card.

    Let me know if it worked for you.

    Cheers,
    Miki
  • arnarb Level 1 Level 1 (0 points)
    Hi Miki.

    Thanks for the assistance. I've uninstalled Safari using Revo Uninstaller, removing Safari completely from my PC. I then restarted by system and install Safari...same problem.

    I have DirectX 9.0c installed on my PC and almost the latest version of the driver for the video card. It's Intel(R) 965 Express Chipset Family, version 6.14.10.4831. From Dell's website I notice the latest driver is 6.14.10.4926 A06 dated May 13th 2008. Mine is dated back in May 16th 2007. However I'm for some reason unable to download it from Dell's website, cannot find the file so I'll try again tomorrow.

    Again thanks for the pointers. If this doesn't work I'm opting Safari out on my PC, still using it on my Mac though. Hope Apple does a better job when releasing software for Windows!
  • sray-95006 Level 1 Level 1 (0 points)
    I doubt that this has anything to do with Direct X or a Video Driver, or Flash for that matter. Ideally the Apple Installer should ensure all these enviormentals are proper prior to installing Safari.

    Something is preventing the application from completely starting is my guess. Would like to know what debug steps are needed at this point. Is it possible that this is a Installer issue? Something missed at the finish? If so how do you debug?
  • niftydog Level 1 Level 1 (0 points)
    I have had the same problem, after a boring advise of update, I do not use, nor need Itunes...I've updated version 3.x to 4...and could not even start to run Safari (Win XP Pro SP3 up to date,NVidia drivers ver 185.85 (04-30-2009) and last Direct X 9.0c, Java 6 rel. 14).
    Following an advise, I've deinstalled Safari with YourUnistaller, which supposed to clean up any trace, and the reinstalled a fresh version downloaded from Apple.
    The same damm message and crash.
    AppName: safari.exe AppVer: 4.530.17.0 ModName: webkit.dll
    ModVer: 4.530.17.0 Offset: 0007df71
  • SharedThought Level 1 Level 1 (35 points)
    Same problem here. Safari 3.2.3 installs and runs fine. Safari 4 crashes on launch with an error in msvcr80.dll.
  • Tom613 Level 1 Level 1 (0 points)
    same here
  • Chudinho Level 1 Level 1 (0 points)
    Please notify me by PM if somebody finds the solution, Safari is my fav browser and I'm depressed of this issue.
  • LaRise Level 1 Level 1 (0 points)
    Look here:
    http://support.microsoft.com/kb/326922/en-us

    Try to reinstall the msvcr80.dll.
  • m-copter Level 1 Level 1 (0 points)
    Hi to everyone,
    had the same problems. When ever I started Safari I got this msvcr80.dll message.
    But I love Safari so I started to do some 'stupid' things. Uploading new dll, installing, deleting Safari, reinstalling, some hdd tools, but nothing helps.
    Now I got Safari back to live.
    I recently tried out Firefox but I deleted it some days ago. In some MS forums ref the dll I read something about probs concerning FF and this msvcr80. So I thought why not reinstalling FF. So I did.
    Safari is back to life, works fine.
    Thanks to FF.
    Greetings from rainy Germany
    Marcus
Previous 1 2 Next