Previous 1 2 Next 26 Replies Latest reply: Apr 8, 2010 12:56 AM by calandjess
Emery J Wilcox Level 1 Level 1 (10 points)
When launching Itunes, I receive a windows message saying:
"iTunes.exe has been set to run in compatibility mode for an older version of Windows.

For best result, turn off compatibility mode of iTunes before you open it."

If I push through the window by selecting "OK", iTunes launces and functions normally however the message is very annoying. Can someone advise on how to turn of compatibility mode? I acnnot find any help on this usbject.

thanks

Windows Vista
  • Niel Level 10 Level 10 (278,825 points)
    Click here and follow the instructions.

    (44536)
  • Emery J Wilcox Level 1 Level 1 (10 points)
    Niel -
    Thanks for the reply. It is odd however that compatibility mode is NOT checked. I tried checking and then unchecking however the issue remains. As mentioned before - iTunes works but the message is annoying. Any other suggestions???

    Thanks,

    emery
  • TroySheets Level 1 Level 1 (0 points)
    Same here. According to my checkboxes, it is NOT in compatibility mode, but every time I launch the program, I get the warning. I've searched everywhere, all I can find is people trying to fix the check boxes.

    Very frustrating that there is NO support.
  • Chris Crowder Level 1 Level 1 (0 points)
    I am running Windows 7 Ultimate 64-bit RTM and having the same issue. Everytime I start iTunes it says that it is running in compatability mode. Anyone know how to stop this?
  • Simalot Level 1 Level 1 (0 points)
    You will get the compatibility message if any of the boxes on the compatibility panel are selected. Please check if anything is selected there. I used to have to run with "Disable visual themes" and "Disable desktop composition" checked to keep from getting the black screen of iTunes.
  • Silvia_s Level 1 Level 1 (0 points)
    Same problem here, no real solution, but changing the name of itunes.exe to whattever ex: itunesss.exe the pop out don´t appear, but if I roll back to old name the pop out apear again.
  • RandomBehavior Level 1 Level 1 (0 points)
    Hi guys
    I found a solution that worked for me perfectly. Thanks to Silvia_s mentioning that changing the file name made iTunes open properly, that led me to believe that the compatibility mode was still being stored within the registry for the itunes.exe file.
    To find where Windows7 was storing this information, since googling didn't help, I set compatibility mode to a file that would be easy to track as a test file in the registry (since itunes.exe will have you looking at entries forever!).
    Anyway, long story short, I found at this location in the registry:

    HKEYCURRENTUSER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

    At that entry I found two files mentioned, the one I just set as a test file and behold.... itunes.exe! I deleted the itunes.exe from the key, fired up iTunes and NO MORE COMPATIBILITY MODE
    Hope this solution works for the rest of you. Thanks again Silvia_s for making me think more logically
    Again, this was a solution for Windows7. In other Windows versions you may find the compatibility mode settings / keys at different locations within the registry. If that's the case, I recommend just setting some test file to use compatibility mode and then searching for that within the registry to make finding the location easier. I used a file called combatfile.exe (any .exe will work, the specific naming is what helps) and then searched for it in regedit, knowing there was no other chance of combatfile.exe showing up anywhere else.
    Sorry I'm long winded
    Jason
  • jms667 Level 1 Level 1 (0 points)
    @RandomBehavior
    Thanks a lot ! I was annoyed with this issue for a few weeks ago. Now th message is gone. Thanks again.
  • cheeser83 Level 1 Level 1 (0 points)
    RandomBehavior:

    Worked perfectly! Thank you. This has been driving me nuts. Didn't even require a restart...
  • DWJohnson Level 1 Level 1 (0 points)
    I'm having the same problem with I tunes , but I refuse to go into the regestry and try to fix because I listened to microsoft just trying to Upgrade my pc to windows 7 last week and it ended up costing me a entire computer replacement, going into regestry crashed my pc and would not boot back up. Is I tunes getting ready to release a new version of I tunes to fix this issue? Because I listened ti what I thought was a tech support tech it cost me $ 800.00 in replacment costs.

    Thanks for your reply,
    Dean
  • Katrina S. Level 7 Level 7 (24,090 points)
    +going into regestry crashed my pc and would not boot back up.+

    Yikes! yeah stay out of there!
  • cheeser83 Level 1 Level 1 (0 points)
    You replaced the computer? You should have just formatted and reinstalled.

    But, the registry fix stated above did the trick for me and was super easy.
  • The hatter Level 9 Level 9 (60,795 points)
    Reset the CMOS if you really get stuck, make sure you have the latest BIOS, too. And for systems with Windows 7 pre-installed, wipe it clean first, there are bugs, crashes, problems and don't use a vendor supplied version, get retail or system builder instead and install that.

    I wouldn't call or listen to or call what you got "tech support."

    I have seen where a hard drive really had to be recertified and striped of partitions to work again.

    Windows 7 has its own new 100MB system recovery partition, but even so booting from the DVD should let you fix or repair a system.

    And by all means, USE the RESTORE Check Points, and make backup of the Registery before making alterations!!

    I have an iTunes library but I waited for 9.02, and not sure I even want iTunes again on or in my system with the way it behaves.
  • adamwood Level 1 Level 1 (0 points)
    that IS indeed the answer - thank you very much!!
Previous 1 2 Next