9 Replies Latest reply: Aug 29, 2009 9:16 PM by ericwusolo
blameitonmyblueeyes Level 1 Level 1
Hi. I know I read something similar to this before but now I can't find the topic. I went back 10 pages and didn't find a solution.
I am working with a 13" alum. MacBook 2.4GHz, OS X 10.5.7. Also using Safari 4.
My problem is that my wireless drops randomly. I have to completely exit Safari, wait about 10 seconds, and restart the program; wireless works again. In a 30 min period online, I have to do this about three times. It happens pretty frequently but not all the time. Not having this problem on any Windows based PCs, just the Mac. Wondering if anyone else has this specific problem or if there is a fix? Thanks.

Message was edited by: blameitonmyblueeyes

MacBook 2.4GHz, Mac OS X (10.5.7), Aluminum MacBook 2.4GHz
  • BAyorgs Level 1 Level 1
    I'm having the same problem, very frustrating. also on the macbook 13-in. PCs are having no problem with the connection, Mac keeps dropping out.
  • felipey Level 1 Level 1
    same problem for me.
    after last update air port is working randomly and when it works is SLOW!!!!!!!!
    next time I'll a couple of months for updates.
  • felipey Level 1 Level 1
    I came up with something.
    seen that airPort (macbook alu 2.4) kept dropping signal I tried to fix transmission ch. on w.router (previously ALWAYS set on auto)
    ...well now works again at full speed and no dropping or misconnection.
    possible that "AirPort Client 2009-001" (1.0) has such bug???
  • Luigi from Italy Level 1 Level 1
    Hello,
    I have the same issue. I have a Netgear wireless router with transmission channel set on "Auto".
    DHCP is disabled, all the IP addresses are manually selected.
    And everything works well most of the times...

    My sister's Acer laptop is stable connected, without any problem, while my MacBook keeps dropping the signal time to time, randomly.

    Please someone find a solution, I can't stand that my 1.200 € MacBook is not connected while my sister's much cheaper Acer works without any issue!

    Thanks.

    Luigi
  • GaryKing Level 1 Level 1
    I have this problem too. Anyone find a fix for this?
  • Level 6 Level 6
    Try setting your router to "g" instead of auto. I had this same problem after I did the OS update.
  • Luigi from Italy Level 1 Level 1
    Hello,
    I have contacted the Apple Support and they suggested to select the Channel 1, 6 or 11 on the Router Settings (no change on the mac settings).

    They said that the above indicated channels are the "preferred ones" for the Apple systems...

    I have followed their suggestion, in few weeks I will post the results of that setting.

    Ciao.

    Luigi
  • mrdude60 Level 1 Level 1
    Where do you find channel 1, 6 or 11? Where would you find the router settings? Is this something on the router itself or what?
  • ericwusolo Level 1 Level 1
    Try removing your battery for 30 seconds and put it back. I was one time advise by Apple. He said removing the battery actually resets the airport card. I just tried on on my uni macbook and it happens to work because I have been having this problem since upgrading to Snow Leopard. Hope it work for you.