Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Error creating a computer-to-computer network

Hello there.
I want to create a wireless computer-to computer network from my MacBook to share ethernet connection with iPod touch, but when I click OK it says: "There was an error creating your Computer-to-Computer network". Any ideas?

MacBook, Other OS

Posted on

Reply

Page content loaded

Aug 31, 2009 7:25 PM in response to Macintosser In response to Macintosser

First thing is go to system preferences. Go to Sharing. Go to Internet Sharing. Click where says"share you connection from" choice ethernet. You have to have ethernet to share internet with you ipod ITOUCH. Click the lock and type in your admin information. Click Airport where it says" to computer using". Now go to your ITOUCH and go to settings. Go the find a internet connection. It should work. I have not try this myself. You can always buy cheap WFI- net-GEAR thing plug in your ethernet to it. You should have WFI going up in 2-5 minutes. Good luck I hope it works out for you.

< Edited by Host >

Aug 31, 2009 7:25 PM

Reply Helpful

Sep 4, 2009 6:05 PM in response to Troy Dillon In response to Troy Dillon

I have been through the other posts and you can create the adhoc network using channels 36,40,44,48. This does not really help. As I what to connect MACENC software between my mac and iphone. IT worked perfectly on Leopard but now not on snow leopard.

Sep 4, 2009 6:05 PM

Reply Helpful

Sep 5, 2009 4:48 PM in response to Troy Dillon In response to Troy Dillon

Same problem: Immediately after installing Snow Leopard Airport failed to create a Network: +'There was an error creating a computer-to-computer Network'+. I'm now unable as previously to use Wi-Fi to sync with iPhone.

Has Apple acknowledged this problem? Where do we go to find out?

Sep 5, 2009 4:48 PM

Reply Helpful

Sep 7, 2009 11:28 PM in response to hebd In response to hebd

Guys this solution worked for me. I will repost: by mesagsx
http://discussions.apple.com/thread.jspa?messageID=10151807#10151807

I have a solution, and it worked for me today, which should make everyone here happy.

* Under airport menu, go to "open network preferences"
* Under "advanced" in the airport tab, click on "Require Administrator password to ... create computer-to-computer networks".
* click OK
* click apply
* under airport, create a network (using some unique SSID name, like blah1)
* under airport, disconnect from blah1
* go back to your airport prefs again (see above)
* uncheck that annoying option about requiring administrator password, etc...
* click OK
* click apply
* go to internet sharing and do your thing like you usually did before.


I'm guessing this is just a bug with a SETUID permission on an executable, now that this option has been added to snow leopard ... and the setting of that option, and subsequent unsetting of it is enough to get the setuid bits all correct.

Sep 7, 2009 11:28 PM

Reply Helpful

Sep 21, 2009 8:01 PM in response to Macintosser In response to Macintosser

I have an older Macbook Pro and still get the error message after trying everything on this post. My Sister on the other hand has a newer Macbook installed Snow Leopard from the same CD and has no problem making computer-to-computer networks?????
I need some help.

Sep 21, 2009 8:01 PM

Reply Helpful
User profile for user: Macintosser

Question: Error creating a computer-to-computer network