5 Replies Latest reply: Jun 17, 2009 8:13 AM by Jim Hall1
Jim Hall1 Level 2 Level 2 (470 points)
I'm not sure if this is an OS issue or a hardware issue, so I'm posting here first as it seems the logical place to start.

I have some data on a thumb drive sent to me by my son who is overseas (an audio diary). The drive was used on a Windows computer, my computer is an early 2009 Mac Mini. The drive when inserted into a usb slot has a small light that illuminates to tell me it's inserted properly.

The drive fails to appear on the desktop. It is not seen by Disk Utility or any other program including TechTool or Diskwarrior. When I remove it from the USB slot I get an error message saying that it was not put away properly.

Is there any way I can get it to mount on the desktop so I can extract the audio files? I'm assuming this is a Windows v Mac issue, but in the past I would at least get some sort of warning that at the least the disk was unrecognizable. In this case it appears that something sees the drive, but won't show it on the desktop.

Mac Mini 2.0, Mac OS X (10.5.6), 4 gigs ram
  • V.K. Level 9 Level 9 (56,130 points)
    sounds like the thumb drive is defective. or possibly something wrong with your USB port. it's a hardware problem either way. try using a different USB port. if that doesn't help try mounting in on a different computer. the fact that the drive is formatted in windows does not make any difference. in any event, disk utility should see it no matter what.
  • Jim Hall1 Level 2 Level 2 (470 points)
    Thanks for the quick suggestions.

    1. Tried other ports, no luck

    2. Tried another Mac, same problem. Don't see the drive, get the warning when I remove it. Disk Utility does not see it.
  • V.K. Level 9 Level 9 (56,130 points)
    if this happens on multiple computers the problem is definitely with the drive itself. as i said formatting makes no difference for the drive showing up in disk utility. sorry but the drive is dead.
  • Jim Hall1 Level 2 Level 2 (470 points)
    I'll give it a shot on a Windoze machine and see if I can get the files and then trash it and put the data back on a fresh drive.

    Will report back on my attempt.
  • Jim Hall1 Level 2 Level 2 (470 points)
    This is becoming a real mystery...

    The drive mounted fine on a Windoze machine (XP).

    I burned the file to a cd and tried opening the drive using XP running in Parallels on one of my Macs. Would not open.

    In any event I tossed the drive in the trash.