Previous 1 2 3 Next 42 Replies Latest reply: Sep 10, 2009 1:42 PM by David.
Touchedinthehead Level 1 (0 points)
I discovered a very annoying wifi problem with the new 3.0 OS. I can very easily connect to a wifi network, however, if my ipod loses the connection, it does not automatically reconnect. In fact it does not even see the network anymore. I have to manually connect by typing in the network name anytime it loses the connection. The connection is maintained fine while I actively use it, but if it drops because it is in standby mode for an extended time, it does not reconnect. I restored back to the previous OS and it reconnects just fine and sees the networks just fine, so this is indeed an OS 3.0 problem. Is anyone else experiencing this bug?

iPhone OS 3.0
  • applegenius18 Level 3 (890 points)
    Reset network settings.
  • luvlabs Level 4 (3,610 points)
    No problem seen here with 3.0 and WiFi. I'm curious, is this network not broadcasting its name?

    Also, some routers get touchy and you might want to restart your router.
  • Touchedinthehead Level 1 (0 points)
    Ok resetting the network settings in the Reset menu of the General settings seems to have done the trick. It's strange that I have never run into this problem in all the updates I have done before. It also seems like it would be reasonable for Apple to have coded in a network reset as a part of the update.
  • videogayme Level 1 (0 points)
    Just did my update to 3.0. My Wi-Fi connection is HORRIBLE. It seems to come and go and I am only 6 feet from the wireless N Linksys dual-radio router - WRT600N. Never had any trouble with previous connections. Can't even Google search!. Tried turning off and back on the iPod and Safari worked 1 time, then connection lost error again. Going to try and restore the entire iPod. So far, this is not a good use of $10 for the iPod touch. Only thing different is the search and a Voice Memos icon. (There is no mic on the iPod Touch - so no use for that.) Bummed out. I expect this from Sony and Microsoft and even Dell, but not from Apple.
  • videogayme Level 1 (0 points)
    Tried the Network reset first - no luck. 1st network access works then everything else is just a spinning icon until it times out: "Network unavailable. This application must have a network connection on first use. Please visit again when you are online."
  • videogayme Level 1 (0 points)
    Really weird stuff. The Weather Channel Application retreives up to date info right away from the internet over wi-fi. So I switch to Safari and I get "Cannot Open Page: Safari could not open the page because the server stopped responding."

    Ipod Touch 2nd gen. Less than a year old.

    Also - another unrelated observation - for 3.0, the screen goes dim much quicker than it used to.
  • videogayme Level 1 (0 points)
    Update: I turned off my Wireless N radio in my router and it seem to have solved my trouble. I am connecting to the internet now. My guess is the "find the best wi-fi" features of 3.0 need some work. I happen to not have any wireless N devices right now, so leaving off the N radio is OK, but NOT acceptable for a solution.
  • Nicetoknow Level 1 (10 points)
    Yes, I have the same WiFi problems. Last night I upgraded my iPod Touch to OS 3.0. Since then it does not automatically connect to my WiFi. I have to do it manually. It does however see the WiFi device and I can say 'connect'. However, the signal seems weaker (less stripes), once connected.
    Also my applications WiFinder and WiFiTracker ("could not proberly initialize the WiFi scanner..") do not work properly anymore.

    I will to reset my network settings on my iPod Touch ....... and YES this seems to solve the problem. Thanx.
  • KarlosGabriel Level 1 (0 points)
    I have the same problem.

    For me the solution are:

    activate DCHP server in my router.

  • luvlabs Level 4 (3,610 points)
    Your iPod can only work with the b/g mode wifi. You can leave the radio on and set to broadcast b/g/n. When you get ready to add a n enabled device, you won't have to change anything.
  • elmivy Level 1 (0 points)
    I have two iPod Touch 2nd generation. After I upgraded one to 3.0, that Touch had problems with wifi and the other had no problem. In my case, it would connect to my local Airport Extreme network but performance was either slow or so bad that Safari would say it could not connect. I reset network setting, cycled the power on the Airport box, powered off the Touch -- didn't help. When I looked at the Airport Utility I didn't see any problems. On the Wireless Clients chart, the two Touch's looked identical, but one worked and the other didn't. Log also looked the same for both working and non-working Touch. Via the Airport Utility, I restarted airport several times. At one point the Touch 3.0 wifi started working. I don't think it followed a change in the settings in the airport. It may have happened after an old G4 PowerBook went to sleep in the next room. Maybe it has to do with 802.11b/g issues. Or maybe it really was random. I have no confidence I know what caused it to start working.
  • shackleton1 Level 1 (0 points)
  • videogayme Level 1 (0 points)
    Thanks for the response, but I know the iPod only has b/g wireless. To clarify: when I turn on the second radio in my wireless N router, wrt600N, it causes interference and I can not get online. Apple appears to have added (at the behest of AT&T) an aggressive wi-fi feature that tries to use local wi-fi instead of their over-burdened 3G network to offload data traffic. It has the unfortunate side-effect of making my ipod Touch indecisive when trying to join my home network. When I turn off the second radio, the problem dissapears. I never had this issue before my upgrade. (Which I do not recommend to anyone with an ipod touch yet - no real benefit and only can cause issues.) Note: I did NOT restore my iPod as I previously said I was going to do. FYI.
  • pvieito Level 1 (0 points)
    I have the same problem I restarted de settings but it still doesn´t go. It´s horrible.
Previous 1 2 3 Next