Previous 1 2 3 Next 33 Replies Latest reply: Jun 30, 2009 5:48 AM by iTouch.user
msumurph Level 1 Level 1 (0 points)
Ever since upgrading to 3.0 today, my wifi hasn't been working.

I enter my WEP password in correctly, and eventually I get an error saying:

Unable to connect to network.


I tried resetting settings, networks, and rebooting several times. By the way, my wifi worked before on 2.2.1.

Is there something I'm missing? Maybe I should try a restore perhaps. I'm trying to save that for last as I just synced everything to my iPod.

Thanx guys.

iPod touch, iPhone OS 3.0
  • Tweekme Level 2 Level 2 (195 points)
    Same issue here. Tried Restore, no go, still an issue.

    Scott K.
  • Tomoyuki Nishino Level 1 Level 1 (0 points)
    I'm having same/similar issues.

    I got my iPod touch on Monday. It connected to my home and office networks fine. Today I updated it with 3.0 and I can no longer connect to my home network.

    • After updating to 3.0, I was able to connect fine to the network at work. I don't know what type of network they have.

    • my home wireless is quite old. D-Link DI-514.

    • my home computer is connected wirelessly, and is fine connecting to the internet.

    • I rebooted both my dsl modem and my wireless router.

    • I rebooted the touch.

    • I reset the network settings.

    • I can manually assign the IP for the ipod via the router (Static DHCP :-S) , and the ipod recognizes it. So it's communicating with the router.

    • I turned broadcasting on and turned MAC filtering off.

    here's where it gets interesting.

    • I turned on the web sharing on my home mac. The ipod touch can see the (default apache) web site on my mac. So somehow it's getting stuck trying to get beyond the wireless router to the WAN.

    • I tried to connect to google via IP, and I can't. My Mac can connect fine via the IP, so it's probably not DNS.

    • My exchange server synced my email once, and only once. I can't reproduce it, but I have my latest emails.

    I'm basically out of ideas. I'm going to bring it to work tomorrow and see if I can connect. That'll tell me if it's my home network's fault somehow...

    Anyone have any other ideas to try?

    thanks,
    -Tom
  • Tomoyuki Nishino Level 1 Level 1 (0 points)
    msumurph: After sleeping on it, I realized my problem's a bit different since I have evidence that I am actually connecting to the network; just unable to get past my router. I'll start a new thread. I'll post my results from my attempt at connecting to my office network here though in case it's useful.
  • luvlabs Level 4 Level 4 (3,610 points)
    The first thing to do when encountering these types of problems is to reset your network settings. Tap Settings > General > Reset > Reset Network Settings. When your iPod restarts, try logging back into your network.

    I doubt that Apple has changed much on logging onto a WEP encrypted network but there a few things you need to consider:

    1) for 48 bit encryption, your password must be 5 characters
    2) for 128 bit encryption, your password must be 13 characters

    Don't like those restrictions? Open your router controls up and write down the hex key (key 1) generated by your router in response to your password. Use the hex key in place of the password.

    The better thing to do is change your encryption to WPA/WPA2 personnel. You will need at least an 8 character password and your security level will be vastly better. You will use that new password (PSK) on all devices that log into the network.
  • Matthew Koller Level 1 Level 1 (25 points)
    I have the same problem. I tried all of the suggestions above with no luck. It says "safari could not open the page because the server stopped responding".

    My ibook can still connect wirelessly, though.
  • luvlabs Level 4 Level 4 (3,610 points)
    The fact of the matter is that your symptom is the same, the cause may be different. Try going to Settings > WiFi and tapping on the blue > next to your network name. You should get the following information: your IP address, your subnet mask, your router IP, and your DNS IP. If your IP address starts with 169.x.x.x your network is not providing you with the information your iPod needs to connect to the internet.

    If that is the case, you need to look at your network settings. Router? DHCP? Encryption used?
  • msumurph Level 1 Level 1 (0 points)
    I had the same problem, but I just fixed it moments ago.

    You have to go into your router, by going to 192.168.2.1, or whatever it is. This allows you to change your settings, etc. You go to "blocked devices", and your iPod touch should be in there. Then you "unblock" it, and it should work.

    This has worked for me, and hopefully will be the fix.
  • Tomoyuki Nishino Level 1 Level 1 (0 points)
    I'm in my office and tested my connectivity. I can connect fine here but not at home, so my problem seems to be my home router. Unfortunately I didn't have a "blocked devices" setting on my router so I still don't know why it's blocking the touch's communication to the WAN; I'll check if there's some other blocking implementation. I'll have to do more digging tonight. I wish the router had a better logging/debugging mechanism...
  • ZombieJesus Level 1 Level 1 (0 points)
    Seconded. I really am having trouble with this.

    I'm using a 3G iPhone, and upgraded to 3.0 yesterday. Since then I've been unable to join any wifi network at all. I've tried.

    -Resetting my network settings
    -reinstalling 3.0
    -full reset
    -full restore

    Every single time I click on a network, it whirls a bit, then tells me "unable to join the network "---" " Signal strength is also MUCH lower, the router right beside me now is only at 1 bar despite being less than 5 feet away.

    I have messed with my router countless times, changing security protocols, passwords, block devices, everything. Nothing changes. My roommates' iMac is connected to my network fine, and I can't join any other networks that are nearby that I used to be able to piggyback on.

    So this is definitely an Apple problem. If anyone knows what to do with it, (as long as you don't tell me to reset the **** phone again), please let me know. This is reaaaally frustrating.
  • Matthew Koller Level 1 Level 1 (25 points)
    I don't have a blocked devices setting either....:(
  • SilvasRW Level 1 Level 1 (0 points)
    Yeah, this worked for me, too--Thnx!

    I use MAC filtering--and my iPod was already in the "Allowed" list--but after the 3.0 upgrade, the router saw it as a different device than the one on the allowed list--and so, automatically added it to my blocked list. So I had to move the blocked device to the allowed list.

    Looking deeper . . . 3.0 didn't change the MAC address--but it does appear to have changed the iPod's broadcasted device name--My router previously saw it as "iPod" (despite its actual name always being "SilvasRW's iPod")--but now sees it as "SilvasRWs-iPod". Seems my (2WIRE) router's MAC filtering is also sensitive to device names--To fully match against the allowed list, both the MAC address and the device name must match what was previously in the list.

    For those who messing with their router's MAC filtering isn't working, I wonder if they want to try simply renaming their iPod to "iPod" (by clicking the iPod name in iTunes)--to match the pre-3.0 broadcast name . . . ?
  • Charles Minow Level 6 Level 6 (9,190 points)
    Hi-

    Tomoyuki Nishino wrote:
    msumurph: After sleeping on it, I realized my problem's a bit different since I have evidence that I am actually connecting to the network; just unable to get past my router. I'll start a new thread.


    Interesting. I had a similar experience: I could connect at work and surf the net. At home, I was connecting to the network, could ping the iPod from another computer, even surf web pages hosted on a computer on the LAN, but wasn't able to get beyond my router.

    After going through all the settings, I noticed that I had two DNS servers listed in my networking setting on the iPod, separated by a space. But, once I removed either one of the DNS IP addresses, I could connect right away. And re-entering a second DNS server's address prevented me from getting out of my LAN.

    Now, I can't swear that it worked with those before, but I'm pretty sure I've browsed outside my LAN from home before (mostly I use the iPod wireless when I'm out of the house at public hotspots, hotels, relatives' houses, places like that).

    So, definitely taking a close look at the network settings is a good step.

    charlie
  • Tomoyuki Nishino Level 1 Level 1 (0 points)
    Hi Charlie,

    thanks for the info. I tried, but to no avail. Following the chain of thought I also tried using the DNS from work and tried entering yahoo and google by IP. No luck.

    I've downloaded Ping Lite from the App store (dl'd it from the office; mochasoft.dk). It has traceroute so checked where things are actually getting stuck. It's looking like it's getting past my router and is going pretty far up the chain. But it's getting stuck at random places -- totally inconsistent over several trials.

    But then, when I traceroute from my mac (which sees web pages fine), I can't see anything past my router. No idea what's going on...

    thanks for the idea, though.

    -tom
  • CactusChef Level 1 Level 1 (0 points)
    Add one more person to this list (me)... I'm pretty computer savvy and I knew something had to be wrong with this upgrade when I couldn't figure out what was wrong.

    Mine shows it's connected (with the bars) but it doesn't find the IP... other computers in house work though.

    Before I scoped out the message boards (which I almost always do as a last resort) I did the following multiple time:

    I reset the router and modem
    Reformatted back to 2.21
    Reverted to last backup
    Reinstalled 3.0
    Resynced music and videos again (big pain)
    Downloaded 3.0 again
    Checked the MAC address filtering
    Entered the 128 encryption key and passcode

    And even with this restore, it deleted all my Apps.

    ***** to see this many with the same problem; the more people having the same issue its a faster chance that Apple should resolve this issue (one that shouldn't have happened in the first place).
Previous 1 2 3 Next