Previous 1 2 3 Next 33 Replies Latest reply: Jun 30, 2009 5:48 AM by iTouch.user Go to original post
  • mgjbond007 Level 1 (0 points)
    Same Exact Problem. Wi-Fi connects for a few minutes and then stops working unless I reset the device, power down, reset network settings, etc etc...

    This is lame. Wi-Fi worked perfectly before the 3.0 upgrade. Is there a way to downgrade???
  • CactusChef Level 1 (0 points)
    I tried downgrading 3 times; I don't think Apple will let you cause it flashes your software preventing you from going back. When I tried it still said I was on 3.0; I tried downgrading to 2.21, didn't help whatsoever.

    I think Apple does this stupid stuff only because of jailbreaking which definitely is not loyal for their customers who don't want to jailbreak (cause they'll [hackers] find a way around it soon).

    Wasted my time dumping and resynching all my songs; maybe wait until a patch is released to save you the effort (unless we're missing something that we don't know about, but I doubt it).
  • iPoggioZ Level 1 (0 points)
    Hi all,
    the problem is for sure the OS 3 .
    Two days ago I bought the OS3 and it worked well for 24 hours !!!! Yesterday night my iPod Touch just stopped to join any wireless network. I tried with Full Reset and Full restore but nothing.
    Finally I downgrade my firmware to 2.2.1 and now wi-fi is perfect as it was before.
    I think that OS 3 has amazing new features but maybe we have to wait the OS 3.1 to have everything working.

  • tonefox Level 6 (9,055 points)
    Suffering the same problems, after eight hours of trying everything up to and including a total restore, I cracked it. I don't know why it worked, but it was an instant cure:

    Try simply changing the name of the wireless network in your router settings.
  • fjsdofnsjgv Level 1 (10 points)
    I had the same problem. After installing the new OS 3 for my iPod Touch, I was surfing the internet, looking up vids on youtube, and my wifi worked great. Then, about 6 hours after I installed the new OS, my wifi signal disappeared and I went into settings and my wifi "could not be found". I have tried everything, reset the network, It finds the wifi network, it shows the bars but I can not go on safari, itunes, app store, weather, stocks, any app that needs an internet connection.
  • fjsdofnsjgv Level 1 (10 points)
    Now this is is 1:00pm and my WiFi is working fine now...I can go on Mail, Youtube, etc...And I didn't change the settings or anything!! I have ATT as my internet provider, has anyone else experienced this?
  • hargloub Level 1 (0 points)
    Hello all
    same for me at home, on a 1st and on a 2nd generation itouches upgraded on 3.0 os. Wifi was perfectly working, nothing else than this ** 3.0 os changed here, it's the only cause of this issue. Please Apple guys, I'm on vacation on tuesday, I need ahaving my iTouchs 100 % ready ! Hurry hurry to release the 3.1 version.
  • Kevin Emery Level 1 (25 points)
    3.0 really hosed up the Wi-Fi. Every time I turned mine on, it would search for a Wi-Fi signal. My work has free Wi-Fi guest access. I had to use Auto Wi-Fi from the iTunes store (my company makes you log in again if you've been off for more than a couple minutes.) After the 3.0 upgrade, the only way to get onto the network is to open up Safari and try to connect. Then I have to do the whole logging in thing every time. (I thought 3.0 was supposed to remember your Wi-Fi login info) My Auto Wi-Fi app doesn't work anymore because it can't find a signal.

    But, when I come home and turn it on, it finds my home network right away and connects. Not sure what's going on.
  • Chris Wainscott Level 1 (5 points)
    Renaming the SSID on my home network fixed this problem for me.
  • sk7 Level 1 (0 points)
    After updating to 3.0 I can't use WEP on the WiFi connection any more. It no longer recognises the 26-char HEX key. In fact, it now just prompts for the passphrase (which I don't have). Tried reconfiguring my router to use a passphrase and managed to connect the iPod, but Safari/Mail etc still don't work.

    Seems better if I completely disable Wireless security, but still some apps (e.g. weather, stocks) are very slow.

    Hope a patch to 3.0 is available soon because this really is not good enough. The WEP connection was a bit ropey on 2.2.1 but at least it worked eventually.
  • luvlabs Level 4 (3,610 points)
    When I first installed 3.0 I got a bit of a wonky WiFi signal but no problems connecting. I did a reset later in the day for an unrelated problem and WiFi is back and running just like it did in the past. I've tried to break WiFi to see if I could duplicate any of the problems the others are having, but no luck -it still is rock solid.

    So to all of you others, do a restart, or reset, or even a restore before you start messing/complaining too much about WiFi. I am positive things change with 3.0, but what, I don't know.

    WEP encryption with the touch has been an iffy thing for a long time. Is your router capable of doing WPA-psk or WPA2-psk? If so, you a better off making the change now then trying to get WEP working.

    With WEP and the touch, the passphrase has to be an exact length based on the strength of the encryption. It must be either 5 characters or 13 characters (128 bit). Using the hex key (key 1) for your pass phrase should still work, however.
  • Kevin Emery Level 1 (25 points)
    Well, I have done a lot of troubleshooting before I 'messed/complained'. The problem appears to be in how the software is handling networks. It handles my home one just fine and it used to handle the one at work fine until upgraded to 3.0.
  • iPoggioZ Level 1 (0 points)
    Hi , sorry but I think that in this forum we are not completely idiots.
    Before I complained I did :
    1) Reset Network configuration
    2) Reset iPOD
    3) Full firmware restore ( iPod brand new , selecting new iPod when iTunes is asking you for the restore )

    Obviously I restarted the device several times.

    Finally I downgraded my firmware to 2.2.1 and magically my wireless is BACK .. it's working just fine.

    This is OS 3 issue ... no doubt that Apple has to sort out ASAP.


  • khenne Level 1 (0 points)
    I had a decrease also from 3 bars to one bar on my iTouch WiFi signal strength post OS 3.0 update. I have a router that is "N" but also can broadcast in "G" and "B". I use wireless for a Dell laptop that still has an older "G" card, when I changed my router settings from mixed "G", "B", and "N" to "G" and "B" only suddenly I have 3 bars of speedy signal strength again anywhere in my house on the iTouch. So...I thing the new OS 3.0 gets jammed up when it detects a mixed "G" and "N" signal, which many Hotspots also have. So this is a temporary fix for your home network until OS 3.1 comes out.

    I also am one of the many folks waiting for the 2.6 (OS3.0 compatible) update for WiFITracker App. One of the few apps that allows you to connect directly at a better signal strength to networks the built in App can't detect.
  • sk7 Level 1 (0 points)
    Thanks for the reply. Have switched to WPA and it is now fine (and has made me realise just how bad WEP was on the iPod). Just leaves me with a Philips Streamium Stereo (WEP only) that won't work on the network now, but since getting the 32GB touch I've generally just plugged that into it anyway.

    Thanks for the help.