Previous 1 2 3 Next 32 Replies Latest reply: Aug 27, 2009 7:58 PM by Joeswell
Scott Link Level 1 Level 1 (5 points)
Have multiple Macs running 10.5.7 w/latest software update. Each trying to use the same web application. Web app downloads a .jnlp file. For most Macs, it launches Java and life is good. On a lone Mac (so far), the .jnlp file downloads, but is opened by TextEdit. Check File Info, and it's associated with TextEdit, so there's the culprit. On the working Macs, the file is associated with Java Web So, I figured I'd change the association on the Mac that's broken, but I can't find Java Web It doesn't show up in Spotlight, so I use the locate command in Terminal and find it listed as being found in /Applications/Java. This folder does not exist on any of the Macs in this scenario. Where is it?! How do I fix the association for .jnlp files to be Java Web


MacBook, Mac OS X (10.5.7)
  • Tom Gewecke Level 9 Level 9 (74,790 points)
    I can't find Java Web

    It should be in Applications/Utilities/Java
  • Scott Link Level 1 Level 1 (5 points)
    Not there, either. In /Applications/Utilities, I did find Java Launched that, poked around in it, but didn't find anything that looked like it might provide some help.
  • nerowolfe Level 6 Level 6 (13,070 points)
    It seems to be part of the Developer tools on my box.

    /Developer/Library/Xcode/Project\ Templates/Java/Java\ Web\ Start\ Application/src/

    It apparently needs to be compiled.

    I don't know if it is a standard app already compiled unless some other app installed it separately.
  • Francine Schwieder Level 6 Level 6 (19,040 points)
    Don't have Xcode installed on this startup drive, did a search (Command-f, select this drive, Kind is Applications, + Other->System Files: include) and it shows up here:

    /System/Library/CoreServices/Java Web

    Looks like a standard part of the OS install. The executable in the bundle has a date modified of May 25, 2009. This startup drive is fully updated.

  • jposner Level 1 Level 1 (0 points)
    I have the same problem. After running the latest Java update, Java Web Start is gone. I have Xcode installed on my machine, but still don't have Java Web Start anywhere on my drive.

    I attempted to restore it to /Applications/Utilities/Java using Time Machine, but when I launched it, it merely crashed.

    I understand that part of the Java update was to patch a vulnerability that could be exploited through Java applications launched from the web, but I was under the impression that there was a fix that didn't simply involve disabling Java Web Start. Is there a new version of Java Web Start out there that doesn't crash with the new Java update? Alternately, is there a way to run a jnlp file without a working version of Java Web Start?

    I have a program that I absolutely need to have running in the next 30 minutes -- which doesn't give me enough time to roll back the whole update. Is it too much to expect Apple to fix what they broke with this update?
  • apex1976 Level 1 Level 1 (0 points)
    Same problem here! After "Java Update 4" installation error the whole Java folder disappeared.

    Could fix by it manually downloading and installing "Update 4".
    Make sure your web browsers are closed, when installation starts!

    Message was edited by: apex1976
  • Scott Link Level 1 Level 1 (5 points)
    You beat me to the punch. I found it in the same place using System Profiler and scanning the Applications listing. I think I'm going to have the user of the broken Mac try a software update first. I have a sneaking suspicion he's not on the latest and this problem may have existed for a while, but didn't manifest itself until we started using an app w/jnlp files. If that doesn't fix the file association, I'll walk him through making the association in Finder.
  • jposner Level 1 Level 1 (0 points)
    In my case, the problem popped up with a jnlp file I've been running every business day for the last 3 years or so. Apple has broken it with Java updates before, but never like this.

    Using the version in the /System/Library/CoreServices got it to launch, but it hung right away, rendering it useless.

    Like I said, I understand that the security issues with web launched apps needed to be addressed, but disabling web launched apps entirely seems like overkill when Apple has trailed substantially behind Sun in patching a well known security flaw. Anyone who runs jnlp apps from an unknown source gets what they deserve, but please don't punish those of us who know the source of our apps.
  • acoluzzi Level 1 Level 1 (0 points)
    Reinstalling the Java Update did not get my Java folder back. I'm toast without my Java Web Start. Anyone else have ideas on how to fix this? Thanks.
  • Martin M Level 1 Level 1 (10 points)
    I've got the same problem. My JNLP files open in TextEdit. Java Web Start has gone missing from the Applications -> Utilities folder after I upgraded to the latest Java. In fact, the entire folder is gone. All that remains is the Java Preferences application.

    When I go to associate the JNLP file with javaws (System/Library/Frameworks/JavaVM.framework/Versions/A/Resources/Deploy.bundle/ Contents/MacOS) it is not seen as an application.

    So where has this function gone? I've looked through Safari 4.01, but have found nothing. And it doesn't appear to have been incorporated into the Java Preferences app. The javaws app that I noted above is the only thing I can think that might be related, but I cannot access it.

    Any help would be appreciated.
  • Scott Link Level 1 Level 1 (5 points)
    acoluzzi, would you be willing to try the following?

    On a .jnlp file you're trying to use Java Web Start on, change the "Open with:" to /System/CoreServices/Java Web Start. That's what appears to be opening the .jnlp files I download on my Mac. I'm assuming your .jnlp files are being opened by TextEdit, or some other app...

    An unusual request, I suppose. I was going to walk my user through these steps, but he's not available until Sunday.
  • Martin M Level 1 Level 1 (10 points)
    I tried this and it worked perfectly. Thanks!
  • acoluzzi Level 1 Level 1 (0 points)
    Thanks so much, that works great and gets me up and running.
  • churchorgan Level 1 Level 1 (0 points)
    After installing the Java update, Mail and Safari crash on launch. This is extremely frustrating!! In fact, I cannot get any WebKit-based browser to launch, including iCab.
Previous 1 2 3 Next